Web domain redirect config

Discussion in 'Installation/Configuration' started by Dvago, Dec 23, 2019.

Tags:
  1. Dvago

    Dvago New Member

    Good afternoon,

    I'm reaching you out as during these days I had few issues with my mail server which uses the last supported version of ISPConfig 3 that supports Centos 6 (.14p2).

    I've recently installed the latest version of Roundcube following the tutorial at this URL https://www.howtoforge.com/install-roundcube-webmail-on-ispconfig-3-server-with-centos-6 (I've used the latest version instead of the one proposed).

    It was all working but I was a bit confused about the main page displayed by httpd, it was displaying /var/www/httpd rather than the one proposed by ISPConfig so I tried to set up the redirect to /roundcube in order to make the user accessing the webmail client directly.
    After this change via the ISPConfig panel sites > web domain > redirect the webmail panel disappeared completely, it does the redirect [R,L] to /roundcube but I get a 403 ISPConfig themed page.

    I then tried to revert the change via the panel, removing the value of the Path and setting up the first dropdown (type of redirect) to No Redirect but nothing changes, I've tried to restart httpd few times but I have no clue what kind of config is using and why /roundcube is not available anymore.

    Thanks in advance for your support
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. Dvago

    Dvago New Member

    Thanks Taleman,

    - ispconfig: 3.1.14p2
    - os: CentOS release 6.10 (Final)
    - kernel: 2.6.32-431.1.2.0.1.el6.x86_64
    Output of the report (note the php command still stuck for minutes)
    ##### SERVER #####
    IP-address (as per hostname): [localhost]
    IP-address(es) (as per ifconfig): ***.***.***.***, ***.***.***.***
    [WARN] ip addresses from hostname differ from ifconfig output. Please check your ip settings.

    Email
    - use Dovecot
    (email seems working fine)

    Web server
    - use Apache
    (see error_log.txt)

    Just to add

    this is the version of installed PHP:
    PHP 5.6.40 (cli) (built: Dec 17 2019 17:19:45)
    Copyright (c) 1997-2016 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies​

    Output of the server.sh is:
    # /usr/local/ispconfig/server/server.sh


    finished. ​
     

    Attached Files:

    Last edited: Dec 23, 2019
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    That report is strange. It should have lots more info.
    Maybe the new Roundcube version is not supported by ISPConfig on CentOS 6?
    Have you considered moving to a more recent OS, there is Migration Tool that helps in migrating your data from old server to new.
     
  5. Dvago

    Dvago New Member

    Thanks for your reply,

    I've seen a link within the ISPConfig saying "os upgrade" but I'm a bit too scared to lose something, unfortunately, I don't have much experience to solve bigger issues, I've inherited this server a few years ago and it could be really tricky to deal with it if anything more substantial happens
     
  6. Dvago

    Dvago New Member

    Keeping up with the topic, this morning I received a ton of alerts via email saying:
    ERROR - httpd is down! Rescue will not help!
    WARNING - Clearing semaphores table for user apache.

    Please see in attachment further error logs:
     

    Attached Files:

  7. till

    till Super Moderator Staff Member ISPConfig Developer

    according to the log file, you must have replaced an SSL certificate or SSL certificate key and the key that is used now does not match the certificate and this causes apache to fail.
     
  8. Dvago

    Dvago New Member

    Might it be something coming from the updater, at the step of regenerating the SSL certificate? I've tried to regenerate it using the following steps but the error log still showing the same messages

    openssl genrsa -des3 -out [mydomain].key 1024
    openssl req -new -x509 -nodes -sha1 -days 365 -key[mydomain].key -out [mydomain].crt
    openssl rsa -in [mydomain].key -out [mydomain].key
    chmod 400 [mydomain].key

    and I changed the entries of the related .vhost to follow the new files
     
  9. Dvago

    Dvago New Member

    As per the list of command above, I regenerated the ispserver.key and .crt files and Apache restarted correctly. I'm still not sure which file to touch to remove the redirect as per the original question, the web panel doesn't seem to reset the "no redirect" option
     
  10. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    If the redirect setting in question has been removed, you could try Tools > Resync > Websites to regenerate vhost config. If the redirect is still in effect, it is probably remembered by your browser - try restarting your browser, or clear the cache.
     

Share This Page