Web Access for ISPConfig

Discussion in 'Installation/Configuration' started by dargx001, Oct 2, 2008.

  1. dargx001

    dargx001 New Member

    I would like to be able to access ISPConfigs Admin Web Interface from IP Addresses that are out side of my network, what do I need to do? When I access it from inside my network everything works fine, but I would like to have access to it when I am at school and I can't figure that out. I've gone into my various configs like httpd.conf, system-config-httpd.conf, and httpd.conf for ISPConfig. Listen is set on the httpd.conf for port 81 which is the port I have to ad to the url. What do I need to do to allow remote web access.
     
  2. AcidKat

    AcidKat New Member

    make sure that port 81 is being forwarded in the router
    let me know if that doesnt work and ill think of another answer that might work for ya.
     
  3. dargx001

    dargx001 New Member

    81 is forwarded through the router. Sorry I should have said that earlier. I've added 192.168.1.136:81 to my hosts file as well. Do I need to set the bind address in the Ispconfig version of httpd.conf. Also should I have port 81 set to listen in the same file. I didn't think I should set that in my actual apache system-config-httpd.conf.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Make sure that your ISP doesn't block port 81.
     
  5. dargx001

    dargx001 New Member

    They don't I already tried that one. I called and asked them and just to make sure I had apache listen on there then I changed it back once it worked.
     
  6. AcidKat

    AcidKat New Member

    id say it has to be a firewall in a router or modem. check every peice of equipment from your server going out to the internet.
    ill bet a beer on it.
     
  7. dargx001

    dargx001 New Member

    Ok I'll check all the equipment and the configs on my switch and router. I'll let you know how that goes.
     
  8. dargx001

    dargx001 New Member

    Ok so I've checked all my configs. Nothing should be blocking access to it. Like I said earlier I can access it with no problem inside my network, but outside access is my problem. I made sure the firewall was off on my box since I have the ISPConfig firewall, and I made sure that port 81 was on the exceptions list. My router is forwarding port 81, also I've added 192.168.1.136:81 to my hosts list like I've done with apache. Still I can't access it from outside my network. Is there a specific configuration I need to look at in my ispconfig/httpd.conf file. Also maybe this could help you guys out a bit. When I type in http://192.168.1.136:81 into my url bar to access the interface I get this.

    Code:
    Bad Request
    Your browser sent a request that this server could not understand.
    
    Reason: You're speaking plain HTTP to an SSL-enabled server port.
    Instead use the HTTPS scheme to access this URL, please.
    
        Hint: https://shadow.server.com:81/
    I'm not sure if that helps, but I'm not sure what to do. Though when I type https://192.168.1.136:81 it goes right to the ISPConfig login screen.
     
  9. falko

    falko Super Moderator ISPConfig Developer

    You must use HTTPS instead of HTTP to access ISPConfig.
     
  10. dargx001

    dargx001 New Member

    Yeah I already knew that since that has been how I've accessed it before. I was hoping that someone could tell if it had anything to do with the fact that it says https://shadow.server.com. I thought that could be the problem, but I don't know where to change that since I don't use that domain name to login to the rest of my server. Maybe this could also be of some help.

    Code:
    15:29:13 [[email protected] ~]# netstat -nal | grep -i 81
    tcp        0      0 0.0.0.0:81                  0.0.0.0:*                   LISTEN
    
    Here is what my eth0 looks like.

    Code:
    eth0      Link encap:Ethernet  HWaddr 00:40:2B:77:72:7D
              inet addr:192.168.1.136  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::240:2bff:fe77:727d/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:17702 errors:0 dropped:0 overruns:0 frame:0
              TX packets:6296 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:2797505 (2.6 MiB)  TX bytes:2192131 (2.0 MiB)
    
    Also I attached a portion of my ISPConfig/httpd.conf so you could see what I've got so far. Just keep in mind that is only the portion that I think would be important.
     

    Attached Files:

    Last edited: Oct 5, 2008
  11. CrossWind

    CrossWind New Member

  12. dargx001

    dargx001 New Member

    I've tried doing that, but every time it comes back with page cannot be displayed. When I'm on my network at home, where my server is, either the network address of my server or my external IP work fine, but when I'm elsewhere like at school the external IP won't work it just shows up as page cannot be displayed. That is why I included all the info in the last post.
     
  13. CrossWind

    CrossWind New Member

    try changing the bindaddress to your external ip... if that doesnt help.
    i'm out of ideas..
    most common would be that the ports are not forwarded as they should, but you already said they are so.....
    no clue.
     
  14. falko

    falko Super Moderator ISPConfig Developer

    Please change or comment out the ServerName in /root/ispconfig/httpd/conf/httpd.conf and restart ISPConfig.
     
  15. dargx001

    dargx001 New Member

    Ok well I've tried commenting out the server line in root/ispconfig/httpd/conf/httpd.conf, and finally I've just changed it to the server name that I have in my apache config. Also I adjusted the listen port to listen to th network address. Here is my current netstat.
    Code:
    09:40:02 [[email protected] /etc/httpd/conf.d]# netstat -nal | grep -i 192.168.1.136
    tcp        0      0 192.168.1.136:81            0.0.0.0:*                   LISTEN
    
    I still get the whole message about how the page cannot be displayed. I've restarted my whole server and just the ispconfig_server. Would it just be easier to uninstall and then reinstall ispconfig.
     
  16. falko

    falko Super Moderator ISPConfig Developer

    Sounds like a firewall issue. PPlease check your router settings again.
     

Share This Page