WARNING: yum overwriting postfix

Discussion in 'Installation/Configuration' started by mike_p, Apr 17, 2010.

  1. mike_p

    mike_p Member

    WARNING: yum overwriting postfix (SOLVED!!)

    Having fought for many days to configure my perfect server, I found that the nightly yum update had overwritten my special (ie Falko) version of Postfix.

    To sort out the resulting problems I had to uninstall all versions of Postfix and reinstall from my locallly built RPM. I then had to uninstall ISPconfig3, delete the dbispconfig database and install ISPconfig3 again.

    Hopefully to prevent this happening again the solution is to edit /etc/yum.conf and in the [main] section add the line 'exclude="postfix"' so that yum doesn't try an upgrade agan.

    Has anyone had the same problem?
    Can anyone confirm this is correct?
    Last edited: Apr 20, 2010
  2. Doug G

    Doug G Member

    I had this problem with CentOS, but on my recent Fedora 12 server it's no longer an issue, postfix is built with mysql support in the Fedora repos.

    One thing I didn't try but thought about was doing a yum --nogpgcheck localinstall <custom postfix rpm> thinking that might stop yum from updating from the repos. But since I went to Fedora it's moot, and I never tried that solution.
  3. mike_p

    mike_p Member

    That didn't work. First thing this morning I checked the mail logs etc and found Postfix errors (eg "fatal: unsupported dictionary type: mysql")

    Does anyone have any solution?

    the good new is that now that I have discovered why it broke, I don't have to uninstall/reinstall IPSConfig.
    Now I just run:

    cp /etc/postfix/main.cf /etc/postfix/main.cf.sql   # save the good version of the config file
    /etc/init.d/killall                # stop all services 
    yum remove postfix
    cd /usr/src/redhat/RPMS/x86_64
    rpm -ivh postfix-2.3.3-2.1.x86_64.rpm
    cp /etc/postfix/main.cf.sql /etc/postfix/main.cf   # restore the good version of the config file
    then go for a reboot to restart all services

    At a guess I could get away with just stopping postfix and restarting after the reinstal instead of a reboot, but a reboot on this server only takes less than two minutes!
    Last edited: Apr 18, 2010
  4. mike_p

    mike_p Member

    problem solved.

    the syntax for the 'exclude' line in yum should be
    While researching this I was interested to see that the CentOSPlus repository apparently contains postfix rpms compiled with mysql support.

    Anyone who wants to give that a go should follow the instructions here:

    If that version works correctly, perhaps "the perfect server" Howto could be rewritten to enable the CetosPlus repository and avoid having to rebuild postfix?

Share This Page