Warning: service ftpd not running

Discussion in 'Server Operation' started by edge, Nov 18, 2006.

  1. edge

    edge Active Member Moderator

    Hmm for some reason ftpd stopped working at 23:59:04 on my server today (till now I've never had this problem!)

    This is a small part of the syslog file:
    Code:
    Nov 17 23:59:03 host /USR/SBIN/CRON[8644]: (root) CMD (/root/ispconfig/php/php /root/ispconfig/scripts/shell/ftp_logs.php &> /dev/null)
    Nov 17 23:59:04 host proftpd[18452]: localhost - ProFTPD killed (signal 15) 
    Nov 17 23:59:04 host proftpd[18452]: localhost - ProFTPD 1.2.10 standalone mode SHUTDOWN 
    Nov 17 23:59:04 host proftpd[8760]: localhost - Failed binding to 0.0.0.0, port 21: Address already in use 
    Nov 17 23:59:04 host proftpd[8760]: localhost - Check the ServerType directive to ensure you are configured correctly. 
    Anyone here who might know why this (suddenly today) started to happen?

    Again.. This is a first time for ftpd to shutdown like this in about 6 months!
     
    Last edited: Nov 18, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    It happened when ISPConfig tried to generate the FTP traffic statistics, but I'm not sure why. Maybe there was an active FTP session so that ProFTPd wasn't shut down fast enough when a new ProFTPd instance was already starting so that both collided...
     
  3. edge

    edge Active Member Moderator

    I'll keep my eye on it. I needed to start proftpd by hand to get it up again !
     
  4. falko

    falko Super Moderator ISPConfig Developer

  5. edge

    edge Active Member Moderator

    Nice one falko!

    I did not know about the "specify an action in ISPConfig's monitoring section" option!
    I've got it set now as a backup.
     

Share This Page