WARNING - No init script, we quit here.

Discussion in 'General' started by jnewman67, Jan 4, 2022.

  1. jnewman67

    jnewman67 Member HowtoForge Supporter

    Perfect Server CentOS 8, ISPConfig 3.2.6

    Anyone seen this email message before? I never have, and I think it may have come from my attempt to import a MySql export from phpmyadmin from one system into my current system - both ISPConfig systems. The import failed with an error message that I quickly forgot because I switched to the command line and imported the database without an issue. I then noticed this in my inbox 30 minutes later.

    Just curious, haven't dug more into it yet.

    thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Either apache or nginx on this system may be started and working but the service is not enabled in systemd, so systemctl command does not return it as valid enabled service when ISPConfig queries systemd, use either:

    systemctl enable httpd

    or

    systemctl enable nginx

    to enable the web server service on Centos, depending on the web server software you use.
     
  3. jnewman67

    jnewman67 Member HowtoForge Supporter

    thanks for the response.
    i'm was pretty sure it was enabled, so i ran systemctl with no options, paged down till i found this:
    Code:
    httpd.service                                   loaded active running   The Apache HTTP Server
    so i think that means it's already enabled. also, i don't have to start the service manually after a reboot, if that helps verify it.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run the command:

    systemctl is-enabled httpd

    and post the result.
     
  5. jnewman67

    jnewman67 Member HowtoForge Supporter

    it shows "enabled" - that's actually all it responded

    thanks.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, then you must check when this issue happens again so we can narrow down which service is causing it. MySQL is not restarted by ispconfig, so it can not cause that error.
     
  7. jnewman67

    jnewman67 Member HowtoForge Supporter

    will do. thanks
     

Share This Page