Warning: mysql_connect()

Discussion in 'General' started by AsDsL, Feb 2, 2009.

  1. AsDsL

    AsDsL New Member

    Today my Server shows this error when I try to log in.
    how may fix it

    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:77) in /home/admispconfig/ispconfig/web/login/login.php on line 62
    Last edited: Feb 2, 2009
  2. Turbanator

    Turbanator Member HowtoForge Supporter

    this just happened to me too, and it's affecting SMTP traffic as well, cannot send email. Restarted (old windows trick), but no good. running Fedora 9. If you can, you should edit the title of your post so that it shows the severity of not being able to login to ispconfig and SMTP is down as well. I'm still testing if I can recieve emails.

    I went ahead and created a new thread for this so the title describes more of the problem, at least my problem...not sure if your email sare working or not or what distro you're running.
    Last edited: Feb 2, 2009
  3. Turbanator

    Turbanator Member HowtoForge Supporter

    ok not sure how or why this happened but it's fixed.

    1st this is to doubcheck that your mysql password for ispconfig is correct.

    If it's correct (or not), I suggest then going to mysql and setting the grants and authorize again.

    Next, reinstall ispconfig. I'm the latest release and did a reinstall over the existing and everything worked perectly.

Share This Page