WARNING: mysql.service changed on disk. Run 'systemctl daemon-reload' to reload units.

Discussion in 'Installation/Configuration' started by jbonlinea, Oct 2, 2018.

  1. jbonlinea

    jbonlinea Member

    Hi everyone,
    I'm busy installing the debian perfect server with apache on a virtual machine.
    the host machine is a debian stretch (laptop), runing virtual box 5.2.18_Debian r123745 on top of which the guest machine (or virtual machine) has a debian stretch fresh net-install with not any additional component,

    Before going through the tutorial, the only change I did to the virtual machine was to install ssh services and redirect network card in order to acces the virtual machine from my host system terminal (and be able to copy paste freely) like explained here (sorry I know realise it's in french)

    Now everything is fine with the insalation process upto step 8, at the end, when I'm supposed to reload the services.

    Code:
    [email protected]:/# systemctl daemon-reload
    [email protected]:/# service mysql restart
    Warning: mysql.service changed on disk. Run 'systemctl daemon-reload' to reload units.
    [email protected]:/#
    
    I've read it wasn't an issue but I would like to know why and how ? and if is there anythin I can do ?

    Thank's by advance !
    J.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    That's ok, just ignore it.
     
  3. jbonlinea

    jbonlinea Member

    Excellent !
    I understood that it could be ignored but wasn't 100% sure.

    Slightly off topic: the tutorial concludes with an optional 22.1 chapter regarding virtual machine.
    Do this applies only if using openVZ or also virtualbox ?
    I guess it don't but just checking
    in case it does apply as well, how can I know what "vpsid" is given to my virtual machine ?
    Thank's again
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Chapter 22.1 is just nescessary when you run this setup inside a virtual server which is hosted on OpenVZ, it does not apply to other virtualization systems.
     
  5. jbonlinea

    jbonlinea Member

    Thank's for your confirmation
     
  6. brt

    brt New Member

    sorry for necrobumping this thread, but i just stumbled over the same problem, being annoyed by the error message everytime i call systemctl XY mariadb.

    i followed the perfect setup for debian buster, it suggests to add the file:
    Code:
    /etc/systemd/system/mysql.service.d/limits.conf
    
    after digging around, i found sites which recommend to add the file:
    Code:
    /etc/systemd/system/mariadb.service.d/limits.conf
    so i gave it a try and renamed the folder from mysql.service.d to mariadb.service.d, followed by systemctl daemon-reload", now the error-message is gone :D when restarting mariadb:
    Code:
    mv /etc/systemd/system/mysql.service.d /etc/systemd/system/mariadb.service.d
    systemctl daemon-reload
    systemctl restart mariadb
    @till: Do you think this is a proper solution, or how can i be sure that the new limit is in effect?

    *edit*
    the following is from /usr/lib/systemd/system/mariadb.service:
    Code:
    ...
    ##############################################################################
    ## USERs can override
    ##
    ##
    ## by creating a file in /etc/systemd/system/mariadb.service.d/MY_SPECIAL.conf
    ## and adding/setting the following under [Service] will override this file's
    ## settings.
    
    # Useful options not previously available in [mysqld_safe]
    
    # Kernels like killing mysqld when out of memory because its big.
    # Lets temper that preference a little.
    # OOMScoreAdjust=-600
    
    # Explicitly start with high IO priority
    # BlockIOWeight=1000
    
    # If you don't use the /tmp directory for SELECT ... OUTFILE and
    # LOAD DATA INFILE you can enable PrivateTmp=true for a little more security.
    PrivateTmp=false
    
    ##
    ## Options previously available to be set via [mysqld_safe]
    ## that now needs to be set by systemd config files as mysqld_safe
    ## isn't executed.
    ##
    
    # Number of files limit. previously [mysqld_safe] open-file-limit
    LimitNOFILE=16364
    
    ...
     
    Last edited: Oct 19, 2019

Share This Page