vsftpd tls/ssl problem

Discussion in 'HOWTO-Related Questions' started by yogoni, Jan 5, 2010.

  1. yogoni

    yogoni New Member

    Hi,
    I am trying to configure a secure vsftpd in CentOS 5.3. The vsftpd
    version is 2.0.5.

    I put this in vsftpd.conf:

    Code:
    ssl_enable=YES
    allow_anon_ssl=NO
    force_local_logins_ssl=YES
    force_local_data_ssl=YES
    ssl_tlsv1=YES
    ssl_sslv2=YES
    ssl_sslv3=YES
    rsa_cert_file=/etc/vsftpd/vsftpd.pem
    rsa_private_key_file=/etc/vsftpd/vsftpd.pem

    I set FTPES in the ftp client. I put the user and pwd and the connection
    starts. Then I accept the certificate, but the user home doesn't appear.
    There isn't folders, the client can't show the user home. This is the error: "521 Data connections must be encrypted".
    However, in the connection without security everything goes ok.

    What am I doing wrong?

    It has the ssl compiled:
    Code:
    # ldd /usr/sbin/vsftpd | grep ssl
            libssl.so.6 => /lib/libssl.so.6 (0x008a9000)
    Also vsftpd is built with OpenSSL support. I've edited "builddefs.h" and I've changed the "#undef VSF_BUILD_SSL" to "#define VSF_BUILD_SSL".

    Please help me.

    Thank you very much.
     
  2. topdog

    topdog Active Member HowtoForge Supporter

    The problem could be your client not fully supporting ssl/tls (only supporting it for login not for data transfer)

    The using a confirmed ssl aware client like lftp, winscp, filezilla.
     
  3. yogoni

    yogoni New Member

    Thanks for the response. I have tried with the clients fireftp and filezilla in the server and in the client, but none works. The same happens when force_local_data_ssl=NO and force_local_logins_ssl=NO.
     

Share This Page