VSFTPD config improvement

Discussion in 'Developers' Forum' started by leo, Dec 19, 2006.

  1. leo

    leo ISPConfig Developer ISPConfig Developer

    Hello I'm Leo.
    It's my first post .... I don't speak english ... but i will to do my best effort :D
    OK....
    I use VSFTP for ftp server.
    I have see some "problems" in the standard config of vsftp. for this... i use one file (/etc/vsftpd.users) where i put (1 per line) users allowed to login on ftp service and what don't be allowed to "go out" of their home directory.
    Is posible add the funcionality of put login name in that file when a new ftp user is added ??

    For that i use the next config in /etc/vsftpd.conf:
    anonymous_enable=NO
    ## Allow local users to log in.
    local_enable=YES
    ## Enable any form of FTP write command:
    write_enable=YES
    ## Users listed in this file only can view yours home directory:
    chroot_list_enable=YES
    chroot_list_file=/etc/vsftpd.users
    ## Only enable users listed in this file:
    userlist_file=/etc/vsftpd.users
    userlist_enable=YES
    userlist_deny=NO
    ## Allow to use /bin/false as user's shell:
    check_shell=NO

    That's all for now ...
    cheers for all !!!
    Leo
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Hi Leo,

    looks like a interesting setup. Which problems do you get with the default ISPConfig FTP configuration? Chrooting to the users home directory is possible with the default configuration too, or do you chroot to other directories then the users home directory?
     
  3. leo

    leo ISPConfig Developer ISPConfig Developer

    Hello!! thanks for reply!

    Whit the standard conf chroot don't work for me. I have make some probes and nothing. In addition, i "need" that only some users can use FTP (i.e. don't allow mail users), but only this (i.e. not ssh-> shell=/bin/false). Even i use AllowUsers in sshd_conf ... but... i want a system "very closed" :rolleyes:

    OH! i'm using slackware if it help !!

    thanks again !!

    Leo
     

Share This Page