vsftp 2.0.7 ftp(s) connect -> 500 oops child died

Discussion in 'Server Operation' started by Ben, Aug 17, 2009.

  1. Ben

    Ben ISPConfig Developer ISPConfig Developer

    the following problem happend (and still happens) on one of my debian boxes.
    When trying to connect via ftp or ftps the client states waiting for the welcome message and than breaks the connection after reaching a timeout. When trying the same with a commanshell ftp (instead of filezilla in this case) it generally works but with the same symptoms of having a very loong time after the welcome message but I get a loginprompt and the rest works.

    While trying to troubleshoot, as vsftpd logs are empty, I took a short view on the tcpdump captures which showed the following error:
    "00 oops child died: vsf_sysutil_recv_peek: no data". Googling did not help much except stating something about mod capability.

    So I tried to lock it down to several things I change on the server since this problem occured:

    - Snort + OSSEC
    - Kernel 2.6.26-1-686-bigmem to 2.6.26-2-686-bigmem
    - deletion of /tmp with recration -> root:root, chmod 1777
    - ISPConfig2 upgrade to the most recent version

    Snort and OSSEC, as well as the changed kernel do not seem to be the problem, as the problem occurs when deactivating them and switching back the kernel to the old one, the problem persists. Also this modprobe thing is the same no matter of the kernel version so I'd assume that this solution would not help at all.

    Well as vsftpd is the debian one, controlled by the ispconfig_tcpserver, maybe there could be the problem located.
    @Till / Falko: Did this binary change since the last two upgrades of ispconfig2?

    The /tmp thing should not be a problem but I actually do not know if vsftpd needs /tmp in a special way like other services, e.g. samba would not be able to accept connections wihout a writeable /tmp.

    Any ideas?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    No.

    Have you tried both active and passive transfers in your FTP client?
     
  3. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Hmmm strange...

    Well the problem does not change, no matter if connecting active or passive. There are no dropped packets at all.
     

Share This Page