VPS +ISPConfig w/o domain

Discussion in 'Installation/Configuration' started by Nino, Dec 2, 2008.

  1. Nino

    Nino New Member

    Hi,

    I'm trying to lern how to manage a VPS and I tried to install ISPConfig.
    I bought a VPS from tagadab.com with Fedora 8.
    I followed http://www.howtoforge.com/fedora-8-server-lamp-email-dns-ftp-ispconfig-p3 and after that I installed ISPConfig.

    But I faced a lot of problems!

    1) I don't have a domain (I could use one at NO-IP) so I didn't understand what I have to write in /etc/hosts instead of
    Code:
    192.168.0.100           server1.example.com server1
    ::1                          localhost6.localdomain6 localhost6
    
    so I left only this line:
    Code:
    127.0.0.1               localhost.localdomain localhost
    
    My /etc/fstab contains the following lines:

    Code:
    /dev/sda1     /            ext3     defaults        1 1
    /dev/sda2     swap      swap    defaults        0 0
    LABEL=/boot /boot      ext3     defaults
    devpts         /dev/pts   devpts gid=5,mode=620  0 0
    tmpfs           /dev/shm  tmpfs   defaults        0 0
    proc            /proc      proc    defaults        0 0
    sysfs           /sys        sysfs   defaults        0 0
    
    2) When I installed ISPConfig I got some errors that I wasn't able to read because of the scrolling.
    To the request:
    Code:
    Please enter the domain:
    
    I wrote my.no-ip.com

    So, when I try to access to https://my.no-ip.com:81 or https://94.102.147.162:81 the browser fails to connect!

    Sorry for bothering you, but I tried to find information in this forum and on the web without success.

    Can you help me? Even a link to a guide will be very useful to me.

    Thank you very much,
    Nino
     
  2. torusturtle

    torusturtle ISPConfig Developer

    What if you add your no-ip domain to /etc/hosts?
    Code:
    94.102.147.162           mydomain.no-ip.com mydomain
    127.0.0.1               localhost.localdomain localhost
    Then restart and check the output of hostname -f like in the perfect setup.

    You might have to install ISPConfig from scratch.
     
  3. Nino

    Nino New Member

    Thanks, torusturtle!

    It works now.

    Ciao,
    Nino
     

Share This Page