vmware workstation kernel 2.6.24 compile error

Discussion in 'Kernel Questions' started by blocker, Apr 23, 2008.

  1. blocker

    blocker Member

    Hi Forumers,

    i am experiencing troubles building the vmware workstation module on my linux PC, i think that it has something to do with the kernel version i use because on earlier version there was no such problem present.

    Software i use:
    Debian sid, kernel 2.4.24 build from the debian source package gcc-4.2 (also tried with debian precompiled image linux-image-2.6.24-1-686)
    VMware-workstation-6.0.3-80004.i386 (also tried with VMware-workstation-6.0.2-59824.i386)

    Building the vmmon module.
    Using 2.6.x kernel build system.
    make: Entering directory `/tmp/vmware-config0/vmmon-only'
    make -C /lib/modules/2.6.24/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
    make[1]: Entering directory `/usr/src/linux-source-2.6.24'
      CC [M]  /tmp/vmware-config0/vmmon-only/linux/driver.o
      CC [M]  /tmp/vmware-config0/vmmon-only/linux/hostif.o
    /tmp/vmware-config0/vmmon-only/linux/hostif.c: In function ‘HostIF_BrokenCPUHelper’:
    /tmp/vmware-config0/vmmon-only/linux/hostif.c:3056: warning: passing argument 1 of ‘HostIFBrokenCPUHelper’ discards qualifiers from pointer target type
      CC [M]  /tmp/vmware-config0/vmmon-only/common/comport.o
      CC [M]  /tmp/vmware-config0/vmmon-only/common/cpuid.o
    In file included from include/asm/bitops.h:2,
                     from /tmp/vmware-config0/vmmon-only/./include/vcpuset.h:74,
                     from /tmp/vmware-config0/vmmon-only/./include/modulecall.h:23,
                     from /tmp/vmware-config0/vmmon-only/common/vmx86.h:18,
                     from /tmp/vmware-config0/vmmon-only/common/hostif.h:18,
                     from /tmp/vmware-config0/vmmon-only/common/cpuid.c:14:
    include/asm/bitops_32.h:9:2: error: #error only <linux/bitops.h> can be included directly
    make[2]: *** [/tmp/vmware-config0/vmmon-only/common/cpuid.o] Error 1
    make[1]: *** [_module_/tmp/vmware-config0/vmmon-only] Error 2
    make[1]: Leaving directory `/usr/src/linux-source-2.6.24'
    make: *** [vmmon.ko] Error 2
    make: Leaving directory `/tmp/vmware-config0/vmmon-only'
    Unable to build the vmmon module.
    For more information on how to troubleshoot module-related problems, please
    visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
    Execution aborted.
    does anybody have an idea how can i fix that?
  2. o.meyer

    o.meyer ISPConfig Developer ISPConfig Developer

  3. blocker

    blocker Member

    hmm it looks like that the tread you posted is for vmware server, and i would like to have vmware workstation installed....
  4. blocker

    blocker Member

    I have tried vmware server, your walktrough works perfect also on debian!
  5. rmarrs

    rmarrs New Member

    Works with VMWare Workstation as well

    I just tested this on Hardy Heron using VMWare Workstation. Works fine, because the kernel modules are what wouldn't build. Doesn't matter which scale of VMWare you have, they'll all build the same kernel modules.
  6. bnv

    bnv New Member

    Version mismatch

    For me the vmmon and vmnet modules compile using the proposed solution, but my virtual machine will not start due to a version mismatch with vmmon module: expecting 167.0, got 161.0. VMWare Workstation 6.02 build-59824 and Kubuntu kernel 2.6.24-16-generic.
  7. bnv

    bnv New Member

    Patched patch

    For a working solution for the combination VMWare Workstation 6.02 and host kernel 2.6.24-16, use the patched any-any patch from http://aldeby.org/blog/?p=113

Share This Page