VMware Won't Start On Ubuntu Hardy

Discussion in 'HOWTO-Related Questions' started by AlfredNoob, Aug 2, 2008.

  1. AlfredNoob

    AlfredNoob New Member

    Hello....i followed falko's guide on "How to install vmware server (version 1.0.6) on an ubuntu 8.04 desktop" and run the code:
    sudo ln -sf /lib/libgcc_s.so.1 /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1

    i can see the "vmware console" in "system tools" but when i click on it, it won't start???????

    how can i remedy this?

    (p.s. when i installed vmware i was never asked about the 20-digit registration number and "inetd" nor "xinetd" can't be found in my kernel...are these the reasons why vmware console won't start?)
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    vmware
    in a terminal. Do you get any errors?
     
  3. AlfredNoob

    AlfredNoob New Member

    hi Falko i'm sorry it took me a while to reply....

    when i invoke "vmware" in terminal i get the message that

    "vmware is installed but not properly configured" so i run the /usr/bin/vmware-config.pl.

    however, i always end-up with,
    "Unable to find any instance of the super-server "inetd" or "xinetd". It is
    possible that you do not have one of these packages installed on this machine.
    Please install "inetd" or "xinetd".

    If you do have "inetd" or "xinetd" installed, make sure that /etc/inetd.conf or
    /etc/xinetd.d exists."

    i am quite sure that inetd daemon is in my system but i cannot understand why it cannot be detected by the installer....

    pls. point me to the right direction.....
     
  4. AlfredNoob

    AlfredNoob New Member

    hi again!

    i've finally solved it!

    it seems that vmware only runs if the daemon installed is xinetd not inetd.

    after i installed xinetd with the command,
    sudo apt-get install linux-headers- `uname -r` build-essential xinetd
    everything went on smoothly...

    in fact, i have attached a screenshot of my desktop showing the vmware console with windowz xp as guest OS....

    thanks for the very nice how to's of Mr. Falko Timme.....you may not know it but you surely are helping a lot of people out there.....

    oh yeah, before i forget....does anyone know how i could remedy a problem wherein everytime my vmware console iis running with a guest OS, my keyboards become unusable in my desktop...

    everytime a key is pressed in my keyboard, any application that is open in my desktop suddenly closes....

    is this a bug in vmware running in ubuntu as host?
     

    Attached Files:

  5. falko

    falko Super Moderator ISPConfig Developer

    Not sure if this helps, but you could install VMware Tools.
     
  6. AlfredNoob

    AlfredNoob New Member

    thanks again mr. falko for that prompt reply....actually now i just resolved it by adjusting it in 'edit' tab and then 'preferences' and then 'input' tab, selecting 'grab mouse and keyboard on input by key press' will do the trick....


    long live open source............

    thanks mr. falko........
     

Share This Page