VMWare server on Debian Squeeze working

Discussion in 'HOWTO-Related Questions' started by unclecameron, Mar 13, 2010.

  1. unclecameron

    unclecameron New Member

    Just got VMWare server 2.0.2 working on Debian Squeeze (based on the howto Falko made for Debian Lenny)
    here's what I did:
    apt-get install linux-headers-`uname -r` build-essential xinetd gcc-4.3
    ln -sf /usr/bin/gcc-4.3 /usr/bin/gcc
    cd /usr/src
    scp ip.from.other.box:VMware* ./
    tar xfvz VMware-server-2.0.2-203138.x86_64.tar.gz
    cd vmware-server-distrib/
    None of the pre-built vmmon modules for VMware Server is suitable for your 
    running kernel.  Do you want this program to try to build the vmmon module for 
    your system (you need to have a C compiler installed on your system)? [yes] 
    Using compiler "/usr/bin/gcc". Use environment variable CC to override.
    What is the location of the directory of C header files that match your running
    kernel? [/lib/modules/2.6.32-trunk-amd64/build/include] 
    but then it errors out with
    Extracting the sources of the vmmon module.
    Building the vmmon module.
    Using 2.6.x kernel build system.
    make: Entering directory `/tmp/vmware-config5/vmmon-only'
    make -C /lib/modules/2.6.32-trunk-amd64/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
    make[1]: Entering directory `/usr/src/linux-headers-2.6.32-trunk-amd64'
      CC [M]  /tmp/vmware-config5/vmmon-only/linux/driver.o
    In file included from /tmp/vmware-config5/vmmon-only/linux/driver.c:31:
    /tmp/vmware-config5/vmmon-only/./include/compat_wait.h:78: error: conflicting types for ‘poll_initwait’
    /usr/src/linux-headers-2.6.32-trunk-common/include/linux/poll.h:70: error: previous declaration of ‘poll_initwait’ was here
    In file included from /tmp/vmware-config5/vmmon-only/./common/vmx86.h:32,
                     from /tmp/vmware-config5/vmmon-only/linux/driver.h:29,
                     from /tmp/vmware-config5/vmmon-only/linux/driver.c:101:
    /tmp/vmware-config5/vmmon-only/./include/x86msr.h:164:1: warning: "MSR_THERM2_CTL" redefined
    In file included from /usr/src/linux-headers-2.6.32-trunk-common/arch/x86/include/asm/msr.h:4,
                     from /usr/src/linux-headers-2.6.32-trunk-common/arch/x86/include/asm/processor.h:21,
                     from /usr/src/linux-headers-2.6.32-trunk-common/include/linux/prefetch.h:14,
                     from /usr/src/linux-headers-2.6.32-trunk-common/include/linux/list.h:6,
                     from /usr/src/linux-headers-2.6.32-trunk-common/include/linux/module.h:9,
                     from /tmp/vmware-config5/vmmon-only/./include/compat_module.h:27,
                     from /tmp/vmware-config5/vmmon-only/linux/driver.c:26:
    /usr/src/linux-headers-2.6.32-trunk-common/arch/x86/include/asm/msr-index.h:225:1: warning: this is the location of the previous definition
    /tmp/vmware-config5/vmmon-only/linux/driver.c: In function ‘LinuxDriverSyncCallOnEachCPU’:
    /tmp/vmware-config5/vmmon-only/linux/driver.c:1423: error: too many arguments to function ‘smp_call_function’
    /tmp/vmware-config5/vmmon-only/linux/driver.c: In function ‘LinuxDriver_Ioctl’:
    /tmp/vmware-config5/vmmon-only/linux/driver.c:1987: error: ‘struct task_struct’ has no member named ‘euid’
    /tmp/vmware-config5/vmmon-only/linux/driver.c:1987: error: ‘struct task_struct’ has no member named ‘uid’
    /tmp/vmware-config5/vmmon-only/linux/driver.c:1988: error: ‘struct task_struct’ has no member named ‘fsuid’
    /tmp/vmware-config5/vmmon-only/linux/driver.c:1988: error: ‘struct task_struct’ has no member named ‘uid’
    /tmp/vmware-config5/vmmon-only/linux/driver.c:1989: error: ‘struct task_struct’ has no member named ‘egid’
    /tmp/vmware-config5/vmmon-only/linux/driver.c:1989: error: ‘struct task_struct’ has no member named ‘gid’
    /tmp/vmware-config5/vmmon-only/linux/driver.c:1990: error: ‘struct task_struct’ has no member named ‘fsgid’
    /tmp/vmware-config5/vmmon-only/linux/driver.c:1990: error: ‘struct task_struct’ has no member named ‘gid’
    /tmp/vmware-config5/vmmon-only/linux/driver.c:2007: error: too many arguments to function ‘smp_call_function’
    make[4]: *** [/tmp/vmware-config5/vmmon-only/linux/driver.o] Error 1
    make[3]: *** [_module_/tmp/vmware-config5/vmmon-only] Error 2
    make[2]: *** [sub-make] Error 2
    make[1]: *** [all] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.32-trunk-amd64'
    make: *** [vmmon.ko] Error 2
    make: Leaving directory `/tmp/vmware-config5/vmmon-only'
    Unable to build the vmmon module.
    For more information on how to troubleshoot module-related problems, please 
    visit our Web site at "http://www.vmware.com/go/unsup-linux-products" and 
    Execution aborted.
    Then I got the patch here and ran it like this:
    and it prompted me through the rest of the install...now if I can get the console working...if I get it figured out I'll post back here :) Right now it just comes up with a 503 Service Unavailable...
    Last edited: Mar 13, 2010
  2. heckmic

    heckmic New Member


    same Problem here! Any sollutions?
  3. hacmieu

    hacmieu New Member

    I had same problem with you :(
    Can't connect to port 8308
  4. heckmic

    heckmic New Member

    503 --> In some forums is loopack in hosts the sollution an sometimes the tomcat...

    In my case nothing of this helps. Same Problem 503 Webservice dont work. Any Idea?
  5. unclecameron

    unclecameron New Member

    read a couple forums, one says you should add
    Code: localhost
    to /etc/hosts, but Squeeze already has it there. Another said vmware tomcat is conflicting with apache tomcat, but I'm not running tomcat. It appears that either

    a. vmware is fighting for port 8333 with some other process, or
    b. vmware tomcat is fighting with debian for tomcat service

    I really need to figure this out, I can't revert to Lenny because of hardware driver issues...hopefully will figure it out today, will post back if I get it
  6. unclecameron

    unclecameron New Member

    I edited /etc/services and added the entry
    vmware-authd    902/tcp
    because it didn't look like that port would be open, but after a reboot it still didn't fix it. It looks like the proxy port has a conflict, I got this from the log file:
    [2010-03-18 12:22:37.816 'App' 139887774213872 info] Trying proxysvc
    [2010-03-18 12:22:37.816 'Proxysvc' 139887774213872 info] Proxy config filepath is /etc/vmware/hostd/proxy.xml
    [2010-03-18 12:22:37.816 'Proxysvc' 139887774213872 panic] Another process is listening on the proxy port.
    [2010-03-18 12:22:37.816 'Proxysvc' 139887774213872 panic] Please make sure other instances of hostd are not running
    so I have to hunt down what's conflicting with that port I think.
  7. unclecameron

    unclecameron New Member

    It looks like it might be an error with vmware-hostd, when I try to restart it I get
    vmware-hostd restart
    [2010-03-18 17:20:41.038 'App' 140465290491632 info] Current working directory: /etc/vmware/hostd
    [2010-03-18 17:20:41.038 'App' 140465290491632 panic] error: Could not find any plugins in config file
    [2010-03-18 17:20:41.038 'App' 140465290491632 panic] backtrace:
    [00] eip 0x9ef90dfb  
    [01] eip 0x9ee8aa40  
    [02] eip 0x9ee2e447  
    [03] eip 0x9ee3bbdb  
    [04] eip 0x9ee3c5f2  
    [05] eip 0x9ee35623  
    [06] eip 0xab6f6e  
    [07] eip 0xac5821  
    [08] eip 0xad55e1  
    [09] eip 0x9dde9abd  
    [10] eip 0x6a82fa 
    so I think somehow vmware-hostd doesn't play nice with Squeeze...now to figure out why :(
  8. unclecameron

    unclecameron New Member

    GOT IT!

    okay, the issue is ipv6, first find out if it's running by doing:
    netstat -lnp | grep tcp6
    ping6 -c1 localhost
    if you get a response that tells you it's running, you have to disable it, which you normally disable elsewhere, but in Squeeze you create a file like this
    vi /etc/sysctl.d/local.conf
    and put this line in it:
    net.ipv6.conf.eth0.disable_ipv6 = 1
    and reboot
  9. heckmic

    heckmic New Member

    I had to deaktivate it like this:

    vim /etc/default/grub ...

    then "update-grub" and reboot.
  10. darky83

    darky83 New Member

Share This Page