VMWare Server howto: Missing packages?

Discussion in 'HOWTO-Related Questions' started by nycvelo, Aug 26, 2006.

  1. nycvelo

    nycvelo New Member

    Dual dual-core Opteron, Ubuntu 6.06.1

    The VMware Server howto says to install these two packages:

    libc6-dev-amd64 lib64gcc1

    I'm getting not-found errors when trying to install them.

    I'm new to Ubuntu. Thanks in advance for pointers on where to find these packages.
  2. falko

    falko Super Moderator ISPConfig Developer

  3. nycvelo

    nycvelo New Member

    Thanks. The only diffs I found between my sources.list and the one on that site were that I was pointing to the "us." Ubuntu sites rather than the "de." ones.

    I changed the links so that the sites are identical, and I'm still unable to install lib64gcc1 or libc6-dev-amd64.

    FWIW I'm using an Opteron and the amd64 version of the Ubuntu distro.

    Thanks again.
  4. falko

    falko Super Moderator ISPConfig Developer

    That might be the problem then. Leave out the missing packages and see how far you get. The tutorial was written for the i386 version of Ubuntu.
  5. nycvelo

    nycvelo New Member

    still no luck

    I've gotten farther along on this, but still don't have vmware server running.

    Two issues with the vmware-install.pl script:

    1. Cert setup doesn't complete. The script complains that it can't get the modification time for rui.key and rui.crt. I work around this by touching those files.

    2. Just before prompting for a serial number, the script produces this error:

    sh: /usr/lib/vmware/bin/vmware-vmx: No such file or directory

    This is possibly because the script chmod's that file to mode 04555, which looks like:


    I tried chmod'ing the file to 555 and even 777 but the script still doesn't like that file, even when it is user-executable. It is a binary file.

    I'm stuck. Any suggestions, other than to try a different OS?


    Dual dual-core Opteron, Ubuntu 6.06.1, whatever version of VMware Server was on their server last week
  6. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    ls -l /usr/lib/vmware/bin/vmware-vmx
  7. nycvelo

    nycvelo New Member

    -r-sr-xr-x 1 root root 4383540 2006-08-31 15:36 /usr/lib/vmware/bin/vmware-vmx

    Tweaking the vmware-install.pl script to chmod the file to 0555 or 0777 doesn't change things. I still get this error:

    In which directory do you want to keep your virtual machine files?
    [/var/lib/vmware/Virtual Machines]

    sh: /usr/lib/vmware/bin/vmware-vmx: No such file or directory
    Please enter your 20-character serial number.

    Type XXXXX-XXXXX-XXXXX-XXXXX or 'Enter' to cancel: 925KX-Y6LD4-23JG1-43K1X

    sh: /usr/lib/vmware/bin/vmware-vmx: No such file or directory

    and so on, ad infinitum.
  8. falko

    falko Super Moderator ISPConfig Developer

    Did you try on a fresh system?
  9. nycvelo

    nycvelo New Member

    Well, this was all on a new install. On the off chance I got something wrong previously, I reinstalled Ubuntu, and the vmware install script still broke down in the same place (that bad (?) binary for vmware-vmx).

    Also, I understand this to be an issue with the VMware install script and not with Ubuntu. Still, it affects this howto, as the howto deals with both Ubuntu and VMware.

    Much as I appreciate everyone's help here, I'm going to stop trying this with Ubuntu. I will try the same thing with CentOS and report back on my progress.
  10. nycvelo

    nycvelo New Member

    OK, so VMware Server installed the first time on CentOS -- no cert errors and no problems with vmware-vmx.

    I'm not tied to any one OS, but for running VMWare Server on Opteron hardware my experience is that the install script works on CentOS and does not work on Ubuntu (x86_64 versions in both cases). Again, I'm not knocking Ubuntu here; I believe this is an issue with the VMware install script not liking Ubuntu x86_64 file locations.

    Thanks again to all who responded.

Share This Page