VMWare Server Howto and Ubuntu Questions

Discussion in 'HOWTO-Related Questions' started by crudolphy, Jul 22, 2006.

  1. crudolphy

    crudolphy New Member

    I have the following machine:

    Asus A7N8X Deluxe MB with Silicone Image Sil 3112A Sata controller with Raid 0/1 support.
    AMD Athlon XP 2500 1.83Gz Processor
    1GB dual channel PC2700 ram (2x512 Corsair Modules)
    2 Seagate Barracuda 80GB Sata1 HD
    ATI Radeon 9600 128MB Video Card

    I currently triple boot Win2KPro, Mandrake 10.1, and Ubuntu Breezy Badger. I need to delete the Mandrake (don't use it anymore.) I have to use Windows on occasion. I love and use Ubuntu as my primary OS of choice. I could dual boot Windows and Ubuntu Dapper but would rather use VMWare and run Windows without having to boot when necessary.

    Before I tear into my machine and re-do it I have a some questions:

    1.) Would like to setup using the Silicone Image Raid 0. Do you think there would be a problem with this?

    2.) Do you think I have enough horsepower for this kind of setup?

    3.) I would want all virtual machines on the same NAT'd ip subnet, ie. 192.168.1.x. The MB provides (2) 10/100 ethernet ports. One is Nvidia based the other is 3Com based. I currently only use the Nvidia based and have the 3Com disabled in the bios setup. Would there be an advantage to enabling the second 3Com ethernet port? Are there any problems to watch out for with two active ethernet ports?

    4. ) The "How To" states that it doesn't matter whether you setup the VMWare server over a Ubuntu "Desktop" or "Server" setup. However as I read through the "How To" it would seem that it might be "better practice"?? to install the Ubuntu "Server" setup, then the VMWare server and management interface, then setup up virtual hosts for your desktops. One for Ubuntu and one for Windows. What do you think of this?

    I really appreciate the great work of Till and Falko.:) This is a great website which provides a wonderful service to the community!

    Would appreciate hearing any and all opinions on the above.

    Thanks

    Chuck Rudolphy
     
    Last edited: Jul 22, 2006
  2. till

    till Super Moderator

    I guess no, if you get linux drivers for this raid controller. But I do not have experience with this raid controller.

    yes.

    No, one network card is enough.

    I recommend to install ubuntu desktop (not server) as you want to use it as your primary OS. Then use either VMWare Server or VMWare player to run windows in a VM.
     
  3. rayit

    rayit New Member

    raid

    I do not think raid will work with silicon

    I advise a 3ware controller
    or an areca controller

    3ware is easier to install.

    greetings

    RayIT
     
  4. crudolphy

    crudolphy New Member

    Till and others thanks for your response. :)

    Ubuntu recognizes Silicone Image SATA driver no problem, although I have never tried it with it's raid 0 or 1 setup. Seeing as I will be clearing out both hard drives I will give it's raid capabilities a try and post my experience back to this thread.

    Thanks

    Chuck
     
  5. crudolphy

    crudolphy New Member

    Silicone Image Raid Controller

    I will say that RayIt is correct in that Ubuntu does not seem to recognize a raid setup with this controller. It has no problems detecting the two drives and utilizing its SATA driver to access them. I setup a raid 1 set (striping) prior to booting from the install cd. It booted then during the partitioning gparted didn't see it as 1 drive it saw the two individual drives. So I don't believe that Ubuntu 6.06 (don't know about other distributions) works with this raid controller.

    I exited the install, removed the raid1 set, then installed and partitioned with two individual drives. I don't think that I will notice the performance difference between the two drives and the raid set.

    Chuck Rudolphy
     
  6. belgampaul

    belgampaul New Member

    Cannot login as root to the newly created VMServer

    It's a really great step-by-step on how to install the vmware-server. And it worked for me nearly perfectly. All seems to be properly installed and working apart from one little detail:

    everytime i try to login to the server either with a web browser or console as root i get the nasty error message "Permission denied: Login incorrect" and i have no idea this happens.

    i succeed to log in as another user but than i have no control of the server.

    this is what i found in the /var/log/vmware-mui/error_log :

    Tue Jul 25 09:08:44 2006] [warn] Invalid session key (1) .\n
    [Tue Jul 25 09:08:45 2006] [vmware error] VMware::Management::Util line 173: -4: Permission denied: Login (username/password) incorrect
    [Tue Jul 25 09:08:45 2006] [vmware error] VMware::Management::SxLogin line 177: -4: Permission denied: Login (username/password) incorrect



    During installation i had no problems and stuck to this howto.

    Any thoughts how to debug this?
     
  7. till

    till Super Moderator


    Did you use the user "root" and your root password? You must enable the root user in Ubuntu, you can not use sudo like it is used normally in ubuntu.
     
  8. belgampaul

    belgampaul New Member

    i used root and its appropriate password. checked at least 15 times :)

    i was installing the vmserver in a konsol's root session terminal.
    was it sudo? i'm not sure about about.
     
  9. till

    till Super Moderator

    And you are able to login with the same root password on the shell?
     
  10. belgampaul

    belgampaul New Member

    yes i'm able to login with the root's password remotely and locally.
    i'm using the same password for my non-priviledged user so typos are excluded.
    i was thinking that there could be problem with apache but given that the installation procedure is straight forward and no error messages appeared i'm a bit clueless.

    my best guess there's some sort of access problem.
     
  11. belgampaul

    belgampaul New Member

    correction

    i'm not able to login as root neither locally nor remotely :(
    the only way i get root is at konsole where everything seems to work.

    i tried to go to the plain terminal (tty1) and i get the same error.
    obviously it's not at all related to vwmare

    but i'm still clueless
     
  12. belgampaul

    belgampaul New Member

    the mistake is so bad that i'm really ashamed. obviously i didn't set the root's password after the install. the only excuse is that i already have ubuntu as a virtual machine on my windows install where it was configured as it should be. poor me. thanks for the help anyways. it makes one feel less lonely :)
     

Share This Page