vmware server 2 on Ubuntu 8.04

Discussion in 'Technical' started by rf75, Mar 26, 2009.

  1. rf75

    rf75 New Member

    I followed the well-written guide to putting vmware 2.0 on Ubuntu 8.04 desktop. I ran into the problem where the configuration process reported a mismatch on the gcc compiler version versus the one used to compile the kernel. The comment on the thread that reported the same problem had no response, so I went ahead and everything seemed to compile. But when I fired up the interface and tried to start vms I copied over, I saw there was no option to reconfigure the vm and there was no console tab. So all I got in feedback from starting the vms was one line of error message, and they were not too helpful. I tried to create a new vm and install Windows 7 but no luck with getting the CDrom to be the boot device (hence the need to reconfig the VM "bios" options).
    I've used VMware server 2 under Windows XP for a long time so I know it well. Should it look the same on a Linux install? Anyone know further tricks to avoid the gcc version warning message in the above scenario? And I will really need the console to do cold OS installs.
    Thanks in advance, all assistance appreciated.
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the exact GCC error message?

    Have you tried to install that GCC version from the Ubuntu repositories and make a symlink from /usr/bin/gcc to that version?
  3. rf75

    rf75 New Member

    sorry to have failed to respond ... I looked to the Dark Side and put up a Windows 7 x64 beta and installed VMware Server there. Sad to say (for Ubuntoids) it worked first time out of the box and continues to work well.

    That said, I saved room for an Ubuntu 64bit partition and will try to multiboot install 8.10 (or would you recommend 8.04 instead?) and try to get the same VMware server setup going there, when time is available.

    This is why Ubuntu and Linux have an uphill battle. Seems like anything nontrivial requires a fair amount of expertise with installing packages, version management, try-and-see, and asking for help from expert sites like this. I'm no computer newbie. OTOH I will have to pay $$ for Windows 7 when the beta expires and VMware is not officially supported except on $$$$ Windows Server. But VMWare server is free only if you don't want support anyway.

    I also expect better performance under Ubuntu; but there are no Linux drivers for some of the advanced functions on my shiny new AM3 mobo. And the few terabytes of disk I have in the box are all NTFS (except the Linus partition) which shares perfectly easily under Windows but which is erratic under Linux / SMB. You say tomato, I say tomahto.


Share This Page