VMWare on Ubuntu?

Discussion in 'Installation/Configuration' started by mrwasabi, Sep 13, 2007.

  1. mrwasabi

    mrwasabi New Member

    Hi Folks,
    I'm interested in setting up vmware server on my ubuntu box and testing vector linux soho, any tips on accomplishing this without error? I've read several tutorials on running windows xp on ubuntu, will the same procedure work for any OS? Thanks in advance.


    Ok I followed the vmware server install guide for ubuntu here, but when I tried to install vectorlinux soho I got an error, can I install VL then mount it with vmware after the fact, or do I have to install from vmware? Thanks in advance.
    Last edited: Sep 17, 2007
  2. chuckl

    chuckl New Member

    Once you have VMWare server installed, you decide what to use with it. You can download VM prebuilt images, or create a new virtual machine, and install whatever you like in there. Only warning I would have is that in my experience the guest op systems use more disk space than they would on a real machine. I'd say multiply your disk space estimates by about 1.5-2 when defining virtual disks.

    As for installing VMWare Server, follow Tills' HowTo

  3. sjau

    sjau Local Meanie Moderator

  4. gobstopper

    gobstopper New Member

    This is becoming an extremely frustrating exercise and one which is showing no signs of moving forward.

    I have a server machine running Ububtu (Feisty) 7.04 server and I would like to install and run VMServer so that I can run a number of "on-demand" scratch servers therefore saving me from run tests on otherwise live, production, servers.

    I'm not an abolsute noob, I have dabbled with *nix for years and many of the products I work with are based on *nix kernels. But this is the first time I've really gotten involved with installing stuff from scratch.

    The installation of 7.04 server itself was a doddle, and I hoped that it would be the sign of things to come. I did my research and found the HowTo article about installing VMWare server and while there seemed to be a fair amount to do, I rolled up my sleeves and thought it was worth a go. Two days (and several full O/S re installations) later, my resolve has all but wained, because try as I might I can't seem to reach a positive conclusion.

    If I use the commercial repository and run "sudo apt-get install vmware-server" the download and installation is pretty painless. I fill in all the blanks and finally get to the point where is asks for the serial number and everything, on the surface seems to be going well. However, once completed, I seeming unable to do anything due to the following message :-

    Module vmnet is not loaded. Please verify that it is loaded before
    running this script.​

    As a result, I can't connect using the VMWare Server Console on my windows PC.

    When I resort to the HowTo document and use the long-hand installation method it, again, seems to be going OK.

    From a clean O/S installation, I do the following:-

    1 - sudo aptitude install linux-headers-`uname -r` build-essential

    2 - sudo aptitude install xinetd

    3 - Download VMWare server installation tar.gz file

    4 - Download "any-any" patch

    5 - tar -xzf VMware-server-1.0.3-44356.tar.gz

    6 - tar xvzf vmware-any-any-update113.tar.gz

    7 - cd vmware-server-distrib

    8 - sudo ./vmware-install.pl (following the step-by-step instructions as per the howto)

    9 - At point where it prompts to run vmware-config.pl, I answer "no"

    10 - cd ../vmware-any-any-update113

    11 - sudo ./runme.pl - answering "yes" to running vmware-config.pl at which point I get the following in my terminal window:-

    The correct version of one or more libraries needed to run VMware Server may be
    missing. This is the output of ldd /usr/bin/vmware:
    linux-gate.so.1 => (0xffffe000)
    libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7fb2000)
    libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7fae000)
    libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7f97000)
    libX11.so.6 => not found
    libXtst.so.6 => not found
    libXext.so.6 => not found
    libXt.so.6 => not found
    libICE.so.6 => not found
    libSM.so.6 => not found
    libXrender.so.1 => not found
    libz.so.1 => /usr/lib/libz.so.1 (0xb7f81000)
    libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7e40000)
    /lib/ld-linux.so.2 (0xb7fdf000)

    This program cannot tell for sure, but you may need to upgrade libc5 to glibc
    before you can run VMware Server.

    Hit enter to continue.​

    12 - I hit enter to continue, as instructed, and then proceed through the license agreement.

    13 - I then come across a message stating the following:-

    None of the pre-built vmmon modules for VMware Server is suitable for your
    running kernel. Do you want this program to try to build the vmmon module for
    your system (you need to have a C compiler installed on your system)?

    Answering "yes", and the default response for the next question, it then goes off and does it's thing...​

    14 - When prompted to set up networking for my virtual machines, I answer "yes" and again opt for the defaults (except for host-only networking to which I answer "no") - at which point it start to build the "vmnet" module.

    15 - Now I am prompted to enter a port for remote console connections, to which I (again) accept the default port.

    16 - Accept the default Virtual Machine directory, and acknowledge that I would like the directory (as it doesn't currently exist) to be created.

    17 - Now the serial number - at which point things take a distinct downward turn:-

    /usr/lib/vmware/bin/vmware-vmx: error while loading shared libraries: libX11.so.6: cannot open shared object file: No such file or directory​

    From this point, I can either keep trying to enter the serial number (even applied for a new one just in case there was something wrong with the original), without any success or press ENTER to drop-out to the command prompt.

    It is possible to esablish a connection with VMWare console, but without the serial number it isn't possible to create or run any machines.

    I've certainly learned a great deal, but I have reached a dead-end with this.

    It would seem that the absense of libX11.so.6 is the probable cause of my problem, but I have used a standard Unbuntu 7.04 server installation and there's nothing to suggest in this HowTo that I need to do anything else in advance to account for this. I've even been adventurous and tried "sudo apt-get install libX11.so.6", but it claims not to be able to find this package.

    Any help would be appreciated.
  5. sjau

    sjau Local Meanie Moderator

    install "apt-file"

    then run:
    sudo apt-file update
    And now you can search for files within packages:
    apt-file search libX11.so.6
    I guess your problem is that you do not have x-server installed. Vmware needs that as far as I can tell. The missing X11 lib does point in that direction.
  6. chuckl

    chuckl New Member

    Are you running a 64 bit version of Feisty? If so you will need to install ia32-libs.

    I think the author of the Feisty HowTo made an awful lot of assumptions about what was already on the machine when he wrote it. Build-essential on it's own is certainly not enough.

    You'd do better following the 6.06 LTS HowTo as far as the libraries to install are concerned. At least libx11-6 libxtst6 libice-dev libsm-dev libxt6 as well.
  7. gobstopper

    gobstopper New Member

    Thanks chuckl, I'm not running a 64-bit version but I will take a look at the 6.06 LTS HowTo. As you say there are certain assumptions made - one of mine, it would seem, is to try and install VMWare Server on to a server ;) working on the principle that you want the host OS to take up as few resources as possible to that they may be used to the full by the guest OS's

    sjau - I took a quick look at your suggestion last night and found that before I could run the apt-file command I first had to run 'sudo apt-get install apt-file'. Then when I did run 'sudo apt-file update' and then 'sudo apt-file search libX11.so.6' it came back with a response to say that it couldn't find it.

    Heading off to try the installation based on the 6.06 HowTo and I'll let you know how I get on.

    Thanks again to both of you.
    Last edited: Sep 18, 2007
  8. sjau

    sjau Local Meanie Moderator

    Hmm, I have to check it out at home in what package I have that file.
  9. gobstopper

    gobstopper New Member

    OK guys we have success - or so it may seem (and I have run through the full installation process from a clean machine twice and it's worked on both occasions.)

    Using the 6.06 LTS Howto, I ran the following command

    sudo apt-get install libx11-6 libx11-dev libxtst6 xlibs-dev xinetd wget​

    and then continued with the steps as per my original post (though in that case step 2 was not required as the new command, above, has already installed xinetd).

    I don't know if all of the elements in this apt-get command are necessary, but one thing is for sure - now I am able to proceed all of the way through the 7.04 Howto and when it gets to the point where I am required to enter the serial number this element does not come back with an error and after a brief pause I am told that the VMWare server environment is ready and waiting.

    Firing-up the VMWare Console on my Windows PC I can now connect, authenticate and create a new virtual machine - groovy! - though I haven't got time to install an OS to this virtual machine at the moment, will have to try that tomorrow.

    Thanks for the pointers guys - maybe the author of this Howto will be able to modify it with a section at the beginning for "if you have Ubuntu 'Server' do this first..."
    Last edited: Sep 18, 2007
  10. endurion

    endurion New Member

    This error was cropping up for me on 7.10 as well.

    Doing this fixed my issues:

    apt-get install linux-headers-`uname -r` libx11-6 libx11-dev x-window-system-core x-window-system xspecs libxtst6 psmisc build-essential
  11. sjau

    sjau Local Meanie Moderator

    so vmware server can be installed in a non-X11 environment :) nice

Share This Page