vmware ispconfig appliance . . . minor problems

Discussion in 'Installation/Configuration' started by KenKnight, Jan 21, 2007.

  1. KenKnight

    KenKnight Member

    Hi all,

    I've got the ispconfig vmware appliance running and upgraded it to 2.2.9.

    I pulled over my Vhosts_ispconfig.conf from my standalone debian perfect setup and I can't get php to work. Its got something to do with the handler portion. It's trying to download the script instead of execute it.

    I saw where it was running suPHP, but I'm not familiar with that yet.

    Any suggestions on where to start?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check that suphp is enabled as PHP handler in the file /home/admispconfig/ispconfig/lib/config.inc.php
  3. KenKnight

    KenKnight Member

    thanks, I'll check it out.

  4. flyingoat

    flyingoat New Member

    I have the same problem (php does not work in Ispconfig appliance), I checked config.inc.php, it said :$go_info["server"]["apache2_php"] = 'suphp';
    How should I go from here, anybody can help? thanks a lot
  5. falko

    falko Super Moderator ISPConfig Developer

  6. flyingoat

    flyingoat New Member

    still doesn't work

    falko, thanks a lot. but after I followed the steps, it seems that all the web sites (domain address) refer to one directory. for example, http://aaa.site1.com, it refered to http://aaa.site1.com/apache2-default/, displaying "It works!", rather that the standard index page for each website. Furthermore, I cannot access the content with the director "web" via internet, as a result, I cannot test whether the php works or not.
    Could you please help me out? thans again.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The vmware appliance for ispconfig from vmwares download site is totally outdated and contains several hacks that may conflict with new ispconfig versions. I guess it would be more work to get it working with a current ISPConfig version then when you start from scratch and install a new vm by following one of the perfect setup guides.
  8. flyingoat

    flyingoat New Member

    Thanks for your replies, yes, I understand the image is out of date. Actually, what I need is a demonstration for web hosting, so now I only need it works, keeping updated is not necessary. The problem is, for me, that the image is not used as easily as it is expected. So can you give me some hints to make it work in a way just as posted on vmware website.Thanks a lot.
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Download the vmware image and do not install any update, then it woks as described there.

    If you do not know how to get started with ispconfig, have a look in the manuals and the first steps guide found on ispconfig.org.
  10. flyingoat

    flyingoat New Member

    Actually, I just downloaded it and didn't install any updates, after I configured the ip address, it worked well (static html files) except the php parts, that was, when I uploaded a php file(with appropriate privileges) and access it via internet, it always said the webpage cannot be displayed.
    I have tried serveral times from scratch, it turned out the same results.

    Have you tried that image recently? Thanks a lot.
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    I have tried the image after it was created and it worked at that time. As far as i know, it was not updated since then so It should still work.

    Please post the exact error message that you get with your php file.
  12. flyingoat

    flyingoat New Member

    Thanks so much. you are right, it works. I finally figured it out. it was because I had given the php files too high privilege(767), so maybe suphp refuted to execute for security reasons!!!
    Thanks again.

Share This Page