VMWare Image corrupted - The Perfect Server - Ubuntu 10.04 (x86_64) [ISPConfig 3]

Discussion in 'Installation/Configuration' started by chrisphotonic, Dec 2, 2011.

  1. chrisphotonic

    chrisphotonic HowtoForge Supporter

    The Perfect Server - Ubuntu 10.04 (x86_64) [ISPConfig 3] (609.1 MB) (05/05/2010)

    I have a paid subscription, and I've downloaded: The Perfect Server - Ubuntu 10.04 (x86_64) [ISPConfig 3] twice.

    I tried converting the vmware image files to raw using: qemu-img convert Ubuntu\ 64-bit.vmdk -O raw Ubuntu10.04_x64.raw and qemu-kvm to play them, and I get:

    UNEXPECTED INCONSISTENCY: RUN fsck MANUALLY

    I also tried using VMWare's Player thinking it was just qemu-img's problem. I get the same error.


    Has anyone that has a paid subscription had that problem with this particular VM?
     
  2. till

    till Super Moderator

    Thanks for your report. We will check if the image is corrupted.
     
  3. chrisphotonic

    chrisphotonic HowtoForge Supporter

    More info:

    This is what vmware player says upon launch:

    The disk "/mnt/vm_images/The_Perfect_Server_Ubuntu_10.04_x86_64_ISPConfig_3/Ubuntu 64-bit.vmdk" has internal consistency errors that might be caused by partial corruption of the disk file. It is recommended that you restore a backup of this virtual machine. If you do not have a backup, VMware Player can repair the disk, but there is a possibility that the data on the disk may be corrupt and affect the stability of the guest.
    Do you wish to repair the disk and continue?
     
  4. chrisphotonic

    chrisphotonic HowtoForge Supporter

    Any updates on this?

    I tried some of the other images, and they all seem to work.

    It would be great to be able to download a good copy VM soon...

    Thanks!
    Chris
     
  5. falko

    falko Super Moderator

    I will check it, but not before Monday.
     
  6. falko

    falko Super Moderator

    You are right, the image is corrupt. I've removed it from the server (unfortunately I don't have a backup anymore because it's so old :().
     
  7. olimortimer

    olimortimer Member

    Ah that's gutting :( I was hoping to subscribe, download Ubuntu 10.04 with ISPConfig3 and go from there :(
     
  8. till

    till Super Moderator

    Why dont you use the current Ubuntu or even better Debian? Debian is the recommended Distribution for ISPConfig 3.
     
  9. olimortimer

    olimortimer Member

    Unfortunately the host I have my VPS with only has Ubuntu or CentOS - I was going to download the VM image, change the network settings, then restore onto my server. I was advised that it's best to run 10.04 in a live environment?

    I thought of doing the above, because I have an email issue I can't fix (http://www.howtoforge.com/forums/showthread.php?t=55228), so wanted to start with a server that was 100% setup correctly.
     
  10. chrisphotonic

    chrisphotonic HowtoForge Supporter

    The image is old but is an LTS (Long Term Support Version)

    The first time I found your site, I used one of these for my production server VMs and it worked out great for a years. I used an non-LTS version and there are no more critical updates. That's why I choose Ubuntu 10.04 LTS.

    Even though its quite old, Ubuntu 10.04 LT is still more up to date than CentOS/REL 5.xx .

    I actually don't need it anymore, because the perfect setup guide for Ubuntu is very easy to run though.

    I setup two servers using your guides over the weekend. Your guides are always excellent. I also bough your billing module. :cool: Glad I can help support howtoforge.
     
  11. till

    till Super Moderator

    When you restore a vm image, then it does not matter which other operating systems your host offers as the operating system of the VM is used. So if you host supports vmware based images, then you should be able to run every vmware image independantly of the used operating system.

    Regarding your email issue, do you use a email alias or a email domain alias. If you used a email domain alias, then its a known problem in courier setups which has been fixed in svn. You can apply that fix by editing the /var/vmail/.mailfilter file and change the line:

    Code:
    `echo $SIZE >> {dist_postfix_vmail_mailbox_base}/$HOST/$USER/ispconfig_mailsize`
    
    to:

    Code:
    `test -e {dist_postfix_vmail_mailbox_base}/$HOST/$USER`
    if ( $RETURNCODE == 0 )
    {
    `echo $SIZE >> {dist_postfix_vmail_mailbox_base}/$HOST/$USER/ispconfig_mailsize`
    }

    If you used a email alias, then it might be a problem with your setup.
     
  12. olimortimer

    olimortimer Member

    I agree that the guides are great, but it feels like I might have missed something, even though I followed the guides step-by-step - maybe because I'm not a Unix administrator, so I might have missed something which I needed to do but wasn't spelt out?

    I'm not using an email alias for my forwards, but applied the above anyway. The error has now changed from:

    Code:
    (temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied sh: cannot create /var/vmail/example.com/me/ispconfig_mailsize: Directory nonexistent /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/example.com/me/26050.0.host.server.com.)
    me@example.com
    ...to:

    Code:
    (temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/example.com/me/26170.0.host.server.com.)
    me@example.com
     
    Last edited: Dec 6, 2011

Share This Page