VMWare and Xen Management with BixData

Discussion in 'HOWTO-Related Questions' started by radox, Nov 5, 2006.

  1. radox

    radox New Member

    I will running Bixdata on a single machine with host being linux unbuntu and guest
    being windows2003 which part of the howto should I follow?

    radox
     
  2. falko

    falko Super Moderator ISPConfig Developer

    I think you must install the BixData agent on the same system as the server.
     
  3. radox

    radox New Member

    thanks for your post

    I installed agent and server on the linux host

    I have now arrived at the point in the howto where i am in the bixdata connections
    screen where i place my IP from my router which in this case is 192.168.1.64

    but the log shows
    <11/06/06 20:42:14> Launched BixDesktop
    <11/06/06 20:45:00> Connecting to 192.168.1.64:7071
    <11/06/06 20:45:01> Connecting to 192.168.1.64:7071
    <11/06/06 20:45:01> Can't connect to 192.168.1.64:7071
    <11/06/06 20:45:10> Connecting to 192.168.1.64:7071
    <11/06/06 20:45:10> Connecting to 192.168.1.64:7071
    <11/06/06 20:45:10> Can't connect to 192.168.1.64:7071

    I
     
    Last edited: Nov 6, 2006
  4. Jed

    Jed New Member HowtoForge Supporter

    perhaps bixagent is not running on 192.168.1.64
    (check with ps aux | grep bixagent)
    Try to install a bixagent on the same box as bixdesktop, and see if you can connect.

    Almost always this is a problem because agent is not running, or the machine you are trying to reach is behind a firewall / nat.
     
  5. radox

    radox New Member

    bixgent/bixserver

    ok this is what i got how . should i loginto to the bixserver ?
    you can see the 192.168.1.64 below which is my router.

    The other entry are a little strange as i have vmware onlinux with windows 20003 guest which has a NAT connection with IP address of 172.16.0.128 and default gateway
    of 172.16.0.2

    vmware was NOT runing when i issued the command
    [email protected]:~/bixdata/bixagent$ ./bixagent &

    [email protected]:~$ cd bixdata/bixagent
    [email protected]:~/bixdata/bixagent$ ./bixagent &
    [1] 12018
    [email protected]:~/bixdata/bixagent$ BixAgent version 2.6; Copyright 2004 - 2006 (http://www.bixdata.com)
    Using data path: /home/alex/bixdata/bixagent/data/
    Warning, missing x509 or private key file. Generating new files
    Public Key Signature D076D089B885ACB86B2CAC63D4F7736F6E2C1237
    SMART :: Unable to obtain read access to /dev/hda (13) [-1]
    SMART plugin :: Unable to enable native SMART support
    sh: /usr/local/sbin/smartctl: No such file or directory
    Authentication disabled
    Own default port 17070
    Auto enumerating interfaces
    Found Interface 127.0.0.1
    Creating listener on 127.0.0.1:17070
    Found Interface 192.168.1.64
    Creating listener on 192.168.1.64:17070
    Found Interface 172.16.0.1
    Creating listener on 172.16.0.1:17070
    Found Interface 172.16.163.1
    Creating listener on 172.16.163.1:17070
     
  6. Jed

    Jed New Member HowtoForge Supporter

    yes that looks like the agent is running fine except for the SMART plugin which you probably don't need.
     
  7. radox

    radox New Member

    bixdata

    thanks for your post but you did not answer my question

    after starting bixdata agent as i have shown in my last post what next?
    when i run bixdata server
    there are two boxes
    server
    agent
    QUESTION 1
    it seems that that IS SOMETHING GOING NO HERE OI WAS UNAWARE OF.

    if you look at the last post you will see an entry for 172.16.0.1 what is that
    as there are many process running on that
    I thought it a NAT connection on my vmware but its not as that IP is 172.16.0.128
    and default gateway 172.16.0.2
    RATHER than one sentence replies please say a little more?

    QUESTION2

    why is it neccessary to run bixdate agent before running
    bixdata server?
     
    Last edited: Nov 13, 2006
  8. wanderer

    wanderer New Member

    ./bixagent
    BixAgent version 2.8; Copyright 2004 - 2006 (http://www.bixdata.com)
    Using data path: /home/marius/bixdata/bixagent/data/
    Public Key Signature 11C1D8865382073C80ADEBE5DB5B718A4CBC85C4
    sh: /usr/sbin/smartctl: No such file or directory

    Smart errno2 22
    SMART plugin :: Unable to enable native SMART support
    Authentication disabled
    Own default port 17070
    Auto enumerating interfaces
    Found Interface 127.0.0.1
    Creating listener on 127.0.0.1:17070
    Found Interface 192.168.1.66
    Creating listener on 192.168.1.66:17070

    This is the message that i receive when i start bixagent and bixdesktop do no't connect to him help please.
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Which distribution do you use?
     

Share This Page