VMware 2.0 on ubuntu server 8.04

Discussion in 'HOWTO-Related Questions' started by robertomason, Jan 3, 2009.

  1. robertomason

    robertomason New Member

    I'm running a Quad Core 64 bit Intel. I'm testing several VM software. I've tried XEN, KVM and now I'm tying out VMware. I've had success with VMware on Centos 5.2-64bit. It installs flawlessly with no problems, and I've been able to create serveral vm's (Windows XP, Vista, Centos and Ubuntu). They work perfectly.

    With Ubuntu 8.04 64-bit, I've installed Kubuntu-desktop. All the updates have b een applied, kernel updated. I installed VMware 2.0 from tar file, Again it was straight forward. I came accross a problem in the installation, and that is when
    the installation performed the VMware-config. It gave me the following message:

    None of the pre-built vmmon modules for VMware Server is suitable for your
    running kernel. Do you want this program to try to build the vmmon module for
    your system (you need to have a C compiler installed on your system)? [no] yes

    Using compiler "/usr/bin/gcc". Use environment variable CC to override.

    Your kernel was built with "gcc" version "4.2.3", while you are trying to use
    "/usr/bin/gcc" version "4.2.4". This configuration is not recommended and
    VMware Server may crash if you'll continue. Please try to use exactly same
    compiler as one used for building your kernel. Do you want to go with compiler
    "/usr/bin/gcc" version "4.2.4" anyway? [no]

    When I answered yes, it compiled properly, no error message.

    I then proceeded to create my first vm, Centos 5.2-64bit. I created the vm, installed the software with no apparent problems. When it did the first install, on boot up it got stuck in the undev portion, frozen. I tried it a couple of times with the same result. :confused:

    Anyone come accross the same problem?
    Was there a solution?
    Is it possible to install gcc 4.2.3 on Centos 5.2?
    Can it co-exist with gcc 4.2.4?

    Thanks in advance::D
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried to set up VMs with different Linux distributions (e.g. Ubuntu or Debian)? Maybe it's just a problem with CentOS...
     
  3. robertomason

    robertomason New Member

    VMware 2.0 on ubuntu server 8.0

    I think you miss understood me, It works well with Centos. It's with Ubuntu where i had the proboem
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Yes, but you tried to create a CentOS VM - that's what I was referring to.
     
  5. robertomason

    robertomason New Member

    VMware 2.0 on ubuntu server 8.0

    I've re-installed my Ubuntu 8.04 server 64 bit, and re-installed VMware 2.0, and whatta u know, it worked. but I did notice something. Though it's been working well, I occaisonally have problems installing new os's, in this case a vm of ubuntu 8.04 32bit. It just seems to get to a point and it just hangs there. I destroy the vm and creat a new one, it then it'll install
     

Share This Page