vlogger: piped log program failed unexpectedly

Discussion in 'Installation/Configuration' started by jpwalters, May 3, 2012.

  1. jpwalters

    jpwalters New Member

    Ubuntu 12.04 LTS
    ISPConfig Version:

    I'm getting the following errors numerous times in my apache2 error.log file.

    piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
    How can I resolved this issue?

    Note: I read this other post and installed perl-DBD-mysql perl-DBI and then restarted apache but I'm install getting the same error.
  2. till

    till Super Moderator Staff Member ISPConfig Developer


    apt-get install vlogger

    to see if any required packages are missing.
  3. jpwalters

    jpwalters New Member

    root@domU-12-31-39-03-C0-08:/tmp/sasl# apt-get install vlogger                                                                                                  Reading package lists... Done                                                                                                                                   Building dependency tree                                                                                                                                        Reading state information... Done                                                                                                                               
    vlogger is already the newest version.
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
     libsasl2-modules-sql : Depends: libmysqlclient16 (>= 5.1.21-1) but it is not installable
    Great so that's the problem...vlogger is missing a dependency. Which I likely created the problem myself.

    History: Over the weekend I upgraded Ubuntu from 11.xx to 12.04. After I did that I ran into this issue "saslauthd: SASL PLAIN authentication failed: no mechanism available" ... which basically just meant I couldn't send emails. I followed this post http://www.howtoforge.com/ubuntu-11...-authentication-failed-no-mechanism-available and that fixed my problem. Ultimately the fix was just to downgrade a few packages from version libsasl2-2_2.1.25 to libsasl2-2_2.1.23 which possibly is what has broken vlogger.

    If I run apt-get -f install as suggested it will re-upgrade to version x.25 which cause the emailing sending problem but still I end up with libmysqlclient16 (>= 5.1.21-1) not getting installed.

    How can I install libmysqlclient16 without also upgrade to version x.25 to keep from breaking my other issue?

    Note: If I had a path to switch to using Dovecot (instead of Courier) for smtp authentication then the email sending issue would likely get resolved and possible my currently issue would also get resolved.

    Thanks for the quick help.
  4. falko

    falko Super Moderator ISPConfig Developer

Share This Page