Vitrual Hosting with ProFtpd & MySql on Fedora 9

Discussion in 'Tips/Tricks/Mods' started by razvan_vlad, Jul 30, 2008.

  1. razvan_vlad

    razvan_vlad New Member

    just a quick question on the "Virtual Hosting with Proftpd and MySql on Fedora 9"...
    i followed the Fedora 9 Perfect server setup and installed ISPConfig after that. Then i wanted to change the ProFtpd to use MySQL by following the above mentioned tutorial; went back on ISPConfig and created a FTP user for a website but i can't log in. I receive the 530 login invalid. I think ISPConfig gets confused on what database to create the ftp-user? Is this correct?
    Then i created the same tables but in the database i use for ISPConfig but still receive the 530 error.
    How can i integrate ProFtpd to use MySql and be able to create ftp-users on ISPConfig and log in?

    Thank you,
    Raz.
     
  2. till

    till Super Moderator

    You can not use ISPConfig with the Virtual Hosting with Proftpd and MySql on Fedora 9 setup. FTP is already configured for ISPConfig when you followed the perfect setup guide.

    You cant.
     
  3. razvan_vlad

    razvan_vlad New Member

    oh.. so.. it's either I set-up the ProFtpd to use MySql for virtual users, which implies i will have to create each user manually, either i let ProFtpd be used by ISPConfig, and those users created by ISPConfig will be placed in ISPConfig's database, but those would be system users.

    Now, i have asked this because in a previous installation with Perfect Setup, ProFtpd worked. What i mean is i could upload files to some directories (root folder.. others) but i couldn't CHMOD them. It said permission denied. How do i have to set this up so when i create an user within ISPConfig to be able to CHMOD his folders?

    Thank you so much for your help,
    Raz.
     
  4. till

    till Super Moderator

    Just allow chmod in proftpd.conf, it is denied by default. But thats nothing ispconfig specific and applies to any default proftpd installation.

    Changing proftpd to the virtual setup messed the configuration up now, you will have to undo very step rom the virtual proftpd setup.
     
  5. razvan_vlad

    razvan_vlad New Member

    i am at work now and my server's at home, off. but I am pretty sure i checked for Allow CHMOD in proftpd.conf and it was allowed. Still, did not work. The only option i had was to log in as root on the server and manually change folder permissions.
    And if I am not mistaken, the Allow CHMOD option was not in proftpd.conf but in proftpd_ispconfig.conf which was included in proftpd.conf.
     
  6. razvan_vlad

    razvan_vlad New Member

    CHMOD in /html directory but not in other folders

    CHMOD was Allowed from default in /etc/proftpd.conf:
    Code:
    <Limit SITE_CHMOD>
        AllowAll
      </Limit>
    It doesn't work to change permissions for the folders in root dir (/) but you can CHMOD inside the /html directory created in the root folder.
    Also i created other subfolders but can't change permissions for those. :(

    help please.

    Thanks guys.
     
  7. till

    till Super Moderator

    It is the intention that you are not able to change permissions in the root folder, as these files are not owned by the web administrator. If you would change them, you wold mess up the configuration and e.g. the mail deliver will fail or apache might refuse to start.
     
  8. razvan_vlad

    razvan_vlad New Member

    yes.. i figured it out. sorry about that.

    my post above is not 100% precise.. i am able to CHMOD the folders created by me through the FTP client only!

    what needs to be done so i can change permissions on those folders and files?
    thanks.
     
  9. till

    till Super Moderator

    As I pointed out above. You can not do this without messing up the configuration.
     
  10. razvan_vlad

    razvan_vlad New Member

    i was talking about folders inside the /root/html directory.
    I can only change permission for folders i create myself but not for the ones i uploaded (e.g: my own website folders).
    How do i get to be able to change permission on those? I think it has to do something with .. ownership under Linux? But how?

    thanks,
    raz.
     
  11. falko

    falko Super Moderator

    Please make sure that the files and directories are owned by the FTP user. You can check that with the
    Code:
    ls -l
    command, for example. you can use the chown command to change ownerships.
     
  12. razvan_vlad

    razvan_vlad New Member

    ok.. so if the files are not owned by the ftp user, how fo i set this to be done automatically when i create a new FTP user in ISPConfig?
    thanks falko.
     
  13. falko

    falko Super Moderator

    Upload your files/directories as that FTP user, and they will be owned by this user automatically.
     
  14. razvan_vlad

    razvan_vlad New Member

    I do log in as that FTP User on my FTP Client (SmartFtp) if this is what you mean. But i just can't CHMOD/override/delete/move some files/folders .
     
  15. falko

    falko Super Moderator

    Please take a look at post #11 again and check the permissions of these files/directories.
     

Share This Page