Virus not working

Discussion in 'Server Operation' started by wp.rauchholz, Jan 30, 2011.

  1. wp.rauchholz

    wp.rauchholz New Member

    My setup: Fedira 14; spamassassin (as daemon), procmail, dovecot, postifx and clamav/clamavsmtp
    Spamassassin works just fine, but I cannot get clamav/clamsmtp to work
    I am sitting now hours in front of my server and try to debug this, but I give up!!

    Error message I get:
    an 30 19:31:41 home spamd[29191]: spamd: clean message (0.5/5.0) for nobody:99 in 5.3 seconds, 1746 bytes.
    Jan 30 19:31:41 home spamd[29191]: spamd: result: . 0 - DKIM_SIGNED,DKIM_VALID,DKIM_VALID_AU,FREEMAIL_FROM,RCVD_IN_DNSWL_LOW,RDNS_NONE,T_TO_NO_BRKTS_FREEMAIL scantime=5.3,size=1746,user=nobody,uid=99,required_score=5.0,rhost=home.theragafamily.com,raddr=127.0.0.1,rport=45294,mid=<AANLkTingkJn599Z=[email protected]>,autolearn=no
    Jan 30 19:31:41 home postfix/pickup[32464]: 52664E098F: uid=99 from=<[email protected]>
    Jan 30 19:31:41 home postfix/cleanup[32529]: 52664E098F: message-id=<AANLkTingkJn599Z=[email protected]>
    Jan 30 19:31:41 home postfix/pipe[32530]: 7FD2AE098D: to=<[email protected]>, relay=spamassassin, delay=6, delays=0.7/0.01/0/5.3, dsn=2.0.0, status=sent (delivered via spamassassin service)
    Jan 30 19:31:41 home postfix/qmgr[32465]: 7FD2AE098D: removed
    Jan 30 19:31:41 home spamd[29190]: prefork: child states: II
    Jan 30 19:31:41 home postfix/qmgr[32465]: 52664E098F: from=<[email protected]>, size=2200, nrcpt=1 (queue active)
    Jan 30 19:31:41 home clamsmtpd: 100000: accepted connection from: 127.0.0.1
    Jan 30 19:31:41 home postfix/smtpd[32553]: initializing the server-side TLS engine
    Jan 30 19:31:41 home postfix/smtpd[32553]: connect from home.theragafamily.com[127.0.0.1]
    Jan 30 19:31:41 home postfix/smtpd[32553]: 6DC8FE098D: client=home.theragafamily.com[127.0.0.1]
    Jan 30 19:31:41 home clamsmtpd: 100000: couldn't open cache file: Permission denied
    Jan 30 19:31:41 home clamsmtpd: 100000: from=[email protected], to=[email protected]
    Jan 30 19:31:41 home postfix/smtpd[32553]: warning: non-SMTP command from home.theragafamily.com[127.0.0.1]: X-Spam-Checker-Version: SpamAssassin 3.3.2-r929478 (2010-03-31) on
    Jan 30 19:31:41 home postfix/smtpd[32553]: disconnect from home.theragafamily.com[127.0.0.1]
    Jan 30 19:31:41 home postfix/smtp[32551]: 52664E098F: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10025, delay=0.14, delays=0.06/0.02/0.06/0, dsn=4.0.0, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 Local Error (in reply to end of DATA command))


    clamav and clamsmtpd are up and running
    clamsmtp 32134 1 0 19:24 ? 00:00:00 clamd.clamsmtp -c /etc/clamd.d/clamsmtp.conf --pid /var/run/clamd.clamsmtp/clamd.pid
    clamav 32231 1 0 19:27 ? 00:00:00 /usr/sbin/clamsmtpd -f /etc/clamsmtpd.conf -p /var/run/clamd.clamsmtp/clamsmtpd.pid


    These are my configs
    /etc/clamd.conf
    LogFile /var/log/clamd.clamsmtpd
    LogTime yes
    LogSyslog yes
    DatabaseDirectory /var/lib/clamav
    LocalSocket /var/run/clamd.clamsmtpd/clamd.sock
    LogSyslog yes
    DatabaseDirectory /var/lib/clamav
    LocalSocket /var/run/clamd.clamsmtpd/clamd.sock
    FixStaleSocket Yes
    TCPAddr 127.0.0.1
    User clamav
    ScanMail yes

    /etc/init.d/clamsmtpd.conf
    OutAddress: 127.0.0.1:10026
    ClamAddress: /var/run/clamd.clamsmtpd/clamd.sock
    User: clamav


    /etc/postfix/main.cf
    # Configure clamsmtp/clamav into Postix
    content_filter = scan:127.0.0.1:10025
    receive_override_options = no_address_mappings

    /etc/postfix/master.cf
    scan unix - - n - 16 smtp
    -o smtp_send_xforward_command=yes
    # Para la inyección de vuelta a postfix desde el filtro
    127.0.0.1:10026 inet n - n - 16 smtpd
    -o content_filter=
    -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks,no_address_mappings
    -o smtpd_helo_restrictions=
    -o smtpd_client_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,reject
    -o mynetworks_style=host
    -o smtpd_authorized_xforward_hosts=127.0.0.0/8


    Thanks
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    getenforce
    ?
     
  3. wp.rauchholz

    wp.rauchholz New Member

    [root@home tmp]# getenforce
    Disabled
     
  4. falko

    falko Super Moderator ISPConfig Developer

  5. wp.rauchholz

    wp.rauchholz New Member


    ...amavis amavis amavisd
    ...clamtsmtp mail clamd.clamsmtp

    ... I guess I know now what to do
    chown amavis,amavis clamd.clamsmtp
     

Share This Page