Virtusertable problems.

Discussion in 'Installation/Configuration' started by djtremors, Aug 30, 2006.

  1. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    Hey all,

    I'm getting frustrated on how ispc handles virtual user tables in postfix.

    Firstly, when creating a new user email, there is the email domain address label next to the box with a
    But when I create the email it creates numerous email addresses like so :

    [email protected] web14_user
    [email protected] web14_user

    I can't get it to create the proper email address without the "www" and i don't know why it's adding it in when the email address in the "user & email" section doesn't display it.

    Some other domains don't have this so I don't know how the hell I did it right the other time as both domains look the same in setup configuration.


    Time for me to use mysql postfix mods to handle virtual domains/users.
  2. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    argh ok.. i'm here solving my own issues again.

    Creating a co-domain of just instead of the main site of forces it to create alias emails for both domains.

    I would've prefered the main domain to NOT have a host and automatically have www as a default host but only do emails for the non www domain. so you only end up with :

    [email protected] web1_user

    instead of

    [email protected] web1_user
    [email protected] web1_user

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats the way ispconfig works, i dont think we will change this behaviour in ISPconfig 2.x.

Share This Page