virtusertable not getting updated

Discussion in 'Installation/Configuration' started by 22hn, May 20, 2006.

  1. 22hn

    22hn New Member

    Hi!

    I'm quite new to both Linux, Postfix and ISPConfig and have a couple of questions for you...

    If I add a site in ispconfig and then add an email user to that site, shouldn't the virtusertable and local-host-names files be updated then?

    The only way I can get something to happen, is by manually running the command '/root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php' (found in another thread).

    Then my virtusertable file gets updated with these 3 lines:
    www.domain1.com VIRTUALDOMAIN
    mike@www.domain1.com web8_mike
    web8_mike@www.domain1.com web8_mike

    But still no change in local-host-names...

    Why is the www-part included in the email address? When editing the email user in ispconfig, it's not...

    Another thing... The autogenerated 'web8_'-prefix, can that be changed?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Maybe the server daemon thread has died. Please restart ISPConfig:

    /etc/init.d/ispconfig_server restart

    local-host-names changes only if you add an new website or co-domain.
    In you case the co-domain domain1.com (with empty host field) is missing in the website www.domain1.com.

    http://www.howtoforge.com/faq/14_47_en.html
     
  3. trueshanti

    trueshanti New Member

    i didnt like the www-part either .. makes nasty aliases in roundcubemail with auto-created users

    so i fixed some libs
    Code:
    root#:>/root/ispconfig.bak/scripts/lib/classes# diff ispconfig_postfix.lib.php ispconfig_postfix.lib.php.orig
    203c203
    <             if(!empty($web["web_host"]) and trim($web["web_host"]) != www [I]and trim($web["web_web_domain"]) != "[B]somesubdomain[/B]"[/I]){
    ---
    >             if(!empty($web["web_host"])){
    303,308c303,307
    <
    <           if(trim($web["web_host"]) != "" and trim($web["web_host"]) != www ){
    <                $virtualdomain = $web["web_host"].".".$web["web_domain"];
    <                 } else {
    <                $virtualdomain = $web["web_domain"];
    <               }
    ---
    >           if(trim($web["web_host"]) != ""){
    >             $virtualdomain = $web["web_host"].".".$web["web_domain"];
    >           } else {
    >             $virtualdomain = $web["web_domain"];
    >           }
    339c338
    <               if(trim($codomain["domain_host"]) != "" and trim($codomain["domain_host"]) != www){
    ---
    >               if(trim($codomain["domain_host"]) != ""){
    419c418
    < ?>
    ---
    > ?>
    \ No newline at end of file
    
    
    i also make some template-changes vor named and procmail but non for postfix

    -c-
     
  4. 22hn

    22hn New Member

    Using trueshanti's code change I got rid of the annoing extra codomain to get the alias file correct. Thanks trueshanti!

    But I still have to run the writeconf script to change any file contents ... And the deamon is running...

    I also got rid of the username prefix...!


    I added a test account and was able to login to the web mail. I successfully sent an outgoing email that arrived at it's destination. So far so good!

    I then sent an email to this test user from the internet. The email is accepted by postfix and the sending smtp server receives an OK!

    But it newer reaches the users inbox...!

    and the mail log is constanly repeating:
    postfix/master[12474]: warning: /usr/lib/postfix/local: bad command startup -- throttling
    postfix/local[12727]: fatal: open database /etc/postfix/virtusertable.db: Operation not permitted
    postfix/master[12474]: warning: process /usr/lib/postfix/local pid 12727 exit status 1
    postfix/master[12474]: warning: /usr/lib/postfix/local: bad command startup -- throttling

    This "operation not permitted" is seen in both /var/log/mail and /var/log/mail.err.

    I also get the same response when doing a 'postmap /var/postfix/virtusertable'

    Any ideas on this 'operation not permitted' error?
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Which distribution do you use? Fedora or SuSE? If you use Fedora, then disable SELinux, if you are on SuSE, disable AppArmor.
     
  6. 22hn

    22hn New Member

    Aaarrrghhhh... So obvious, but yet so hard to crack...!


    Thanks a lot falko!
     

Share This Page