virtualhost doesn't work

Discussion in 'Installation/Configuration' started by fswolf, Aug 9, 2008.

  1. fswolf

    fswolf New Member

    Hello, I just install ISPconfig and ewerything works fine, I made a new customer, new website with ftp user. FTP works fine, but when I write URL tu my browser I see just "It works" then I have to manualy edit /etc/apache2/httpd.conf width:
    <VirtualHost *>
    DocumentRoot /var/www/web2/web

    And then everithing works OK, do anyone know why its not work automatically.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    First, please undo the manuals editing. Then, have a look if the file vhosts/Vhost_ispconfig.conf is included at the end of your httpd.conf or apache2.conf file.
  3. fswolf

    fswolf New Member

    Nothing changed

    I have done it. I deleted <VirtualHost *> ..... in httpd.conf but there was already line: Include /etc/apache2/vhosts/Vhosts_ispconfig.conf in the end of file apache2.conf. Now it doesen't work again.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Do you have copies of the file Vhosts_ispconfig.conf with a date appended to the filename in the same directory?

    2) Have you selected the correct IP address for the website in ISPConfig? If your server is behind a router, you must use the internal IP address and not the external IP address. Also make sure that you access the website by domain anme and not IP address.
  5. fswolf

    fswolf New Member


    Thanks a lot, I wrote there a wrong IP address, I wrote and I have - I know - stupid mistake - thanks!

Share This Page