Virtual Users.....: pop3d-ssl: chdir No such file or directory

Discussion in 'HOWTO-Related Questions' started by dinnouti, Nov 9, 2006.

  1. dinnouti

    dinnouti New Member

    Hi I follow the "Virtual Users And Domains With Postfix, Courier And MySQL (Fedora Core 5)" and I getting the error:

    Nov 9 14:48:41 x-apache pop3d-ssl: Connection, ip=[XXXXX]
    Nov 9 14:48:41 x-apache pop3d-ssl: chdir XXXX.com/sales/: No such file or directory
    Nov 9 14:48:44 x-apache pop3d-ssl: Connection, ip=[XXXXX]
    Nov 9 14:48:44 x-apache pop3d-ssl: chdir XXXX.com/sales/: No such file or directory

    any guess?

    I bet 40% is something I mistype, 35% I just forget to type, 15% I overlooked and 10% is a real error. :)

    Thanks
    Alex.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you send an email to that user before you tried to fetch mails? Maildir is created when the first email for that user arrives.
     
  3. dinnouti

    dinnouti New Member

    I will send an email and let you know.
    Thanks!
    Alex.
     
  4. dinnouti

    dinnouti New Member

    I still have the same problem

    I was able to send to the mailbox

    # mail
    Mail version 8.1 6/6/93. Type ? for help.
    "/var/spool/mail/root": 1 message 1 new
    >N 1 root@localhost.local Sat Nov 11 15:58 26/1101 "test"
    & 1
    Message 1:
    From root@localhost.localdomain Sat Nov 11 15:58:51 2006
    X-Original-To: sales@XXXX.com
    Delivered-To: root@XXXX.com
    X-Virus-Scanned: amavisd-new at localhost
    Date: Sat, 11 Nov 2006 15:58:45 -0500
    From: root <root@localhost.localdomain>
    To: sales@XXXX.com
    Subject: test

    test 1 2 3

    & q
    Saved 1 message in mbox


    But when I check the mailbox the mailog shows:

    Nov 11 16:00:25 XXXX pop3d-ssl: Connection, ip=[XXXXX]
    Nov 11 16:00:25 XXXX pop3d-ssl: chdir XXXXX.com/sales/: No such file or directory


    The /home/vmail folder is empty, the permissions seems right

    home]# stat vmail
    File: `vmail'
    Size: 4096 Blocks: 8 IO Block: 4096 directory
    Device: fd00h/64768d Inode: 3538945 Links: 2
    Access: (0700/drwx------) Uid: ( 5000/ vmail) Gid: ( 5000/ vmail)
    Access: 2006-11-11 16:08:32.000000000 -0500
    Modify: 2006-11-08 20:07:52.000000000 -0500
    Change: 2006-11-08 20:07:52.000000000 -0500


    Thanks
    Alex.
     
    Last edited: Nov 11, 2006
  5. falko

    falko Super Moderator ISPConfig Developer

    Your mail to sales has been delivered to root! Did you set up any forwarding rules? Is XXXX.com listed only in mydestination in /etc/postfix/main.cf, or also in the domains table in the MySQL database?
     
  6. dinnouti

    dinnouti New Member

    It's listed in the MySQL and main.cf (mydestination and myhostname)

    Alex.
     
  7. falko

    falko Super Moderator ISPConfig Developer

    You cannot have a domain in mydestination that is in the domains table and vice versa.
    If you want to use the domain for virtual email accounts, list it in the domains table; if you want to use it for "real" email accounts, put it in mydestination.
     
  8. nl0pat

    nl0pat New Member

    similar problem

    To start, I want to apologise for hijacking this thread, but I think I have similar problems.
    I keep getting a message in my /var/log/maillog saying:
    Code:
    Nov 14 23:22:05 aaa postfix/trivial-rewrite[3436]: warning: do not list domain aaa.bbb.com in BOTH mydestination and virtual_mailbox_domains
    I tried this:
    [root@aaa ~]# postconf -n | grep mydestination
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    and as you can see I have nu mydestiniation set.

    Any ideas on what could cause this message then ?

    Besides, in the tutorial itself i see:
    so initially I changed this to
    I want to remark that my server aaa.bbb.com should be mailserver for the domain aaa.bbb.com and is also named like that. I think this should not be causing my problems, but just wanted to let you know.
     
  9. falko

    falko Super Moderator ISPConfig Developer

    There must be a mydestination line in main.cf if you followed the tutorial (unless you deleted it afterwards).
    What's the output of
    Code:
    postconf -d | grep mydestination
    ?
     
  10. nl0pat

    nl0pat New Member

    Output of
    Code:
    [root@aaa ~]# postconf -d | grep mydestination
    mydestination = $myhostname, localhost.$mydomain, localhost
    
    I have tried and tried and I think in my struggling to get it running I have also tried deleting the mydestination and haven't put it back afterwards.
    So I've checked in the tutorial once again and indeed found the line where we should set mydestination. So I changed it to what the tut says. My output of postconf -e | grep mydestination now says:
    Code:
    mydestination = aaa.bbb.com, localhost, localhost.localdomain
    
    What I've just come up with now, is that this doesn't change a thing because in the previous situation with an absent mydestination variable postfix would have taken its defaults, which is $myhostname which is also aaa.bbb.com
    After I changed it I restarted postfix.
    For testing I delivered a message for this domain and I still get:
    Code:
    Nov 16 07:07:56 aaa postfix/trivial-rewrite[3081]: warning: do not list domain aaa.bbb.com in BOTH mydestination and virtual_mailbox_domains
     
  11. falko

    falko Super Moderator ISPConfig Developer

    So you have aaa.bbb.com both in mydestination and in the domains table. You must remove it from one of them.
     
  12. nl0pat

    nl0pat New Member

    Yes as I said in my starting post I have the machine named at the domain it should be mailserver for.
    Is there any way to make this a working situation?:confused:
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Use another hostname for your server. The ideal way would be to get a "technical domain", i.e. a domain that you don't use for web hosting, FTP, etc., but only for naming your servers. That's how I do it.
     
  14. nl0pat

    nl0pat New Member

    Ok,

    I get it, have tried it today and found that this works, I have now labeled the postfix box to hostname.aaa.bbb.com.
    Very much thanks for supporting me and thumbs up for the good howto you wrote..

     
  15. swydo

    swydo New Member

    Hi,

    Sorry to refloat this post. I'm having exactly the same problem nl0pat had. I tried to change the hostname and so on, but the problem still there.

    Here's a copy of the error given by mail.log

    And a copy of the "postconf -d | grep mydestination"

    Maybe it is due to a step I didn't consider when following the howto. Anyway I have no installed Spamassasin, ClamAV...


    Thanks in advance for your support.
     
  16. falko

    falko Super Moderator ISPConfig Developer

    Did you send a mail to that account first? Maildir is created automatically when the first email arrives.
     
  17. swydo

    swydo New Member

    I did, and now it works except for the SMTP server.

    That's what my log says:

    When I try to connect to SMTP server, I always receive a login error, and then the message above on the mail.log


    Any suggestion??


    Thanks in advance :)
     
  18. swydo

    swydo New Member

    Solved.

    I had just to do this:


    Thanks!
     

Share This Page