Virtual users passwords are being rejected? (postfix)

Discussion in 'Installation/Configuration' started by benjamin_robert, Jul 25, 2008.

  1. benjamin_robert

    benjamin_robert New Member

    Hi, While trying to get postfix up and running with ISPConfig suddenly the passwords of virtual users are not longer being accepted (previously they just hadn't been able to receive email - though the users on the 'home' server seem to be ok). If anyone has any suggestions they are most welcome! Thank you. Ben
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 2 or ISPCOnfig 3?
     
  3. benjamin_robert

    benjamin_robert New Member

    Hi Brehm, thanks for your fast response, it is Version: 2.2.21
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, ISPConfig 2 does not use virtual mail users, it uses linux system users for email and the user passwords are stored in /etc/shadow.

    Which is the error message that you get in the mail log when you try to authenticate with a mail user?
     
  5. benjamin_robert

    benjamin_robert New Member

    Hi Brehm, that makes sense since the host server's user emails are ok. The message is 'Aborted login' (i'm using Dovecot for pop)...
    Ben
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the exact error message from the mail log, not the error message that you got in the pop3 client.
     
  7. benjamin_robert

    benjamin_robert New Member

    Hi Brehm, thanks for your efforts with this - i was trying to go back to where i had the settings earlier when it worked and i got it logging in now, but back to the old chestnut where email bounces back with a User unknown message (550 5.1.1 User unknown). Can you recommend anything for this?

    Curiously, if you send mail from a user account to another user account it works ok. It's only 'foreign' incoming emails that get the bounceback.

    The maillog confirms the user is logging in and out ok now.

    And, as usual, the @ homeserver accounts are all fully functional. It's the sites not named after the home server that are failing here.

    Your help appreciated!

    Ben
     
  8. benjamin_robert

    benjamin_robert New Member

    I narrowed it down a little.

    mydestination =/etc/postfix/local-host-names
    overcomes a 'relay access denied' error message, and,

    virtual_maps = hash:/etc/postfix/virtusertable
    enables email to go between users, and from outside users to the home server users... (which are those home server users actually written into virtusertable, rather than linux users)

    so it looks like those files are being referenced correctly.. but somehow incoming mail from non local users to @domains other than the hostname are getting bounced back with a user unknown message..... but in the maillog those all users are logging in and out ok with no error messages....
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Is the email address that you want to send mail to listed in /etc/postfix/virtusertable
    2) Please post the exact error message from the mail log file, not the message that the sender gots back via mail.
     
  10. benjamin_robert

    benjamin_robert New Member

  11. till

    till Super Moderator Staff Member ISPConfig Developer

    If you dont see anthing in the mail.log, then the mail was never sent to this server. I guess that it is a DNS issue and nothing with your mail system. Please make sure that the MX record for the domain points to the correct server.

    You should also check that the dns A-Record for the domain points to the correct server too.

    Be aware that changes in DNS may take up to 48 hours to propagate.
     
  12. benjamin_robert

    benjamin_robert New Member

    Brehm,
    I talked to the guy doing the DNS for the domains, it sounds suspicously like there was a mis-setting. I'll come back to this later/tomorrow when DNS has updated.

    I have a strong hope this will fix it. What is the best way to recompense you for your time?
     
  13. benjamin_robert

    benjamin_robert New Member

    As they say, if you want something done do it yourself! Finally success with the MX update. Let me know re making a contribution.
     

Share This Page