Virtual Users & Domains With Postfix, [...] SquirrelMail Conn. dropped by IMAP ubuntu

Discussion in 'HOWTO-Related Questions' started by danstinebaugh, Dec 27, 2012.

  1. danstinebaugh

    danstinebaugh New Member

    Just finished going through the Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 12.10) post and again I'm amazed at the thoroughness of your guides. Thank you for all that you do!

    However I'm getting stuck so close to the end, and I'm not sure what could be causing the error.

    I've gotten to the end where I'm trying to login as the test user created to squirrelmail but am getting the error "ERROR: Connection dropped by IMAP server.
    "

    [​IMG]

    Here is the results from a netstat -tap:
    Code:
    root@mail1:/var/log# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:http                  *:*                     LISTEN      4319/apache2
    tcp        0      0 *:ssh                   *:*                     LISTEN      2519/sshd
    tcp        0      0 *:smtp                  *:*                     LISTEN      27367/master
    tcp        0      0 localhost.localdo:10024 *:*                     LISTEN      1660/amavisd-new (m
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN      27367/master
    tcp        0      0 localhost.localdo:mysql *:*                     LISTEN      7930/mysqld
    tcp       59      0 localhost.localdo:40045 localhost.localdo:10025 CLOSE_WAIT  1665/amavisd-new (c
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      2519/sshd
    tcp6       0      0 [::]:smtp               [::]:*                  LISTEN      27367/master
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      21734/couriertcpd
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      21802/couriertcpd
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      21765/couriertcpd
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      21697/couriertcpd
    I've made sure to replace the mail_user_password in all of the references in the walkthrough (At least I'm pretty sure I did!) and everything seems to be working correctly,

    telnet results:
    Code:
    root@mail1:/var/log# telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.localdomain.
    Escape character is '^]'.
    220 my.hidden.host ESMTP Postfix (Ubuntu)
    ehlo localhost
    250-my.hidden.host
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH PLAIN LOGIN
    250-AUTH=PLAIN LOGIN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    quit
    221 2.0.0 Bye
    Connection closed by foreign host.
    
    Anyone have any ideas on where I should start troubleshooting this? imap I'm guessing, but could use some guidance.

    Also I have sent each of the test account's I've created a test email using the mailx command as stated in the guide.

    Thanks in advance!
     
    Last edited: Dec 27, 2012
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Are there any errors in your mail log (in the /var/log/ directory)?
     
  3. danstinebaugh

    danstinebaugh New Member

    The only error's I've got in my mail.err file is the following:

    Code:
    root@mail1:/var/log# cat mail.err
    Dec 26 19:46:46 mail1 imapd: sales@example.com: No such file or directory
    Dec 26 19:47:33 mail1 imapd: sales@example.com: No such file or directory
    Dec 26 19:51:17 mail1 imapd: sales@example.com: No such file or directory
    Dec 26 19:54:38 mail1 imapd: sales@example.com: No such file or directory
    Dec 26 19:55:09 mail1 imapd: daniel@example.com: No such file or directory
    Dec 26 19:58:25 mail1 imapd: sales@example.com: No such file or directory
    Dec 26 20:26:54 mail1 imapd: sales@example.com: No such file or directory
    
    I created the daniel@example.com from phpmyadmin just to test on a second account, with the same result.
    Here is a link to my mail.log pastebin. http://pastebin.com/ckFxnfDr
     
    Last edited: Dec 29, 2012
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please post your /etc/postfix/main.cf.
     
  5. DuaBeo35

    DuaBeo35 New Member

    i have same error. This is my main.cf

    # See /usr/share/postfix/main.cf.dist for a commented, more complete version


    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    readme_directory = /usr/share/doc/postfix

    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    myhostname = mail.hactech.vn
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = mail.hactech.vn, localhost, localhost.localdomain
    mydestination = localhost, localhost.localdomain
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    html_directory = /usr/share/doc/postfix/html
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /home/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    virtual_maildir_extended = yes
    virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
    virtual_mailbox_limit_override = yes
    virtual_maildir_limit_message = "The user you are trying to reach is over quota."
    virtual_overquota_bounce = yes
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $
    content_filter = amavis:[127.0.0.1]:10024
    receive_override_options = no_address_mappings
     
  6. DuaBeo35

    DuaBeo35 New Member

    my mail.log
    Jun 6 12:05:50 hactech imapd: (null): TOO MANY CONSECUTIVE PROTOCOL VIOLATIONS
    Jun 6 12:06:04 hactech postfix/qmgr[2408]: 4CE9242872: from=<root@mail.hactech.vn>, size=786, nrcpt=1 (queue active)
    Jun 6 12:06:40 hactech postfix/smtp[2642]: connect to mail.hactech.vn[203.119.8.111]:25: Connection refused
    Jun 6 12:06:40 hactech postfix/smtp[2642]: 4CE9242872: to=<sales@hactech.vn>, relay=none, delay=1542, delays=1505/0/36/0, dsn=4.4.1, status=deferred (connect to mail.hactech.vn[203.119.8.111]:25: Connection refused)
    Jun 6 12:10:46 hactech imapd: Connection, ip=[::ffff:127.0.0.1]
    Jun 6 12:10:46 hactech imapd: chdir hactech.vn/lxthanh/: No such file or directory
    Jun 6 12:10:46 hactech imapd: lxthanh@hactech.vn: No such file or directory
    Jun 6 12:11:04 hactech postfix/qmgr[2408]: ADACE428C3: from=<root@mail.hactech.vn>, size=771, nrcpt=1 (queue active)
    Jun 6 12:12:02 hactech postfix/smtp[2719]: connect to mail.hactech.vn[203.119.8.111]:25: Connection refused
    Jun 6 12:12:02 hactech postfix/smtp[2719]: ADACE428C3: to=<sales@hactech.vn>, relay=none, delay=445, delays=387/0.05/58/0, dsn=4.4.1, status=deferred (connect to mail.hactech.vn[203.119.8.111]:25: Connection refused)
     
  7. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Is Postfix listening on all interfaces? What's the output of
    Code:
    netstat -tap
    ?
     

Share This Page