Virtual Users/Domains with Postfix for FC5 - Errors

Discussion in 'HOWTO-Related Questions' started by dabest80, Sep 21, 2006.

  1. dabest80

    dabest80 New Member

    Alright, I followed the very helpful tutorial, but I'm still experiencing a few problems. I have a perfect connection when I telnet into my SMTP and POP3 services both locally and remotely. But, the real problem begins when I try to authenticate into my account. I receive the following error after I try to login with a user "[email protected]" and the correct password in the POP3 connection:

    I've read all of the threads on here about this issue, so I know to resolve this I need to send an email to this user account. I have to do this so it will create my account, before I can log into it through POP3.

    Well, I've tried sending myself an email using the following command locally:

    echo welcome | mail [email protected]
    When I do that, I receive the following messages in my /var/log/maillog file.

    I've read all of the threads and I've looked through my Postfix .cf files for errors. I've made sure the my domain hostnames are correct. Can somebody please give me some ideas where to begin to pinpoint this issue? I don't know if my Postfix is successfully pulling the SQL data or not. Hope to hear something ASAP. Thanks!
  2. dabest80

    dabest80 New Member

    The VRFY command is returning the correct response when I telnet into the server through a SMTP connection. It doesn't say that the user is not found in the recipient table. So, are my issues DNS related? I can provide more logs to try to fix this matters. Thanks in advance!
  3. falko

    falko Super Moderator ISPConfig Developer

    Make sure that the domain isn't listed in mydestination and in your domains table at the same time.
  4. dabest80

    dabest80 New Member

    Thanks for the response. Well, I checked and "" was listed in the mydestination field on the file. I removed it, restarted postfix, and it still doesn't work. In the file, here's a look at it:

    Here's a look at my /etc/hosts file:

    Are there any other things that need to be configured that aren't mentioned in the tutorial that could be the reason for this error:

    It looks like it's checking for the FQDN [email protected] in the virtual tables rather than checking for [email protected]. My domains tables looks like this:

    I have no entries in my forwardings or transport sql tables (which I don't think that should have an effect on what I'm trying to accomplish at this point). I'm running 2.6.17-1.2187_FC5 kernel and I used the repository listed in the tutorial for my installs. I'm not seeing anything that would make me think it's not operating correctly except the domain mismatch stuff. I think it's close to working. Any other suggestions?
  5. chrishenley

    chrishenley New Member

    Little problem

    Thanks for this guide. It was helpful. The only problem I had was that postfix couldn't create the new domain directories in /home/vmail unless I chmod'd 777. Is this because postfix is running as postfix and cannot write to /home/vmail?

    Has anyone figured out vacation notices? To me, this would complete the virtual mail solution.
  6. falko

    falko Super Moderator ISPConfig Developer

    Are you sending to [email protected], [email protected], or just username?
  7. falko

    falko Super Moderator ISPConfig Developer

    Please open a new thread for this.
  8. dabest80

    dabest80 New Member

    I'm using the username "", but it shows this:

    Notice the instead of
  9. dabest80

    dabest80 New Member

    Alright, I was able to get it to work. I had to make sure that I had an entry in the forwardings table for

    Source Destination
    ------ ----------

    Now, it's working. It delivered my first email to my /home/vmail folder. Thanks for the help! Hope this helps someone else.

Share This Page