virtual-users-domains-postfix-courier-mysql-squirrelmail-ubuntu8.04

Discussion in 'HOWTO-Related Questions' started by DannyB, Jun 3, 2009.

  1. DannyB

    DannyB New Member

    Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 8.04)

    Hi all,

    Hopefully this is me missing something simple but I've been looking for ages and can't find the problem...

    Installed a new Ubuntu server following the guides on here, then ran through the install for virtual users+ domains + postfix + courier + mysql + squirrelmail.

    No errors encountered on installation, however on testing I cannot send any of the users a mail, if I attempt by telnetting to localhost:25 it accepts the ehlo, then after I have typed the MAIL FROM: command I can type anything I like and although it appears on the screen it's not responding to commands.

    I've looked at the mail.log on the ubuntu box and as soon as I've entered the MAIL FROM: Command it get's the following entries.


    Jun 3 21:44:46 ernie postfix/smtpd[5356]: connect from localhost[127.0.0.1]
    Jun 3 21:45:03 ernie postfix/proxymap[5357]: warning: connect to mysql server 127.0.0.1: Access denied for user 'mail_admin'@'localhost' (using password: NO)
    Jun 3 21:45:03 ernie postfix/trivial-rewrite[5359]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
    Jun 3 21:45:04 ernie postfix/master[5045]: warning: process /usr/lib/postfix/trivial-rewrite pid 5359 exit status 1
    Jun 3 21:45:05 ernie postfix/trivial-rewrite[5361]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
    Jun 3 21:45:06 ernie postfix/smtpd[5356]: warning: problem talking to service rewrite: Success
    Jun 3 21:45:06 ernie postfix/master[5045]: warning: process /usr/lib/postfix/trivial-rewrite pid 5361 exit status 1
    Jun 3 21:45:06 ernie postfix/master[5045]: warning: /usr/lib/postfix/trivial-rewrite: bad command startup -- throttling

    I suspect the Using Password: NO is a pointer to the error but I can't see where to set it, I have (I think) double checked all the config files for mistypes on passwords etc but have either missed it or it's not there!

    I've created a maildir for a user using makemaildir and squirrelmail can connect okay, so I guess the mysql is working okay. However I can't talk SMTP to the machine at all.

    Spent the last couple of days tearing my hair out on this one so any pointers to assist would be greatly appreciated!

    Many thanks,

    Danny
     
    Last edited: Jun 3, 2009
  2. falko

    falko Super Moderator

    There is a problem with the MySQL password for the user mail_admin.
    Can you connect (using the same password) on the command line?
    Code:
    mysql -u mail_admin -p
     
  3. DannyB

    DannyB New Member

    Not tried from command line but can connect using the mail_admin account and password from myphpadmin. It looks to me like it's not trying to use the password rather than refusing it? Could be wrong however I'm fairly new to this!

    Edit: Just tried from the command line and it connects fine.

    Danny
     
  4. falko

    falko Super Moderator

    Does the MySQL password contain any special characters?
     
  5. DannyB

    DannyB New Member

    Nope, just plain alpha characters.

    However have now rebuilt from scratch and all is working, so I guess I mucked something up in the initial build, not sure what however.

    Many thanks for the assistance.
     

Share This Page