Virtual Users & Domains, Mail Server CentOS 6.2

Discussion in 'HOWTO-Related Questions' started by CDesign, Jun 29, 2012.

  1. CDesign

    CDesign New Member

    Hello there HowToForge Forum Dwellers!, and specifically Falko, thanks for referring me to here for some help on your tutorial.

    Im just going to go ahead and copy and paste most of the message I first sent, to here on the forum.

    I have been following the tutorial of "Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (CentOS 6.2 x86_64)".
    Located here: click me

    Everything has been going pretty well, but when I reached the the Fifth Page, I ran into a problem.

    The first thing I had issues with was step 13.
    I went to:
     yum install perl-Razor-Agent pyzor
    and it turns out, there is no pyzor package available for CentOS 64bit..
    It seems that many people have asked about this online, but without any answer as to why, or if there is a workaround..
    So I just found an RPM for it and installed the RPM with "rpm -ivh". Which seemed to work, it seemed everything was fine and all in the correct directories.

    So I continued, chmod'ed fine, but when I came to the next commands:
     su -m amavis -c 'pyzor --homedir /var/spool/amavisd discover'
     su -m amavis -c 'razor-admin -home=/var/spool/amavisd -create'
     su -m amavis -c 'razor-admin -home=/var/spool/amavisd -register
    It gave me a couple errors:
     Traceback (most recent call last):
       File "/usr/bin/pyzor", line 8, in <module>
       File "/usr/lib/python2.6/site-packages/pyzor/", line 1022, in run
       File "/usr/lib/python2.6/site-packages/pyzor/", line 180, in run
     OSError: [Errno 13] Permission denied: '/var/spool/amavisd'
    So I started to try to debug. I checked out the Python Script on the lines specified and they weren't even the correct lines, nor did it give anything relevant to work off of.

    So then I checked out /var/spool/amavisd
    It turned out, that it didn't even exist.. Which is strange because I know amavisd is running and installed perfectly fine.

    Any thoughts on why this may not exist?

    I asked this question on from stack exchange, and unfortunately didn't get a reply.

    So since that didn't work, I tried to move on just to get the emailing functionality at least, without the spam/antivirus.
    Mainly because, I didn't get any answers, and I am running on a VPS server, and I have quite a limited amount of Memory for me to use, and when the antivirus is running it shoots my RAM usage up nearly 50%. Which is just way too much.. I can really live without the Anti-Virus, as all the Email Clients I have, all have Anti-Viruses on the recieving end, so that shouldn't really matter at the moment. But Spam on the other hand. I really need to prevent spam at least.
    I really just want to prevent Spam, and send, recieve email. Simple as that, and preferably as lightweight as possible with the smallest Memory footprint. Plus, the tutorial really appealed to me because of the fact we are able to make Virtual users and domains. Which is GREAT!

    So moving on to the next part I had trouble.
    At Step 15.

    I installed the cyrus-sasl as suggested in the comments at the bottom of the page for that step as well.
    But even though everything was running correctly, when I went to run:
     telnet localhost 25
    I got:
    Trying ::1...
     Connected to localhost.
     Escape character is '^]'.
     220 ESMTP Postfix
    as normal,
    so I continued:
     ehlo localhost
    and I received:
    Code: Hello localhost [], pleased to meet you
     250 HELP
    As stated in the tutorial, if it shows :
    then it is ready for SMTP-AUTH and TLS.
    But, unfortunately as shown above, it isn't showing on mine..

    For some reason though, in the tutorial it only explains that this "should" work, and not what to do if it doesn't work.
    Is there anyway someone wouldn't mind helping me with this please? I would really greatly appreciate it very much.
    I also posted this question on Unix & Linux Stack Exchange, but unfortunately there was no answers either... So my only chance really, is the great folks here.

    I just don't even know where to start right now. Not sure what I should be looking at, whether I should check certain package installations, error logs, configurations, etc.

    I have a pretty good knowledge of Linux, but like I mentioned I just don't know where I should start out to fix this.

    Thank you very much everyone.
    Please do let me know if this is enough information, or if I should provide anymore or something in particular or something.
    Hope we can work this out! Would love to have this working today.

    Take Care everyone.

  2. TiTex

    TiTex Member

    post the output of
    ls -l /var/spool/ | grep amavisd
    Last edited: Jun 29, 2012
  3. CDesign

    CDesign New Member


    Idk what happened..
    There is no output for that at all.

    What could that mean?

    I can start|stop|restart|etc the amavisd service using:
    /etc/init.d/amavisd start


Share This Page