Virtual users and domains with postfix, Mysql, courier, Squirrelmail

Discussion in 'HOWTO-Related Questions' started by matiancai74, Jan 24, 2011.

  1. matiancai74

    matiancai74 New Member

    Hello, can anyone help a linux newbie? Thank you very much. I am a teacher trying to set up an email server for my school. I am on page 3 of the tutorial and I am pretty sure I have setup something wrong. Can anyone spot something wrong here? I am getting the following output from netstat -tap:

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 regents-pattaya.a:10024 *:* LISTEN 11158/amavisd (mast
    tcp 0 0 regents-pattaya.a:mysql *:* LISTEN 937/mysqld
    tcp 0 0 regents-patt:submission *:* LISTEN 1782/sendmail: MTA:
    tcp 0 0 *:5900 *:* LISTEN 11329/vino-server
    tcp 0 0 *:webmin *:* LISTEN 1912/perl
    tcp 0 0 *:www *:* LISTEN 1869/apache2
    tcp 0 0 *:ssh *:* LISTEN 22783/sshd
    tcp 0 0 regents-pattaya.ac.:ipp *:* LISTEN 12635/cupsd
    tcp 0 0 regents-pattaya.ac:smtp *:* LISTEN 1782/sendmail: MTA:
    tcp 0 0 regents-pattaya.ac:smtp regents-pattaya.a:56017 TIME_WAIT -
    tcp 0 0 regents-pattaya.ac:5900 202.149.116.20:3073 ESTABLISHED 11329/vino-server
    tcp6 0 0 [::]:imaps [::]:* LISTEN 9783/couriertcpd
    tcp6 0 0 [::]:pop3s [::]:* LISTEN 9843/couriertcpd
    tcp6 0 0 [::]:5900 [::]:* LISTEN 11329/vino-server
    tcp6 0 0 [::]:pop3 [::]:* LISTEN 9810/couriertcpd
    tcp6 0 0 [::]:imap2 [::]:* LISTEN 9750/couriertcpd
    tcp6 0 0 [::]:ssh [::]:* LISTEN 22783/sshd
    tcp6 0 0 ubuntu:ipp [::]:* LISTEN 12635/cupsd

    I am also getting the following output from the command 'ehlo localhost' when using telnet 25:

    root@regents-pattaya:/usr/local/sbin# telnet localhost 25
    Trying ::1...
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 localhost.localdomain ESMTP Sendmail 8.14.3/8.14.3/Debian-9.2ubuntu1; Mon, 24 Jan 2011 12:04:11 +0700; (No UCE/UBE) logging access from: regents-pattaya.ac.th(OK)-regents-pattaya.ac.th [127.0.0.1]
    ehlo localhost > /home/ehlo_output.txt
    501 5.0.0 Invalid domain name
    ehlo localhost
    250-localhost.localdomain Hello regents-pattaya.ac.th [127.0.0.1], pleased to meet you
    250-ENHANCEDSTATUSCODES
    250-PIPELINING
    250-EXPN
    250-VERB
    250-8BITMIME
    250-SIZE
    250-DSN
    250-ETRN
    250-AUTH DIGEST-MD5 CRAM-MD5
    250-DELIVERBY
    250 HELP

    Thanks for your help,
    Matt
     
  2. falko

    falko Super Moderator

    You are using Sendmail instead of Postfix.
     
  3. matiancai74

    matiancai74 New Member

    Thanks Falko. I seem to have both packages installed. If I uninstall and remove Sendmail would that then solve the problem? I do have Postfix installed and have followed all the configuration steps in your brilliant howto. I am desperate to get this to work. I teach Information Technology at an International School - the IT Technicians are telling me it's impossible to set up a mail server on our Ubuntu server without buying something like Microsoft Exchange but I'd love to prove them wrong.
     
  4. falko

    falko Super Moderator

    Yes, uninstalling Sendmail would help. Make sure you start Postfix afterwards.
     

Share This Page