[virtual-users-and-domains-with-postfix-courier-mysql...] Transport question

Discussion in 'HOWTO-Related Questions' started by azel, Jan 20, 2011.

  1. azel

    azel New Member

    So, I'm have used this setup for quite some time and on different machines. Worked pretty well for me, thanks for keeping the guides up-to-date. :)

    Now, I have this setup running for couple of domains on a single machine. I'd like to make use of that box for another domain as an edgemail server that forwards mails to an exchange server. The exchange server is connected to the internet by a vdsl-uplink with a static ip. Since the exchange-server can't send the mails directly to some mail-providers due to anti-spam measures on their side and is only available like 98% a day (we still have forced disconnects here in germany) I'd like to use the postfix as catch-all/transport/relay jack-of-all-trades for the exchange.

    So, I put in the transport stuff, as well as the ip of the exchange into the mynetworks settings. Everything works, I can send mails to the local virtual users, plus my own user as a known alias on the new domain is getting the mails aswell. BUT all the other exchange users are not getting their mails, postfix is rejecting mails because the "user is unknown in virtual mailbox table".

    How do I disable address verification for the domains listet in the transport tables? I tried setting up a [email protected] and was playing around with address_verify_default_transport and address_verify_transport_maps without any luck. So I reverted these changes, so my system is pretty much the way it should be after finishing the tutorial.

    Any help would be appreciated,
  2. falko

    falko Super Moderator ISPConfig Developer

  3. azel

    azel New Member

    I think it's not. I only set up the transport_maps according to the tutorial.
    I will have a look into ur links and the main.cf tomorrow and report back.

  4. azel

    azel New Member

    Thanks for your help so far.

    Unfortunatly I didnt' found time to give this a try. Until now ;)

    According to your suggestion here is what I did:
    1. Added a table 'relaydomains' with a domain column
    2. Added another mysql script to postfix directory using following query
      SELECT domain AS relay FROM relaydomains WHERE domain='%s'
    3. changed permission of the new script file
    4. added relay_domains setting to main.cf
      postconf -e 'relay_domains = proxy:mysql:/etc/postfix/mysql-virtual_relaydomains.cf'
    5. changed record in transport table to mydomain.tld | relay:[x.x.x.x]
    6. restartet postfix

    Since current exchange edgemail is still running, I can't say for sure but the mails I sent from the new edgemail itself it seems to be relayed.

    What do you think?

Share This Page