- Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail

Discussion in 'HOWTO-Related Questions' started by VRage, Jul 26, 2010.

  1. VRage

    VRage New Member

    Hello,
    I'm somewhat new to linux and followed this tutorial as closely as i could.

    If i try to login to an email account created I get an error message such as:

    "imapd: chdir visual-rebirth.com/user/: No such file or directory"

    If I send an email to an address on this server i guet the following error:

    "connect to transport private/amavis: No such file or directory
    Jul 26 02:18:11 visual-rebirth postfix/error[25761]: 5F54E37680AF: to=<user@visual-rebirth.com>, relay=none, delay=3534, delays=3534/0.01/0/0.01, dsn=4.3.0, status=deferred (mail transport unavailable)"

    Any ideas on where to look to sort this out?

    Thanks in advance for your time.

    My main.cf is as follows
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's the URL of the tutorial?

    Did you send a welcome mail to that account? The necessary directories are created automatically when the first email arrives.
     
  3. VRage

    VRage New Member

    The tutorial's here


    When I send the email using mailx I get the same error:

    warning: connect to transport private/amavis: No such file or directory
    relay=none, delay=0.04, delays=0.03/0/0/0.01, dsn=4.3.0, status=deferred (mail transport unavailable)
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's in /etc/postfix/master.cf and /etc/postfix/main.cf? What's the output of
    Code:
    netstat -tap
    ?
     
  5. VRage

    VRage New Member

    Hi again,
    Many thanks for you time on this.

    Main.cf is above, netstat -tap and master.cf bellow

    Netstata -tap


    master.cf

     
    Last edited: Jul 27, 2010
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  7. VRage

    VRage New Member

    Thanks!
    Feeling silly for having missed those lines =)

    Sadly now I get the following:
    Not sure if related but on my transport table I have:

    [Domain] [Transport]
    visual-rebirth.com smtp:mail.visual-rebirth.com
     
    Last edited: Aug 3, 2010
  8. herbie

    herbie New Member

    I just completed the install and the problem I'm getting is the domains and mailboxes are not being automatically created with the welcome message.
    Any ideas?
    What actually creates the mailbox?

    mailx sales@example.com
    But the there is no /home/vmail/example.com or sales inside it
     
    Last edited: Jul 29, 2010
  9. VRage

    VRage New Member

    Have you checked /var/log/mail.log to see if the message is actually delivered or if an error occurred?
     
  10. herbie

    herbie New Member

    Code:
    fatal: bad string length 0 < 1: virtual_mailbox_base = 
    warning: process /usr/lib/postfix/virtual pid 3240 exit status 1
    warning: /usr/lib/postfix/virtual: bad command startup -- throttling
     
  11. VRage

    VRage New Member

    Well, I'm here for the help too so I might not be much help to you, but from your error message I'm guessing you should go have a look in your /etc/postfix/main.cf to for the "virtual_mailbox_base" line.
     
  12. herbie

    herbie New Member

    That was it... somehow skipped entering that line and half a dozen others.
    Seems A-OK now
     

Share This Page