Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail

Discussion in 'HOWTO-Related Questions' started by garther, Jul 24, 2008.

  1. falko

    falko Super Moderator ISPConfig Developer

    Can you try to raise PHP's memory limit in the php.ini file and restart Apache afterwards?
     
  2. sharkbun

    sharkbun New Member

  3. admin

    admin Administrator Staff Member Moderator

    Then I'm at my wit's end... :(
     
  4. wierben

    wierben New Member

    This could be fun, a new problem!

    Hi,

    I've set up this mailserver with the tutorial, and it worked fine after intensive testing. Now, the system is live and it keeps on crashing. However, I cannot find an error log anywhere, don't even know where to look anymore..

    What happens is, at some point, the server just stops delivering mail, or even processing mail? Users cannot send/recieve mails.. They can log in though and everything looks fine. After I restart *all* processes (since I don't know which is failling), the server start delevering the mails (so the mails get in, but not delivered). I think they are stuck somewhere in either spamassassin, clamv or the thingy that actually delivers the mails (is it maildrop?). The only thing noticable in the logs, is that there are no more entries as soon as the ghost deamon crashes (don't know which one).

    Any ideas?

    thx,
    wybren
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Did you check /var/log/mail.log?
     
  6. wierben

    wierben New Member

    well yes, only thing funny in these logs are:

    Sep 1 06:57:42 cantharis postfix/error[30240]: 1AEBA18907B5E: to=<[email protected]>, relay=none, delay=11524, delays=10923/600/0/0.02, dsn=4.4.2, status=deferred (delivery temporarily suspended: conversation with 127.0.0.1[127.0.0.1] timed out while receiving the initial server greeting)

    And this a lot. So, it is the delevery thingy that is not responding, but why? :)
     
  7. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ?
     
  8. wierben

    wierben New Member

    Code:
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:nfs                   *:*                     LISTEN      -
    tcp        0      0 *:58821                 *:*                     LISTEN      -
    tcp        0      0 *:52391                 *:*                     LISTEN      5253/rpc.mountd
    tcp        0      0 *:55431                 *:*                     LISTEN      4220/rpc.statd
    tcp        0      0 localhost:10024         *:*                     LISTEN      1369/amavisd (maste
    tcp        0      0 localhost:10025         *:*                     LISTEN      3531/master
    tcp        0      0 localhost:mysql         *:*                     LISTEN      7484/mysqld
    tcp        0      0 localhost:spamd         *:*                     LISTEN      3538/spamd.pid
    tcp        0      0 *:sunrpc                *:*                     LISTEN      4171/portmap
    tcp        0      0 *:www                   *:*                     LISTEN      1831/apache2
    tcp        0      0 *:ftp                   *:*                     LISTEN      30066/proftpd: (acc
    tcp        0      0 *:smtp                  *:*                     LISTEN      3531/master
    tcp        0      0 servername.domain.tld:smtp 222-153-42-151.je:57646 SYN_RECV    -
    tcp        0      0 localhost:mysql         localhost:57023         TIME_WAIT   -
    tcp        1      0 localhost:10024         localhost:37574         CLOSE_WAIT  14725/amavisd (ch3-
    tcp        0      0 localhost:38145         localhost:mysql         TIME_WAIT   -
    tcp        0      0 localhost:57023         localhost:mysql         TIME_WAIT   -
    tcp        0      0 localhost:38146         localhost:mysql         TIME_WAIT   -
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      5136/couriertcpd
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      5175/couriertcpd
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      3440/couriertcpd
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      3409/couriertcpd
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      5841/sshd
    Note: At this point, everything is running as it should. I'm also beginning to suspect amavis-new (it used 100% CPU today, a process which I had to kill)
     
  9. ikaros

    ikaros New Member

    HowTo depedencies

    Sorry to intrude in the thread but I have a question about the "Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 8.04 LTS)" tutorial.

    The preliminary note states that "...This tutorial is based on Ubuntu 8.04 Server (Hardy Heron), so you should set up a basic Ubuntu 8.04 server installation before you continue with this tutorial (e.g. as shown on the pages 1 - 3 in this tutorial: The Perfect Server - Ubuntu Hardy Heron (Ubuntu 8.04 LTS Server))...". Does this mean that you have to follow the entire Perfect Server tutorial and install and setup everything or that pages 1-3 are enough?
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Do you see any errors in the mail log when you restart Postfix and amavisd?
     
  11. falko

    falko Super Moderator ISPConfig Developer

    Pages 1 - 3 are enough.
     
  12. pulse00

    pulse00 New Member

    unable to login using squirrel mail or telnet

    hi,

    i've followed all the steps in the howto, but i can't login using squirrelmail, mail.log says:

    Code:
    imapd: Connection, ip=[::ffff:127.0.0.1]
    imapd: LOGIN FAILED, [email protected],ip=[::ffff:127.0.0.1]
    imapd: LOGOUT, ip=[::ffff:127.0.0.1], rcvd=58, sent=332
    

    trying to connect using 'telnet localhost pop3' i get:

    Code:
    courierpop3login: Connection, ip=[::ffff:127.0.0.1]
    courierpop3login: LOGIN FAILED, [email protected],ip=[::ffff:127.0.0.1]
    
    However, using postfixadmin i am able to send emails, i can also receive mails from my gmail account.

    Has anyone a hint how i could track this down ?
     
  13. pulse00

    pulse00 New Member

    ok, i figured out the solution myself, the module was simply not installed...

    now i'm struggling with a different error when logging in with squirrelmail:

    Code:
    Access denied for user 'mail_admin.'@'localhost' (using password: YES)
    What is strange here is the . after mail_admin. i've double checked the authmysqlrc file and dot is definitely not there.

    Anyone knows what could cause this ?
     
  14. wierben

    wierben New Member

    None, btw, the service was down today, while it was, I did the netstat thingy:

    Code:
    tcp        1      0 localhost:10024         localhost:51173         CLOSE_WAIT  -
    tcp        1      0 localhost:10024         localhost:51810         CLOSE_WAIT  -
    tcp        1      0 localhost:10024         localhost:36522         CLOSE_WAIT  -
    tcp        1      0 localhost:10024         localhost:56246         CLOSE_WAIT  -
    tcp        1      0 localhost:10024         localhost:51483         CLOSE_WAIT  -
    
    Quite a lot of these..
     
  15. falko

    falko Super Moderator ISPConfig Developer

    I'd search all your configuration files for "mail_admin.".
     

Share This Page