virtual users and domains with postfix courier mysql and squirrelmail ubuntu10.10

Discussion in 'HOWTO-Related Questions' started by kaar, Apr 8, 2011.

  1. kaar

    kaar New Member

    oooo.. ok.. ill try to install new server with other domain.. thanks
     
  2. kaar

    kaar New Member

    hi.. already install new server with new domain name(konyang.com).. still cant login..
    just want to ask how to add a user for my squirrelmail? for example i want to add [email protected] as a user.. is it i have to use another computer for the new user?
     
  3. falko

    falko Super Moderator ISPConfig Developer

    You simply create a mail account as shown in the tutorial, send a welcome email to that account, and then you log into SquirrelMail with the email address and password.
     
  4. kaar

    kaar New Member

    still cannot login.. sorry for asking too many question.. Im new to ubuntu and still confuse with it.. Here is my mail log

    so what was the problem? did i configure it wrong or im just have a problem with the user?
     
    Last edited: May 24, 2011
  5. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    grep soli /etc/passwd
    ?
    Can you post your /etc/postfix/main.cf?
     
  6. kaar

    kaar New Member

    when i typed that code,there was no output.

    and this is my /etc/postfix/main.cf
    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    readme_directory = /usr/share/doc/postfix
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname = kuku.konyang.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = kuku.konyang.com, localhost, localhost.localdomain
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command =
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    home_mailbox = Maildir/
    html_directory = /usr/share/doc/postfix/html
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /home/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    virtual_create_maildirsize = yes
    virtual_maildir_extended = yes
    virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
    virtual_mailbox_limit_override = yes
    virtual_maildir_limit_message = "The user you are trying to reach is over quota."
    virtual_overquota_bounce = yes
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    content_filter = amavis:[127.0.0.1]:10024
    receive_override_options = no_address_mappings
    
    
    
     
  7. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/mailname?
     
  8. hapony

    hapony New Member

    Hi There , i have same problem after complete following link from you in How to setup virtual...

    the error is i get this message " ERROR: Connection dropped by IMAP server " when try to login, and the last error message on /var/log/mail.log is :

    May 31 02:45:06 idcmail imapd: Connection, ip=[::1]
    May 31 02:45:06 idcmail authdaemond: authmysql: MYSQL_SERVER nor MYSQL_SOCKET set in/etc/courier/authmysqlrc.
    May 31 02:45:06 idcmail imapd: LOGIN FAILED, [email protected], ip=[::1]
    May 31 02:45:06 idcmail imapd: authentication error: Input/output error

    any solution and advice will be greatfull,

    Thanks and regard
     
  9. kaar

    kaar New Member

    this is my /etc/mailname.

    Code:
    kuku.konyang.com
     
  10. bitmystic

    bitmystic New Member

    Using the downloadable ISO....

    I downloaded the VMWare ISO of this setup and wondered what the default passwords were that were used in setting up image?

    Thanks
    Dave
     
  11. kaar

    kaar New Member

    so falko, is there any solution for this IMAP problem?
     
  12. falko

    falko Super Moderator ISPConfig Developer

    It's probably an easy fix, but it is hard to tell from the distance what the problem is... :(
     
  13. kaar

    kaar New Member

    ermm... ok. Need to ask some question.. I already install the server.. also install Oracle VM Virtualbox for the webmail user purpose.. just want to know whether i'm doing a right things by install the virtualbox or i have to setup a new computer just for the one user?

    I need atleast 2 user for my webmail.

    another thing is ip address for my virtualbox is 10.0.2.15 and my server is 10.64.116.217.. Do i have to change the ipaddress on virtual box?
     
  14. dbr9449

    dbr9449 New Member

    I downloaded the virtual machine Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 11.10) but got an error when unzipping it. I have tried a few times from different internet connections and always get the unzipping error. I would appreciate it if you could check and perhaps refresh the download image. Thanks.

    Also, I downloaded the virtual machine image for Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 10.04). I have that running and can send but not receive emails. I changed the host name and have set up the server names through our internet provider, but still don't receive emails. Can you suggest what I should check? Thanks.
     
  15. falko

    falko Super Moderator ISPConfig Developer

    Does the MX record of your domain point to the correct server? Does your router forward port 25 to your server? Also please check if your ISP blocks port 25.
     
  16. dbr9449

    dbr9449 New Member

    Falko,

    I think that those settings are fine. I sent myself a message from gmail and could see it come through in mail.log, but it was not immediately delivered to my inbox. I am including below an excerpt from mail.log (I replaced my domain name with *--*). Does that provide any clues? The emails are now coming through from email, but not from our internal email server that is on the same subnet as the new mail server. So, it is working externally, but not internally. I set some pointer records that may help, but if you have any ohter thoughts, let me know. Thanks.

    Dec 20 08:16:51 mail postfix/qmgr[2555]: C3F80203D1: from=<db*--*@gmail.com>, size=2057, nrcpt=1 (queue active)
    Dec 20 08:16:51 mail postfix/smtpd[2591]: disconnect from localhost.localdomain[127.0.0.1]
    Dec 20 08:16:51 mail amavis[1357]: (01357-02) Passed CLEAN, [74.125.82.46] [74.125.82.46] <db*--*@gmail.com> -> <[email protected]*--*.com>, Message-ID: <[email protected]om>, mail_id: Bvilmwl-mMgb, Hits: 2.134, size: 1557, queued_as: C3F80203D1, [email protected], 2169 ms
    Dec 20 08:16:51 mail postfix/smtp[2586]: 6ABA2203CF: to=<[email protected]*--*.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=2.6, delays=0.44/0.01/0.01/2.2, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=01357-02, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as C3F80203D1)
    Dec 20 08:16:51 mail postfix/qmgr[2555]: 6ABA2203CF: removed
    Dec 20 08:16:52 mail postfix/virtual[2592]: C3F80203D1: to=<[email protected]*--*.com>, relay=virtual, delay=0.2, delays=0.09/0.04/0/0.07, dsn=2.0.0, status=sent (delivered to maildir)
    Dec 20 08:16:52 mail postfix/qmgr[2555]: C3F80203D1: removed
    Dec 20 08:17:03 mail imapd: Connection, ip=[::1]
    Dec 20 08:17:03 mail imapd: LOGIN, [email protected]*--*.com, ip=[::1], port=[52086], protocol=IMAP
    Dec 20 08:17:03 mail imapd: LOGOUT, [email protected]*--*.com, ip=[::1], headers=0, body=0, rcvd=87, sent=391, time=0
    Dec 20 08:17:19 mail postfix/smtpd[2580]: disconnect from mail-ww0-f46.google.com[74.125.82.46]
    Dec 20 08:17:46 mail imapd: Connection, ip=[::1]
    Dec 20 08:17:46 mail imapd: LOGIN, [email protected]*--*.com, ip=[::1], port=[52087], protocol=IMAP
    Dec 20 08:17:46 mail imapd: LOGOUT, [email protected]*--*.com, ip=[::1], headers=0, body=0, rcvd=87, sent=391, time=0
     
    Last edited: Dec 20, 2011
  17. falko

    falko Super Moderator ISPConfig Developer

    Does the internal email server use the same domains? I guess that when you send a mail from the internal email server, it doesn't leave that server because it feels responsible for the domain.
     

Share This Page