Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04

Discussion in 'HOWTO-Related Questions' started by c4rdinal, May 27, 2008.

  1. falko

    falko Super Moderator

    You are using procmail with the virtual users howto?
     
  2. tkorves

    tkorves New Member

    Yes, I do... ;-) Added a lot of nice functions around this setup... Webconfigurator for Postfix (Supervisor login, admin per domain etc, procmail via MySQL and many many more functions)...
     
  3. rakeshakurathi

    rakeshakurathi New Member

    ERROR: Connection dropped by IMAP server.

    i was breaking my head to solve this probs from 2 days i cant take it any more
    please any one help me urgent

    this is my mail log,
    i can send mails from mailx, but when i send mail to one of the user from gmail account it bounces back with delivery notification,
    in this log i have tried to connect through thunderbird which resulted in error ,even squirrelmail doesnt work,
    i don know what is the problem


    i followed http://www.howtoforge.com/virtual-us...-ubuntu9.04-p5
    please guys help me any information is helpful

    i have done all the steps 4 times and i dint get any error all the telnet sessions gave me the exact output as in the tutorial. please any one help me....


    log file:-
    Jan 11 00:30:41 exampleserver authdaemond: authmysql: MYSQL_SERVER nor MYSQL_SOCKET set in/etc/courier/authmysqlrc.
    Jan 11 00:30:41 exampleserver authdaemond: authmysql: TEMPFAIL - no more modules will be tried
    Jan 11 00:30:41 exampleserver imapd: LOGIN FAILED, method=PLAIN, ip=[::ffff:90.152.67.122]
    Jan 11 00:30:41 exampleserver imapd: authentication error: Input/output error
    Jan 11 00:31:53 exampleserver postfix/smtpd[4360]: connect from eba.b.xyar.se[xxx.xxx.xx.xx]
    Jan 11 00:31:53 exampleserver postfix/smtpd[4360]: lost connection after CONNECT from eba.b.xyar.se[xxx.xxx.xx.xx]
    Jan 11 00:31:53 exampleserver postfix/smtpd[4360]: disconnect from eba.b.xyar.se[xxx.xxx.xx.xx]
    Jan 11 00:32:34 exampleserver postfix/anvil[4363]: statistics: max connection rate 2/60s for (smtp:90.152.67.122) at Jan 11 00:26:56
    Jan 11 00:32:34 exampleserver postfix/anvil[4363]: statistics: max connection count 1 for (smtp:xxx.xxx.xx.xx) at Jan 11 00:22:34
    Jan 11 00:32:34 exampleserver postfix/anvil[4363]: statistics: max cache size 2 at Jan 11 00:26:44
    Jan 11 00:32:34 exampleserver postfix/smtpd[4360]: connect from eba.b.xyar.se[xxx.xxx.xx.xx]
    Jan 11 00:32:34 exampleserver postfix/smtpd[4360]: lost connection after CONNECT from eba.b.xyar.se[xxx.xxx.xx.xx]
    Jan 11 00:32:34 exampleserver postfix/smtpd[4360]: disconnect from eba.b.xyar.se[xxx.xxx.xx.xx]
    Jan 11 00:33:34 exampleserver postfix/smtpd[4360]: connect from eba.b.xyar.se[xxx.xxx.xx.xx]
    Jan 11 00:33:34 exampleserver postfix/smtpd[4360]: lost connection after CONNECT from eba.b.xyar.se[xxx.xxx.xx.xx]
    Jan 11 00:33:34 exampleserver postfix/smtpd[4360]: disconnect from eba.b.xyar.se[xxx.xxx.xx.xx]
    Jan 11 00:34:01 exampleserver imapd: Connection, ip=[::1]
    Jan 11 00:34:01 exampleserver authdaemond: received auth request, service=imap, authtype=login
    Jan 11 00:34:01 exampleserver authdaemond: authmysql: trying this module
    Jan 11 00:34:01 exampleserver authdaemond: authmysql: MYSQL_SERVER nor MYSQL_SOCKET set in/etc/courier/authmysqlrc.
    Jan 11 00:34:01 exampleserver authdaemond: authmysql: TEMPFAIL - no more modules will be tried
    Jan 11 00:34:01 exampleserver imapd: LOGIN FAILED, user=amin@exampleserver.se, ip=[::1]
    Jan 11 00:34:01 exampleserver imapd: authentication error: Input/output error
     
  4. falko

    falko Super Moderator

    Please don't double-post!
     
  5. rakeshakurathi1

    rakeshakurathi1 New Member

    sorry for double posting

    thanks for u r help falko..

    after posting the thread i realised that i have done in wrong post..
    so i have posted it again,

    hey my biggest problem i m unable to send messages to any of my email accounts, can u help why does it happen,
    i can send messages from my server from mutt or mailx
    everything is working fine as u said in tutorial but my when i send messages from yahoo or gmail it give me error "message deleivery notification"
     
  6. tonkyman

    tonkyman New Member

    I know this is an old thread but I hope you can help me.

    I've been using this setup since 2009 and it has been working flawlessly (Thanks Falko).

    I've had an issue pop up recently that I can't seem to resolve. I have someone trying to send me an email that has a 10 meg attachment and the server keeps rejecting it. The bounce notice on the other side does not say that I'm over quota because I'm not (my quota is 30 meg). The notice says:

    xxxxx@xxxxx.com on Fri, 1 Jul 2011 08:54:36 -0500
    This message is larger than the current system limit or the recipient's
    mailbox is full. Create a shorter message body or remove attachments and
    try sending it again.
    <blahblahblah.com #5.2.3 smtp;450 5.2.3 Msg Size greater than allowed by
    Remote Host>


    I need to be able to send and receive files up to my quota but for some reason it won't.

    Can you help??

    Thanks,
    Tony
     
  7. falko

    falko Super Moderator

  8. tonkyman

    tonkyman New Member

    Thanks falco, that worked! My main.cf didn't even have that parameter value in it at all so it must have been using the default 10meg.

    Humbly,
    Tony
     
  9. horace11091

    horace11091 New Member

    I had similar problem! thanks everybody!
     
    Last edited by a moderator: Jul 17, 2011
  10. lucifer1306217

    lucifer1306217 New Member

    Last edited: Aug 2, 2011
  11. falko

    falko Super Moderator

    Please open a new thread!
     
  12. palcica

    palcica New Member

    Hi!

    What is the simpliest way to do a backup of mails? For user is a baskup od data in mysql... but for mails?

    Thanks
     
  13. falko

    falko Super Moderator

    Please open a new thread!
     

Share This Page