Virtual Users And Domains With Postfix, Courier, And SquirrelMail Ubuntu 8.04

Discussion in 'HOWTO-Related Questions' started by LePrince, Jun 10, 2008.

  1. LePrince

    LePrince New Member

    I followed the ubuntu manual, but I actually have the Debian 4.0. At some point during installing and configuring, my mail was delivered, but some later phase of conf killed it. I've been searching for solutions for 2 weeks now and I ran out of ideas. I keep getting the same fatal error in my log:

    Code:
    Jun 10 15:09:22 server postfix/smtpd[20120]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
    Jun 10 15:09:23 server postfix/smtpd[20120]: fatal: unexpected command-line argument: ??o
    Jun 10 15:09:24 server postfix/master[19933]: warning: process /usr/lib/postfix/smtpd pid 20120 exit status 1
    Jun 10 15:09:24 server postfix/master[19933]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    Jun 10 15:09:24 server amavis[20084]: (20084-01) (!) FWD via SMTP: <info@example.com> -> <me@mysite.com>, 450 4.4.1 Can't connect to 127.0.0.1 port 10025,  (Bad file descriptor) at (eval 42) line 145, <GEN25> line 127., MTA([127.0.0.1]:10025), id=20084-01
    
    I don't have any more ideas of how to find where this fatal error comes from.

    Could anybody please suggest some ways to find the problem.
     
  2. thecaoticone

    thecaoticone New Member

    The "NIS domain name not set" error pertains to your "alias_maps =" in the main.cf

    The "450 4.4.1 Can't connect to 127.0.0.1 port 10025" error means that Postfix is not connecting to Amavis


    There is a guide for Debian Etch 4.0 in the howto guides you may want to have a look at that. I believe they run diferent versions of some of the software.

    http://howtoforge.com/virtual_users_and_domains_with_postfix_debian_etch
     
  3. LePrince

    LePrince New Member

    I reinstalled postfix and rechecked config files using the HOWTO for debian, but it is practically identical and it didn't solve my problem. My log is still like this:

    Code:
    Jun 12 16:39:50 server postfix/smtpd[15318]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
    Jun 12 16:39:51 server postfix/smtpd[15318]: fatal: unexpected command-line argument: ??o
    Jun 12 16:39:52 server amavis[15191]: (15191-01) (!) FWD via SMTP: <root@server.mydomain.com> -> <postmaster@mydomain.com>, 450 4.4.1 Can't connect to 127.0.0.1 port 10025,  (Bad file descriptor) at (eval 42) line 145, <GEN24> line 40., MTA([127.0.0.1]:10025), id=15191-01
    Jun 12 16:39:52 server postfix/master[13003]: warning: process /usr/lib/postfix/smtpd pid 15318 exit status 1
    Jun 12 16:39:52 server postfix/master[13003]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    Jun 12 16:39:52 server amavis[15191]: (15191-01) Blocked TEMPFAIL, <root@server.mydomain.com> -> <postmaster@mydomain.com>, Message-ID: <20080611210003.1044617F3D@server.mydomain.com>, mail_id: 3feSSSF6+IhL, Hits: 1.135, 12095 ms
    Jun 12 16:39:52 server postfix/smtp[15308]: 1044617F3D: to=<postmaster@mydomain.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=59990, delays=59978/0.13/0.1/12, dsn=4.4.1, status=deferred (host 127.0.0.1[127.0.0.1] said: 450 4.4.1 Can't connect to 127.0.0.1 port 10025,  (Bad file descriptor) at (eval 42) line 145, <GEN24> line 40., MTA([127.0.0.1]:10025), id=15191-01 (in reply to end of DATA command))
    I personally believe that problem lies behind this error:
    Code:
    Jun 12 16:39:51 server postfix/smtpd[15318]: fatal: unexpected command-line argument: ??o
    
    This is only error I see in my mali.err log and it appears every time I send mail to my server or when I flush the mail queue. I don't have "??o" in my postfix config files - at least I didn't find one.

    Is it possible to find the source of this problem? For me, reinstalling linux is starting to become more and more reasonable solution.
     
  4. thecaoticone

    thecaoticone New Member

    The only place I know that contains an "o" are the lines in the /etc/postfix/master.cf file.

    i.e.
    "127.0.0.1:10025 inet n - - - - smtpd
    -o content_filter=
    -o local_recipient_maps="



    Here is copy of a working master.cf file for you to compare yours against.

    Hopefully it is just a typo and you will not have to re-install the entire system.

    You should be able to copy this "as is" if needed. This is how the guides specify, no changes.

    Hope this helps.

    Code:
    #
    # Postfix master process configuration file.  For details on the format
    # of the file, see the master(5) manual page (command: "man 5 master").
    #
    # Do not forget to execute "postfix reload" after editing this file.
    #
    # ==========================================================================
    # service type  private unpriv  chroot  wakeup  maxproc command + args
    #               (yes)   (yes)   (yes)   (never) (100)
    # ==========================================================================
    smtp      inet  n       -       -       -       -       smtpd
    #submission inet n       -       -       -       -       smtpd
    #  -o smtpd_tls_security_level=encrypt
    #  -o smtpd_sasl_auth_enable=yes
    #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #  -o milter_macro_daemon_name=ORIGINATING
    #smtps     inet  n       -       -       -       -       smtpd
    #  -o smtpd_tls_wrappermode=yes
    #  -o smtpd_sasl_auth_enable=yes
    #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #  -o milter_macro_daemon_name=ORIGINATING
    #628      inet  n       -       -       -       -       qmqpd
    pickup    fifo  n       -       -       60      1       pickup
    cleanup   unix  n       -       -       -       0       cleanup
    qmgr      fifo  n       -       n       300     1       qmgr
    #qmgr     fifo  n       -       -       300     1       oqmgr
    tlsmgr    unix  -       -       -       1000?   1       tlsmgr
    rewrite   unix  -       -       -       -       -       trivial-rewrite
    bounce    unix  -       -       -       -       0       bounce
    defer     unix  -       -       -       -       0       bounce
    trace     unix  -       -       -       -       0       bounce
    verify    unix  -       -       -       -       1       verify
    flush     unix  n       -       -       1000?   0       flush
    proxymap  unix  -       -       n       -       -       proxymap
    proxywrite unix -       -       n       -       1       proxymap
    smtp      unix  -       -       -       -       -       smtp
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops
    relay     unix  -       -       -       -       -       smtp
        -o smtp_fallback_relay=
    #       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq     unix  n       -       -       -       -       showq
    error     unix  -       -       -       -       -       error
    retry     unix  -       -       -       -       -       error
    discard   unix  -       -       -       -       -       discard
    local     unix  -       n       n       -       -       local
    virtual   unix  -       n       n       -       -       virtual
    lmtp      unix  -       -       -       -       -       lmtp
    anvil     unix  -       -       -       -       1       anvil
    scache    unix  -       -       -       -       1       scache
    #
    # ====================================================================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # Many of the following services use the Postfix pipe(8) delivery
    # agent.  See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ====================================================================
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    #
    maildrop  unix  -       n       n       -       -       pipe
      flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
    #
    # See the Postfix UUCP_README file for configuration details.
    #
    uucp      unix  -       n       n       -       -       pipe
      flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    #
    # Other external delivery methods.
    #
    ifmail    unix  -       n       n       -       -       pipe
      flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp     unix  -       n       n       -       -       pipe
      flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
    scalemail-backend unix    -    n    n    -    2    pipe
      flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
    mailman   unix  -       n       n       -       -       pipe
      flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
      ${nexthop} ${user}
    
    amavis unix - - - - 2 smtp
            -o smtp_data_done_timeout=1200
            -o smtp_send_xforward_command=yes
    
    127.0.0.1:10025 inet n - - - - smtpd
            -o content_filter=
            -o local_recipient_maps=
            -o relay_recipient_maps=
            -o smtpd_restriction_classes=
            -o smtpd_client_restrictions=
            -o smtpd_helo_restrictions=
            -o smtpd_sender_restrictions=
            -o smtpd_recipient_restrictions=permit_mynetworks,reject
            -o mynetworks=127.0.0.0/8
            -o strict_rfc821_envelopes=yes
            -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
            -o smtpd_bind_address=127.0.0.1
    
     
  5. LePrince

    LePrince New Member

    Hi,

    I replaced my master.cf with your master.cf and everything works! No errors and all mail moves just as it is supposed to.

    Thank you very much. I really couldn't do it without your help.

    And here's the end of my old master.cf:

    Code:
    127.0.0.1:10025 inet	n	-	n	-	-	smtpd
        Â*o content_filter=
        -o local_recipient_maps=
        -o relay_recipient_maps=
        -o smtpd_restriction_classes=
        -o smtpd_client_restrictions=
        -o smtpd_helo_restrictions=
        -o smtpd_sender_restrictions=
        -o smtpd_recipient_restrictions=permit_mynetworks,reject
        -o mynetworks=127.0.0.0/8
        -o strict_rfc821_envelopes=yes
        -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
        -o smtpd_bind_address=127.0.0.1
    Obviously this is the problem:
    Code:
        Â*o content_filter=
    but for some reason, it's not visible when I look at the master.cf inside a linux machine - I saw it now when I copied the file to my laptop. Then I copied the file back to linux machine and again it appeared as "-o content_filter=" when I viewed the file with either vi or mc editor.

    Some sort of character set translation issue I guess.
     
    Last edited: Jun 13, 2008
  6. thecaoticone

    thecaoticone New Member

    Glad you got it working without a re-install!
     

Share This Page