Virtual Users And Domains With Postfix, Courier, And SquirrelMail Ubuntu 8.04

Discussion in 'HOWTO-Related Questions' started by flipb18b, Jun 3, 2008.

  1. flipb18b

    flipb18b New Member

    Everything seems to be working fine but when I attempt to log int to SquirrelMail
    It just goes to a blank page. Also I am unable to sent email to any other domain other then my own via outlook for thunderbird I have enable to logging into the my out going server. Any information would be great thanks
     
  2. falko

    falko Super Moderator

    Are there any errors in your logs?
     
  3. mikeyr

    mikeyr New Member

    I forget which one it was, I had a typo in one of the 4 files you have to create. I am sorry I don't remember which one it was, for me I had made a typo in the select statement, I found it by looking in the log files.

    Once I fixed it, squirrelmail worked fine.
     
  4. flipb18b

    flipb18b New Member

    Where would I see the Logs for SQ Mail?
    As far as the Regular mail log goes it looks like this at the end

    Jun 5 21:08:35 mail imapd: LOGIN, user=flip@willthatdo.com, ip=[::ffff:127.0.0.1], port=[50922], protocol=IMAP
    Jun 5 21:08:35 mail imapd: LOGOUT, user=flip@willthatdo.com, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=30, sent=238, time=0

    Does this mean I'm logging out right when I sign in?

    Also When I try to send VIA Outlook i receive this error flipb18b@gmail.com>: Relay access denied
     
    Last edited: Jun 6, 2008
  5. celltek2006

    celltek2006 New Member

    server tutorial help needed

    Hi,

    I had tried to install ubuntu server 8.04 LTS but without success. I could not able to host my web site, can you please help me? I am really want to learn this but could not figure out how to. Please help I ahve the server up and running but could not config dns and isp config to host web site. My static IP 58.108.167.171, with D-link router gateway 192.168.0.1 and domain auhostserver.com.

    Thank you in advance!!!!!

    Jacky
     
  6. thecaoticone

    thecaoticone New Member

    flipb18b,
    I had a blank page issue as well. I posted how I fixed it here:

    http://www.howtoforge.com/forums/showthread.php?t=23797&page=2

    This may work for you.

    As for the login and logout, this standard for imap clients. They will only stay connected until the requested task is completed, then logout until the next requested task. (such as check mail, create a folder, delete mail, send mail, etc.) You may see many login / logout lines from the same user during a single session.
     
  7. flipb18b

    flipb18b New Member

    I still am unable to Send out mail Via outlook. The error is Relay access Denied
     
  8. thecaoticone

    thecaoticone New Member

    In the /var/log/mail.log relay error line, it should have something like this:


    Code:
    Relay access denied; from=<some_user@some_domain.com> to=<another_user@another_domain>
    is the "from=<>" your user_name@your_domain?
     
  9. flipb18b

    flipb18b New Member

    Jun 7 10:12:21 mail postfix/smtpd[26241]: connect from c-71-235-64-188.hsd1.ct.comcast.net[71.235.64.188]
    Jun 7 10:12:21 mail postfix/smtpd[26241]: NOQUEUE: reject: RCPT from c-71-235-64-188.hsd1.ct.comcast.net[71.235.64.188]: 554 5.7.1 <flipb18b@gmail.com>: Relay access denied; from=<flip@willthatdo.com> to=<flipb18b@gmail.com> proto=ESMTP helo=<desktop>
    Jun 7 10:12:23 mail pop3d: Connection, ip=[::ffff:71.235.64.188]
     
  10. thecaoticone

    thecaoticone New Member

    Is "Server requires authentication" enabled for the account?
     
  11. flipb18b

    flipb18b New Member

    When I attempt to send email with the server requires authentication enable it keeps asking me for a user name and password and it seems to never take the ones I provide.
    As for the Postfix Config

    #
    ifmail unix - n n - - pipe
    flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp unix - n n - - pipe
    flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
    scalemail-backend unix - n n - 2 pipe
    flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
    mailman unix - n n - - pipe
    flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
    ${nexthop} ${user}

    amavis unix - - - - 2 smtp
    -o smtp_data_done_timeout=1200
    -o smtp_send_xforward_command=yes

    127.0.0.1:10025 inet n - - - - smtpd
    -o content_filter=
    -o local_recipient_maps=
    -o relay_recipient_maps=
    -o smtpd_restriction_classes=
    -o smtpd_client_restrictions=
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,reject
    -o mynetworks=127.0.0.1/8
    -o strict_rfc821_envelopes=yes
    -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
    -o smtpd_bind_address=127.0.0.1
     
  12. thecaoticone

    thecaoticone New Member

    If I remember correctly, it has been quite a while, I had the same issues with pop3 clients in the 6.06 LTS guide. I keep thinking the relay and server authentication errors are both tied to the saslauthd file. I failed to make a note when I finally figured it out.

    You may want to double check the last line of /etc/default/saslauthd


    Code:
    OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"

    I believe my problem was I missed the "-r" at the end.
     
  13. flipb18b

    flipb18b New Member

    Still will not authenticate / Send mail
     
  14. falko

    falko Super Moderator

    What's in the mail log now when you try to send an email?
     
  15. flipb18b

    flipb18b New Member

    Jun 9 17:21:20 mail pop3d: LOGOUT, user=flip@willthatdo.com, ip=[::ffff:69.37.80.21], port=[17016], top=0, retr=0, rcvd=18, sent=130, time=1
    Jun 9 17:21:31 mail postfix/smtpd[11648]: connect from unknown[69.37.80.21]
    Jun 9 17:21:31 mail postfix/smtpd[11648]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Jun 9 17:21:31 mail postfix/smtpd[11648]: warning: unknown[69.37.80.21]: SASL LOGIN authentication failed: generic failure
    Jun 9 17:21:31 mail postfix/smtpd[11648]: disconnect from unknown[69.37.80.21]
    Jun 9 17:21:42 mail postfix/smtpd[11651]: connect from unknown[69.37.80.21]
    Jun 9 17:21:43 mail postfix/smtpd[11651]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Jun 9 17:21:43 mail postfix/smtpd[11651]: warning: unknown[69.37.80.21]: SASL LOGIN authentication failed: generic failure
    Jun 9 17:21:43 mail postfix/smtpd[11651]: disconnect from unknown[69.37.80.21]
    Jun 9 17:21:56 mail postfix/smtpd[11648]: connect from unknown[69.37.80.21]
    Jun 9 17:21:56 mail postfix/smtpd[11648]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Jun 9 17:21:56 mail postfix/smtpd[11648]: warning: unknown[69.37.80.21]: SASL LOGIN authentication failed: generic failure
    Jun 9 17:21:56 mail postfix/smtpd[11648]: disconnect from unknown[69.37.80.21]
     
  16. flipb18b

    flipb18b New Member

    Ok so I figured out from reading that log that I needed to enable to sslauth
    Still though mail does not pass through my log now reads when trying to send

    tup -- throttling
    Jun 9 17:26:46 mail amavis[10749]: (10749-18) (!)FWD via SMTP: <flip@willthatdo.com> -> <flipb18b@gmail.com>, 451 4.5.0 From MTA([127.0.0.1]:10025) during fwd-connect (Negative greeting: at (eval 84) line 442, <GEN21> line 599.): id=10749-18
    Jun 9 17:26:46 mail amavis[10749]: (10749-18) Blocked MTA-BLOCKED, [69.37.80.21] [69.37.80.21] <flip@willthatdo.com> -> <flipb18b@gmail.com>, Message-ID: <000401c8ca78$c0cd1090$4d00a8c0@ntwrk.net>, mail_id: 7Tmeiw9zhPJC, Hits: -, size: 3843, 1085 ms
    Jun 9 17:26:46 mail postfix/smtp[11711]: E158D36C682: to=<flipb18b@gmail.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=1.2, delays=0.12/0/0/1.1, dsn=4.5.0, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 From MTA([127.0.0.1]:10025) during fwd-connect (Negative greeting: at (eval 84) line 442, <GEN21> line 599.): id=10749-18 (in reply to end of DATA command))
    Jun 9 17:26:46 mail postfix/master[18527]: warning: process /usr/lib/postfix/smtpd pid 11716 exit status 1
    Jun 9 17:26:46 mail amavis[10741]: (10741-19) (!)FWD via SMTP: <flip@willthatdo.com> -> <flipb18b@gmail.com>, 451 4.5.0 From MTA([127.0.0.1]:10025) during fwd-connect (Negative greeting: at (eval 84) line 442, <GEN21> line 590.): id=10741-19
    Jun 9 17:26:46 mail amavis[10741]: (10741-19) Blocked MTA-BLOCKED, [69.37.80.21] [69.37.80.21] <flip@willthatdo.com> -> <flipb18b@gmail.com>, Message-ID: <000901c8ca78$c0de0080$4d00a8c0@ntwrk.net>, mail_id: vjPFvx-Gdoco, Hits: -, size: 3826, 1084 ms
    Jun 9 17:26:46 mail postfix/smtp[11714]: 466DE36C689: to=<flipb18b@gmail.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=1.2, delays=0.12/0/0/1.1, dsn=4.5.0, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 From MTA([127.0.0.1]:10025) during fwd-connect (Negative greeting: at (eval 84) line 442, <GEN21> line 590.): id=10741-19 (in reply to end of DATA command)
     
  17. thecaoticone

    thecaoticone New Member

    Is there a line in you log files that looks like this?

    Code:
    fatal: parameter 
    Also double your /etc/postfix/master.cf for the line:

    -o mynetworks=127.0.0.1/8

    In mine it reads:


    -o mynetworks=127.0.0.0/8
     
    Last edited: Jun 10, 2008

Share This Page