Virtual Users And Domains With Postfix, Courier And MySQL

Discussion in 'Server Operation' started by Mathias, Jun 7, 2007.

  1. Mathias

    Mathias ISPConfig Developer ISPConfig Developer

  2. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in the mail log (/var/log/mail.log)?

    Please make sure that /etc/courier/authmysqlrc looks exactly as in the tutorial. Courier is very finicky about the format (whitespace, etc.). Also, you must have authmodulelist="authmysql" in /etc/courier/authdaemonrc.
  3. bayuadhi

    bayuadhi New Member

    i have the same problem with Mathias. installation was smooth but can't log either. can't log using pop3 and can't log using imap.

    tried to log via telnet localhost 110 and telnet localhost 143 but no luck either.

    btw, my mysql always gives different output when i execute "select encrypt('secret')", so i change the MYSQL_CRYPT_PWFIELD to MYSQL_CLEAR_PWFIELD in /etc/courier/authmysqlrc. but it's no luck either.

    i'm using edgy, mysql 5, postfix 2.3.3

    any help would be highly appreciated.

    btw, here's the error log:

    Last edited: Jun 23, 2007
  4. falko

    falko Super Moderator ISPConfig Developer

    You must send an email first to a new account before you can fetch the mails with POP3/IMAP. Maildir is created when the first email arrives.
  5. bayuadhi

    bayuadhi New Member

    thanks for the reply.

    i did the following:

    it's deliberate to send email to new user which i haven't add to the mysql table. just wanna test whether the virtual user on mysql is working or not.

    then, i created the user on mysql table and did the following:

    conclusion: the virtual user on mysql works.

    but, when i test the pop3 and imap, it still gives me the same error message.

    btw, can you give me the /home/vmail looks like? thanks.
  6. falko

    falko Super Moderator ISPConfig Developer

    Have you double-checked that your Courier configuration looks exaclty as in the tutorial? Courier is very finicky about the formatting.

    Should be like this:
  7. zeVeNoM

    zeVeNoM New Member

    Hi there,

    I have an issue with (i think) postfix, it seems that i have misconfigured something, but i don't know where i could search.

    If i try to send a mail to a newly created mailbox, i get a mail back which tells me, that the mailbox is full:

    It doesn't matter if i send a mail to a forwarded or real adress. Anyway, to make it weird: I tried to send a mail through telnet, and this worked. So the mail System itself works properly. It's just something with the quota plug-in i think, and like i said: i have no clue where i have to search for a misconfiguration. Any hints for me?
  8. zeVeNoM

    zeVeNoM New Member

    Hi again,

    pls forget what i wrote, i just remembered that i didn't set my MX DNS entries @ domain configuration ;)

Share This Page