Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, ...

Discussion in 'HOWTO-Related Questions' started by mho, Feb 29, 2008.

  1. mho

    mho New Member

    Hello there.

    I have a serious problem. I'm trying to make this setup on a debian etch (your perfect setup guide..)

    First of all I tried apt-get install ... but it seems like the courier-authmysql is renamed as another name, courier-libauth-mysql or something related.

    Then I tried the aptitude install wayish. This worked first time. Got the blue screen, (setup) and the install was happening.

    But when the install tries to setup courier-pop and pop-ssl, it comes with a failure.

    Starting Courier POP3 server:bind: Address already in use
    ll_daemon_start: Resource temporarily unavailable
    invoke-rc.d: initscript courier-pop, action "start" failed.
    dpkg: fejl under behandling af courier-pop (--configure):
     underproces post-installation script returnerede afslutningsstatus 1
    dpkg: afhængighedsproblemer forhindrer konfiguration af courier-pop-ssl:
     courier-pop-ssl afhænger af courier-pop, men:
      Pakken courier-pop er ikke sat op endnu.
    dpkg: fejl under behandling af courier-pop-ssl (--configure):
     afhængighedsproblemer - efterlader den ukonfigureret
    Der opstod fejl under behandlingen:
    * In english, this says that the courier-pop isn't configuret. I then tries apt-get install courier-pop courier-pop-ssl but this give me the same arror as above and this one.
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    My netstat -a -n says:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State
    tcp        0      0*               LISTEN
    tcp        0      0   *               LISTEN
    tcp        0      0   *               LISTEN
    tcp        0      0    *               LISTEN
    tcp        0      0 *               LISTEN
    tcp        0      0   *               LISTEN
    tcp        0      0    *               LISTEN
    tcp        0      0    *               LISTEN
    And this is netstat -tap:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost:mysql         *:*                     LISTEN     2321/mysqld
    tcp        0      0 *:pop3                  *:*                     LISTEN     30140/tcpserver
    tcp        0      0 *:sunrpc                *:*                     LISTEN     1949/portmap
    tcp        0      0 *:www                   *:*                     LISTEN     30197/apache
    tcp        0      0 *:58160                 *:*                     LISTEN     2804/rpc.statd
    tcp        0      0 *:auth                  *:*                     LISTEN     2631/inetd
    tcp        0      0 *:ftp                   *:*                     LISTEN     13680/pure-ftpd (SE
    tcp        0      0 *:smtp                  *:*                     LISTEN     19855/tcpserver
    tcp6       0      0 *:imaps                 *:*                     LISTEN     510/couriertcpd
    tcp6       0      0 *:pop3s                 *:*                     LISTEN     5366/couriertcpd
    tcp6       0      0 *:imap2                 *:*                     LISTEN     463/couriertcpd
    tcp6       0      0 *:ftp                   *:*                     LISTEN     13680/pure-ftpd (SE
    tcp6       0      0 *:ssh                   *:*                     LISTEN     2743/sshd
    tcp6       0   1184   0x55513f8c.adsl.c:10317 ESTABLISHED29433/0
    I'm really lost right now, tried google but with no luck.

    Can/would anyone help my out, I hope the above information is good enough or else ask for more.

    Have a nice weekend.

    From Mikkel, Roskilde - Denmark
  2. topdog

    topdog Active Member HowtoForge Supporter

    it seems like your are already running another pop3 server via inetd you possibly need to disable that before reconfiguring.
  3. mho

    mho New Member

    I'm not so deep into linux, could you tell me howto find that pop3 server.

    I found a Qmail device, but used apt-get remove to .. remove it. It's not my server, and the owner dosen't know which mailserver is running twice.
    Either do I.

    Give me a little clue please :)

    Thanks for quick answer.
  4. falko

    falko Super Moderator ISPConfig Developer

    apt-get update
    and try to install Courier again. If that doesn't help - what's in /etc/apt/sources.list?
  5. mho

    mho New Member

    Well, I tried something else. Removed something called php-auth. After that, courier-pop and pop-ssl started to configuring.

    I think I am at the right path now, telnet localhost pop3 works now and the last chapter in the guide, about the list of 250's - this works also very nice.

    Thx for quick answers and a very well written guide.

    Hav a nice day.

Share This Page