Virtual Users And Domains With Postfix, Courier And MySQL - Postfix Problems

Discussion in 'HOWTO-Related Questions' started by rculley, Jan 23, 2007.

  1. rculley

    rculley New Member

    Having followed the Virtual Users And Domains With Postfix, Courier And MySQL howto on FC several times I still keep getting the same problem. If I do "echo test | mail" the mail folders are created fine and I can login and view the mail no problem.

    However, if I try to send the mail from another network to the domain on this server it never arrives and there's no log of it in maillog! In BIND I have the MX record for the domain configured as follows: IN MX 10

    and an A record pointing the FQDN to the IP: IN A ip.ip.ip.ip

    Everything else is working fine on the server - Apache, MySQL etc and mail sends to other networks OK.

    My /etc/postfix/ file is as follows (some standard commented lines removed):-


    queue_directory = /var/spool/postfix
    command_directory = /usr/sbin
    daemon_directory = /usr/libexec/postfix
    mail_owner = postfix
    inet_interfaces = all
    mydestination = localhost, localhost.localdomain
    unknown_local_recipient_reject_code = 550
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    debug_peer_level = 2
    debugger_command =
    xxgdb $daemon_directory/$process_name $process_id & sleep 5
    sendmail_path = /usr/sbin/sendmail.postfix
    newaliases_path = /usr/bin/newaliases.postfix
    mailq_path = /usr/bin/mailq.postfix
    setgid_group = postdrop
    html_directory = no
    manpage_directory = /usr/share/man
    sample_directory = /usr/share/doc/postfix-2.3.3/samples
    readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
    myhostname =
    mynetworks =
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/, mysql:/etc/postfix/
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/
    virtual_mailbox_base = /home/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
    smtpd_use_tls = yes
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    transport_maps = proxy:mysql:/etc/postfix/
    virtual_create_maildirsize = yes
    virtual_mailbox_extended = yes
    virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/
    virtual_mailbox_limit_override = yes
    virtual_maildir_limit_message = "The user you are trying to reach is over quota."
    virtual_overquota_bounce = yes
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    content_filter = amavis:[]:10024
    receive_override_options = no_address_mappings


    I'm assuming that it's a DNS issue or something similar as mail addressed to the same address arrives if sent internally. The machine is directly connected to the Internet in a colocation datacentre configured with two public IPs and there are currently no firewalls blocking any ports.


    # Do not remove the following line, or various programs
    # that require network functionality will fail. localhost.localdomain localhost
    ip.ip.ip.ip domain

    I'd be really grateful of any help as it's been driving me crazy the last two days!

    Last edited: Jan 23, 2007
  2. rculley

    rculley New Member

    Sorted, working now! I was sending from an old server which used to have the domain configured on it so it was just spooling internally! :rolleyes:

Share This Page