Virtual Users And Domains With Postfix, Courier And MySQL (Fedora Core 5)

Discussion in 'HOWTO-Related Questions' started by sapphire327, Dec 20, 2006.

  1. sapphire327

    sapphire327 New Member

    I worked through this tutorial step by step, and successfully installed everything on a Fedora 5 VMware system. I then proceeded to go through the tutorial again on my actual server, and I ran into a problem:

    This is what shows up in /var/log/maillog
    These three lines appear repeatedly in the log file, and running a tail -f on it shows that they appear roughly every minute, and not in response to me trying to connect to port 25.

    Trying to telnet to port 25 just disconnects me, or doesn't show the ESMTP greeting line.

    The problem I am having is that I followed the directions exactly, and it worked the first time, and didn't work the second. I also re-installed my live server, and ran through the tutorial again, thinking I may have missed a step, but it still didn't work.

    My config files look exactly like they do in the tutorial, and they also look the same as they do on my VMware server. SElinux is disabled.

    If I disable SASL authentication in postfix, by entering postconf -e 'smtpd_sasl_auth_enable = no', then I can connect to the server and send a message successfully. However, I need SMTP authentication support, so I want to get this working.

    I have looked through other forum posts, but everyone else's problems are different from mine. Can anybody offer an explanation?


    Aaron Parecki
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is SASL started?
  3. sapphire327

    sapphire327 New Member

    Thanks for replying. Yes, it is started, though.
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in /usr/lib/sasl2/smtpd.conf? What's the output of
    uname -m
  5. sapphire327

    sapphire327 New Member

    This is the output. It is the same on both the working and the not working computers.

  6. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/postfix/ (please strip out the comments)?
  7. sapphire327

    sapphire327 New Member

    Thanks, here it is.

  8. falko

    falko Super Moderator ISPConfig Developer

    Is this in one line?

    Please run
    postconf -e 'smtpd_sasl_local_domain ='
    /etc/init.d/postfix restart
  9. sapphire327

    sapphire327 New Member

    yes, it is all on one line.

    I ran

    postconf -e 'smtpd_sasl_local_domain ='
    /etc/init.d/postfix restart

    but still the same problem.

    Is it a problem that authdaemond does not show up in that list? I tried changing the pwcheck_method in /usr/lib/sasl2/smtpd.conf to shadow, but that didn't help.

    Also please note that at the moment, does not actually point to this machine. I can give you access to my machine directly if you think you would be able to solve this faster that way, then post the solution to the forum. My machine is a VPS, so I can easily restore it back to the current state for any reason.
  10. falko

    falko Super Moderator ISPConfig Developer

  11. sapphire327

    sapphire327 New Member

    I did not do anything special as far as setting up Fedora Core 5. Fedora came installed on the VPS. I first verified that SElinux was disabled, then proceeded with installing packages as described on the first page.

    Here is a snippet of my history file:
    (I chose not to install PHPmyadmin)

    I got it working!! I just noticed bsquare's comments at the bottom of the first page of the tutorial. I needed to install cyrus-sasl-plain. After that, everything works perfectly! I would suggest updating the tutorial.

    Thank you for the wonderful tutorial!


Share This Page