Virtual Users And Domains With Postfix, Courier And MySQL (Fedora Core 5)

Discussion in 'Server Operation' started by broyce66, Oct 12, 2006.

  1. broyce66

    broyce66 New Member

    I followed this tutorial "Virtual Users And Domains With Postfix, Courier And MySQL (Fedora Core 5)". The goal was to setup email accounts for my different domains. I put one in and am trying to configure outlook to check it but nothing works.

    I also ran into a problem with this mysqladmin -h server1.example.com -u root password yourrootsqlpassword
    for some reason - I could not get this to work - I can connect the other way but this is not working.


    I am wondering if there is a way to test to make sure that I did everything correctly?

    I am also a bit confused by the hostname in /etc/hosts?
    192.168.0.100 server1.example.com server1

    I dont understand the second part if my domain is example.com then what is the first part server1? I dont understand and I am wondering if this is the problem. Should server1 be mail?

    Lastly - I need help on configuring the mail client. I have tired and I cant seem to get it to work. It seemed like it was able to send but I never received the email. For the username I am using just the name and for the incoming mail server I am using mydomain.com. I have tried enambling ssl on the out going mail server and that works it even pulls the cert but for some reason I am not able to get the supposedly sent email.
     
    Last edited: Oct 12, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you replace server1.example.com with your own hostname? What's the output of
    Code:
    netstat -tap
    ?


    You must use your own hostname here. server1.example.com is just an example. Your hostname could be something like mail.yourdomain.com, www.yourdomain.com, etc.

    It must be an email address.
    Use the IP address for now to rule out DNS problems.

    Undo it until everything else works.
    Make sure you enable "Server requires authentication." in your email client.
     
  3. broyce66

    broyce66 New Member

    Different Problem

    I think at this point I have gotten to the point were everything is working except that I am wondering about the mynetworks portion of the postfix setup. Also the box is a not on my network - it is located at the hosts place.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Always put
    Code:
    mynetworks = 127.0.0.0/8
    into /etc/postfix/main.cf. This means that only localhost (the server itself) can send without authentication, everyone else must authenticate. This way you make sure that thesystem is not abused by spammers (unless a spammer finds out a valid username and password).
     

Share This Page