Virtual Users And Domains With Postfix, Courier And MySQL (Debian Etch)

Discussion in 'HOWTO-Related Questions' started by kdclaver, Jul 18, 2007.

  1. klonos

    klonos New Member

    Didn't know about these commands. Googled a bit and found out about them. This proves troubleshooting one of the best ways to dig deep into Linux (..or almost everything in general) and learn more.

    Anyways, nothing is diplayed, so I guess there is no file by that name on my system.

    Searching for dcc though spits:

    Hope I've helped you in helping me.

    Thank you for your time.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you post the full error message from mail.err (incl. the date and the application that logged it)?
     
  3. klonos

    klonos New Member

    Sure, here it is:
    By the way, what about that fatal error about non-null host address bits? I recall setting a 192.168.1.0/8 in the postfix main.cf but realized this was wrong and should be replaced with 192.168.1.0/24. Finaly, I removed this entry completely and have no more such entries since then. So, is it something I can safelly ignore?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Can you try this?
    Code:
    mkdir -p /var/run/dcc
    Then restart DCC. Does /var/run/dcc/dccifd.pid exist then?
     
  5. klonos

    klonos New Member

    Ok, dir created. Then I do:

    dir is empty. After restarting the server:

    Tried the procedure twice, just to make sure. Same resaults. How does this dir get autodeleted??
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Is there maybe anything in the DCC inti scripts that deletes the directory?
     
  7. klonos

    klonos New Member

    I am not sure in which files to look in. Here is a list of any dcc related files (I have included an attachment with the ones in bold):

    Please take a look at them and see if there is some command that could be deleting the file. In case I got the wrong files, please point me to the right ones.

    ... Just an idea... is there any way I could do a search for files containing the string "dccifd.pid"? If yes, could you please provide the command.
     

    Attached Files:

    • dcc.zip
      File size:
      5.5 KB
      Views:
      198
  8. CavalierDeVache

    CavalierDeVache New Member

    I got rid of the dccifd.pid not found error in Ubuntu by removing the line comment to enable DCC in /etc/spamassassin/v310.pre then used this in /etc/spamassassin/local.cf
    Code:
    # Enable DCC
    use_dcc 1
    dcc_home /var/lib/dcc
    dcc_add_header 1
     
  9. klonos

    klonos New Member

    Ok, tried that as well CavalierDeVache. This is what is see in my mail.log after reboot:

    Also mail.err:

    What do you make of that guys?

    ...By the way:

    So, once again I tried creating the directory as falco suggested:

    reboot and:

    once again deleted.

    Waiting for any more ideas as to what to try next. Thank you all.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    What's in your /etc/spamassassin/local.cf now?
     
  11. klonos

    klonos New Member

    /etc/spamassassin/local.cf:

    and /etc/spamassassin/v31o.pre:

    [...]
     
  12. CavalierDeVache

    CavalierDeVache New Member

    Hello again.

    After I thought I had mine all working, it actually wasn't. Although everything looked all right in the log files, the eicar test files and spam samples from my gmail account passed right on through, plus SPF (I had installed it earlier following another tutorial here) was not checking reverse DNS while this whole dog and pony show was running. So I reverted everything back to my original working configuration from backups and went on a documentation quest.

    It turns out that in Spamassasin 3.1.x /spamassassin/local.cf is deprecated, these tools should be loaded as modules in /spamassassin/v31o.pre. I ended up using the Ubuntu guide at https://help.ubuntu.com/community/PostfixAmavisNew to start over with, but then ran into a problem with amavis not accepting connections, this turned out to be a problem with postfix using a newer format of configuration files than what I had on my server as documented here http://postfix.bestmx.eu/postfix-release/official/postfix-2.1.6.RELEASE_NOTES

    So I shut down amavis and postfix, then ran "postfix upgrade-configuration" to repair errors in the config files, plus it added some postfix services I was missing, started amavis, then postfix back up and all is well here now.

    I am running Ubuntu 6.06.1 LTS server
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Can you comment out
    Code:
    loadplugin Mail::SpamAssassin::Plugin::DCC
    in /etc/spamassassin/v31o.pre and try again?
     
  14. klonos

    klonos New Member

    Yes falko, you are right. Cavalier asked me to do so in the first place and I did not. I did it this time but the issue is still there.

    Both configurations seem to somehow delete the dir after a reboot. Restarting amavis or/and postfix doesn't delete the directory though. It seems that the thought you had that maybe a startup script is deleteing the dir is correct. Or it could be something during shutdown.

    Can you help me locate this script? How can I look for files containing the string "dcc" in my filesystem?

    By the way... amavis and postfix seem to work properly and also I have the report in my mail.log every 24h saying:

     
  15. falko

    falko Super Moderator ISPConfig Developer

    You can try this:
    Code:
    cd /
    grep -R dcc *
    This can take some time if you have a big HDD and/or lots of files...
     
  16. asejua

    asejua New Member

    Mail Loops back to myself error madness

    Hello,

    first of all, great howto, pretty easy to follow :) gratz!

    I'm having a bit of trouble with the "mail for host.server.org loops back to myself" error. After reading too much documentation about this trying to fix I've decided to ask you :)

    Obviously the problem is that any mail (from inside or outside the server) I send to any user 'at' virtualhost 'dot' org gets that error and bounces back

    Here's my configuration (deleted dates for clear reading :D):

    Code:
    BIND DNS Registers for : server.org.db
    --------------------------------------
    @                    IN  	SOA ns.server.org.  root.localhost 
    							( [...serial, retry, etc... ] )
    server.org.          IN      NS      ns1.server.org.
    server.org.          IN      A       192.168.0.20
    mail.server.org.     IN      A       192.168.0.20
    hostname			 IN      A       192.168.0.20
    
    BIND DNS Registers for : virtualhost.org.db
    -------------------------------------------
    @               	IN  	SOA ns.virtualhost.org.  root.localhost 
    							( [...serial, retry, etc... ] )
    virtualhost.org.    IN      NS      ns1.virtualhost.org.
    virtualhost.org.    IN      A       192.168.0.20
    virtualhost.org.    IN      MX      10      mail.server.org.
    hostname        	IN		A   	192.168.0.20
    
    Data in domains table
    ---------------------
    virtualhost.org
    
    Data in transport table
    -----------------------
    virtualhost.org		smtp:mail.server.org
    
    Data in users table
    -------------------
    [email protected]	<password>	<quota>
    
    
    Relevant data in main.cf
    ------------------------
    myhostname = mail.server.org
    myorigin = mail.server.org
    mydomain = server.org
    mydestination = $myhostname, $mydomain, localhost.$mydomain, localhost.localdomain
    
    Error log when trying to send mail locally with myuser user to [email protected]
    (happens also with any mail received from outside, from gmail for example...)
    -----------------------------------------------------------------------------------------
    
    postfix/pickup[6020]: 165E917914: uid=1000 from=<testuser>
    postfix/cleanup[6033]: 165E917914: message-id=<[email protected]>
    postfix/qmgr[6021]: 165E917914: from=<[email protected]>, size=321, nrcpt=1 (queue active)
    postfix/smtpd[6041]: connect from localhost.localdomain[127.0.0.1]
    postfix/smtpd[6041]: 3A440766D: client=localhost.localdomain[127.0.0.1]
    postfix/cleanup[6033]: 3A440766D: message-id=<[email protected]>
    postfix/qmgr[6021]: 3A440766D: from=<[email protected]>, size=790, nrcpt=1 (queue active)
    postfix/smtpd[6041]: disconnect from localhost.localdomain[127.0.0.1]
    amavis[4820]: (04820-03) Passed CLEAN, <[email protected]> -> <[email protected]>, Message-ID: <[email protected]>, mail_id: 0RKTcnXMuzbS, Hits: 0.249, queued_as: 3A440766D, 2077 ms
    postfix/smtp[6036]: 165E917914: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=2.5, delays=0.28/0.03/0.01/2.1, dsn=2.6.0, status=sent (250 2.6.0 Ok, id=04820-03, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 3A440766D)
    postfix/qmgr[6021]: 165E917914: removed
    [COLOR="Red"]postfix/smtp[6044]: 3A440766D: to=<[email protected]>, relay=none, delay=0.18, delays=0.07/0.1/0.01/0, dsn=5.4.6, status=bounced (mail for mail.server.org loops back to myself)[/COLOR]
    postfix/cleanup[6033]: 6E62B25C77: message-id=<[email protected]>
    postfix/qmgr[6021]: 6E62B25C77: from=<>, size=2618, nrcpt=1 (queue active)
    postfix/bounce[6045]: 3A440766D: sender non-delivery notification: 6E62B25C77
    postfix/qmgr[6021]: 3A440766D: removed
    postfix/local[6047]: 6E62B25C77: to=<[email protected]>, relay=local, delay=0.1, delays=0.02/0.03/0/0.04, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSION")
    postfix/qmgr[6021]: 6E62B25C77: removed
    Guess it's a DNS error, but after doing thousands of tryouts without success... well... Can you help me? ^
     
  17. falko

    falko Super Moderator ISPConfig Developer

    Please add host.server.org to the mydestination line in /etc/postfix/main.cf and restart Postfix.
     

Share This Page