Virtual Users And Domains With Postfix, Courier And MySQL (CentOS 5.1)

Discussion in 'HOWTO-Related Questions' started by nacef, Jul 31, 2008.

  1. nacef

    nacef New Member

    Hi all,

    I am trying to set a mail server with this tutorial and it worked just great for me. There is although one thing that I am trying and I can't get it to work.

    The virtual domain that I have configured on my server is registered at my ISP and I have some email adresses registered at the ISP on this domain. What I want to have on my server is some other email accounts with the same domain name and keep my old accounts on the ISP server, and I want them to be able to send emails to each other semlessly.
    I will give an example :
    on my ISP server I have these accounts : [email protected] and [email protected]
    On my local server I want to have the same domain mydomain.com as a virtual domain and create user3 and [email protected] and I want to be able to send from these local accounts to the external accounts.
    When I try to send something to an external account the server tells me :Recipient address rejected: User unknown in virtual mailbox table which is quite normal as it cannot find this address on my server but is there a way to make him go external through my relayhost when it doesn't find a registered account

    Thanks to all
     
  2. falko

    falko Super Moderator ISPConfig Developer

    You can try Postfix transports. See
    Code:
    man 5 transport
     
  3. nacef

    nacef New Member

    Hi falko,

    I have tried to add this transport rule in the transport table :
    domain = mydomain.com
    transport = smtp:my_isp_smtp_server

    But it seems that it doesn't work

    Any help ?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    I think the line should look like this:

    Code:
    mydomain.com smtp:my_isp_smtp_server
     
  5. nacef

    nacef New Member

    That' waht I did, I am using Mysql as a backend for my postfix. So I had to insert these values in the transport table. But now when I try to send to some external mail address, it keeps telling me that the user account could not be found as if it were a local account.

    So any clues ?
     

Share This Page