Virtual Users And Domains W/ Postfix, Courier and MySql + Squirrelmail prob

Discussion in 'HOWTO-Related Questions' started by kwinnuxbie, Oct 20, 2006.

  1. kwinnuxbie

    kwinnuxbie New Member

    Hello all , mr Newbie here.. I have a question. I want to set up (just as the title implies ) on a server that is also my FW/ Router, Web host etc.. Nothing Fancy.. This is my first attempt with a clean install. I was wondering if anyone can answer this.
    Is it super important to vi /etc/host with 192.168.0.1 server1.example.com server 1 (since that's what I use for local) as instructions say? Or can do I need to use the external... on the Hosts file?

    I have yet to do anything but yum update so I want to make sure I get it correct from the get go.. Not sure I understand it all but what better way to learn right??? :D

    I will wait a bit to...
    Thanks
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    It's not super-important. If you like, you can also put all your IP addresses in /etc/hosts.
     
  3. kwinnuxbie

    kwinnuxbie New Member

    Supper

    Thanks... I will do just that... :)
     
  4. kwinnuxbie

    kwinnuxbie New Member

    Still AHHHHHHHH

    Okay, I did take care of the erros that were poping. Now everything seemed fine.. I created a user etc.. I sent from my Laptop to it and from webmail and also sent to another account.. The emails went out ok (so I thought) but they are no where to be found... I am really confused here...:confused:

    My set up is modeled after the howto page with minor diff.. Well not so minor and perhaps that is my problem.. Anyway, here are the diffs..
    I created the home deirectory under a larger drive not /home/vmail.. /myurl/vmail. and I am using this system for every server need. That is http, ftp, samba, email and as a router.. All others are working except (samba) but I will start that after all is okay.
    By the way ( I am using FC5 64 ) I will post log files as soon as I know whic ones to look at.. or am asked to by some kind person with patients of a god... :eek: Well I will check back here again.. Thanks in advance
     
  5. kwinnuxbie

    kwinnuxbie New Member

    Oh I got my mail log

    here is my mail log I removed the host and names to protect the guilty :D I changed my host name.. did not want servewr1.myhost.com so I just made it myhost.com If anyone can tell me from here what is wrong then perhaps I can figure it out.. Having the answer will not make me cry either :D

    /usr/bin/unfreeze
    Oct 21 21:11:34 myhostnamehere amavis[2536]: Found decoder for .Z at /usr/bin/gzip -d
    Oct 21 21:11:34 myhostnamehere amavis[2536]: Found decoder for .gz at /usr/bin/gzip -d
    Oct 21 21:11:34 myhostnamehere amavis[2536]: Found decoder for .bz2 at /usr/bin/bzip2 -d
    Oct 21 21:11:34 myhostnamehere amavis[2536]: Found decoder for .lzo at /usr/bin/lzop -d
    Oct 21 21:11:34 myhostnamehere amavis[2536]: Found decoder for .rpm at /usr/bin/rpm2cpio
    Oct 21 21:11:34 myhostnamehere amavis[2536]: Found decoder for .cpio at /usr/bin/pax
    Oct 21 21:11:34 myhostnamehere amavis[2536]: Found decoder for .tar at /usr/bin/pax
    Oct 21 21:11:34 myhostnamehere amavis[2536]: Found decoder for .deb at /usr/bin/ar
    Oct 21 21:11:34 myhostnamehere amavis[2536]: Internal decoder for .zip
    Oct 21 21:11:34 myhostnamehere amavis[2536]: No decoder for .rar tried: rar, unrar
    Oct 21 21:11:34 myhostnamehere amavis[2536]: Found decoder for .arj at /usr/bin/arj
    Oct 21 21:11:34 myhostnamehere amavis[2536]: Found decoder for .arc at /usr/bin/nomarch
    Oct 21 21:11:34 myhostnamehere amavis[2536]: No decoder for .zoo tried: zoo, unzoo
    Oct 21 21:11:34 myhostnamehere amavis[2536]: No decoder for .lha tried: lha
    Oct 21 21:11:34 myhostnamehere amavis[2536]: Found decoder for .cab at /usr/bin/cabextract
    Oct 21 21:11:34 myhostnamehere amavis[2536]: No decoder for .tnef tried: tnef
    Oct 21 21:11:34 myhostnamehere amavis[2536]: Internal decoder for .tnef
    Oct 21 21:11:34 myhostnamehere amavis[2536]: Found decoder for .exe at /usr/bin/arj
    Oct 21 21:11:34 myhostnamehere amavis[2536]: Using internal av scanner code for (primary) ClamAV-clamd
    Oct 21 21:11:34 myhostnamehere amavis[2536]: Found secondary av scanner ClamAV-clamscan at /usr/bin/clamscan
    Oct 21 21:11:34 myhostnamehere imapd: bind: Address already in use
    Oct 21 21:11:34 myhostnamehere amavis[2536]: Creating db in /var/spool/amavisd/db/; BerkeleyDB 0.27, libdb 4.3
    Oct 21 21:11:34 myhostnamehere imapd-ssl: bind: Address already in use
    Oct 21 21:11:34 myhostnamehere pop3d: bind: Address already in use
    Oct 21 21:11:34 myhostnamehere pop3d-ssl: bind: Address already in use
    Oct 21 21:11:35 myhostnamehere sendmail[2573]: alias database /etc/aliases rebuilt by root
    Oct 21 21:11:35 myhostnamehere sendmail[2573]: /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total
    Oct 21 21:11:40 myhostnamehere postfix/postfix-script: starting the Postfix mail system
    Oct 21 21:11:40 myhostnamehere postfix/master[2619]: daemon started -- version 2.2.8, configuration /etc/postfix
    Oct 21 21:12:42 myhostnamehere dovecot: pop3-login: Login: user=<this_is_me>, method=PLAIN, rip=::ffff:192.168.0.8, lip=::ffff:24.38.113.154
    Oct 21 21:12:42 myhostnamehere dovecot: POP3(this_is_me): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Oct 21 21:12:44 myhostnamehere dovecot: pop3-login: Login: user=<this_is_me>, method=PLAIN, rip=::ffff:192.168.0.8, lip=::ffff:24.38.113.154
    Oct 21 21:12:44 myhostnamehere dovecot: POP3(this_is_me): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Oct 21 21:15:36 myhostnamehere dovecot: pop3-login: Login: user=<this_is_me>, method=PLAIN, rip=::ffff:192.168.0.8, lip=::ffff:24.38.113.154
    Oct 21 21:15:36 myhostnamehere dovecot: POP3(this_is_me): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Oct 21 21:18:43 myhostnamehere postfix/smtpd[3210]: connect from web56503.mail.re3.yahoo.com[66.196.97.32]
    Oct 21 21:18:43 myhostnamehere postfix/trivial-rewrite[3214]: warning: do not list domain myhostnamehere.com in BOTH mydestination and virtual_mailbox_domains
    Oct 21 21:18:43 myhostnamehere postfix/smtpd[3210]: 859382F72D6: client=web56503.mail.re3.yahoo.com[66.196.97.32]
    Oct 21 21:18:43 myhostnamehere postfix/cleanup[3219]: 859382F72D6: message-id=<20061022041841.50022.qmail@web56503.mail.re3.yahoo.com>
    Oct 21 21:18:43 myhostnamehere postfix/qmgr[2627]: 859382F72D6: from=<gwizrk@yahoo.com>, size=1751, nrcpt=1 (queue active)
    Oct 21 21:18:43 myhostnamehere postfix/smtpd[3210]: disconnect from web56503.mail.re3.yahoo.com[66.196.97.32]
    Oct 21 21:18:44 myhostnamehere amavis[2725]: (02725-01) (!)connect_to_sql: unable to connect to DSN 'DBI:mysql:database=mail;host=127.0.0.1;port=3306': Access denied for user 'mailmin'@'localhost' (using password: YES)
    Oct 21 21:18:44 myhostnamehere amavis[2725]: (02725-01) (!!)TROUBLE in process_request: connect_to_sql: unable to connect to any dataset at (eval 43) line 218, <GEN5> line 5.
    Oct 21 21:18:44 myhostnamehere amavis[2725]: (02725-01) (!)Requesting process rundown after fatal error
    Oct 21 21:18:44 myhostnamehere postfix/smtp[3220]: 859382F72D6: to=<this_is_me@myhostnamehere.com>, relay=127.0.0.1[127.0.0.1], delay=1, status=deferred (host 127.0.0.1[127.0.0.1] said: 421 4.3.2 Service shutting down, closing channel (in reply to RCPT TO command))
    Oct 21 21:20:16 myhostnamehere dovecot: imap-login: Login: user=<this_is_me>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
    Oct 21 21:20:16 myhostnamehere dovecot: IMAP(this_is_me): Disconnected: Logged out
    Oct 21 21:20:17 myhostnamehere dovecot: imap-login: Login: user=<this_is_me>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
    Oct 21 21:20:17 myhostnamehere dovecot: IMAP(this_is_me): Disconnected: Logged out
    Oct 21 21:20:17 myhostnamehere dovecot: imap-login: Login: user=<this_is_me>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
    Oct 21 21:20:17 myhostnamehere dovecot: IMAP(this_is_me): Disconnected: Logged out
    Oct 21 21:20:19 myhostnamehere dovecot: imap-login: Login: user=<this_is_me>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
    Oct 21 21:20:19 myhostnamehere dovecot: IMAP(this_is_me): Disconnected: Logged out
    Oct 21 21:20:20 myhostnamehere dovecot: imap-login: Login: user=<this_is_me>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
    Oct 21 21:20:20 myhostnamehere dovecot: IMAP(this_is_me): Disconnected: Logged out
    Oct 21 21:20:21 myhostnamehere dovecot: imap-login: Login: user=<this_is_me>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
    Oct 21 21:20:21 myhostnamehere dovecot: IMAP(this_is_me): Disconnected: Logged out
    Oct 21 21:20:22 myhostnamehere dovecot: imap-login: Login: user=<this_is_me>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
    Oct 21 21:20:22 myhostnamehere dovecot: IMAP(this_is_me): Disconnected: Logged out
    Oct 21 21:20:36 myhostnamehere dovecot: pop3-login: Login: user=<this_is_me>, method=PLAIN, rip=::ffff:192.168.0.8, lip=::ffff:24.38.113.154
    Oct 21 21:20:36 myhostnamehere dovecot: POP3(this_is_me): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Oct 21 21:22:03 myhostnamehere postfix/anvil[3213]: statistics: max connection rate 1/60s for (smtp:66.196.97.32) at Oct 21 21:18:43
    Oct 21 21:22:03 myhostnamehere postfix/anvil[3213]: statistics: max connection count 1 for (smtp:66.196.97.32) at Oct 21 21:18:43
    Oct 21 21:22:03 myhostnamehere postfix/anvil[3213]: statistics: max cache size 1 at Oct 21 21:18:43

    Thanks a billion
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Amavisd cannot connect to your MySQL database. Please check your amavisd.conf.

    Also, it seems as if you have some other processes running on the POP3 and IMAP ports:

    What's the output of
    Code:
    netstat -tap
    ?

    I strongly recommend to follow the tutorial as close as possible. Maybe it's a good idea to do a clean reinstall.
     
  7. kwinnuxbie

    kwinnuxbie New Member

    yes I though I might have to...

    Thanks. Here is netsat -tap. I might try to recover from this but fresh install might be best at this point...

    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdomain:10024 *:* LISTEN 2536/amavisd (maste
    tcp 0 0 localhost.localdomain:10025 *:* LISTEN 6024/master
    tcp 0 0 *:mysql *:* LISTEN 2484/mysqld
    tcp 0 0 *:39690 *:* LISTEN 2170/rpc.statd
    tcp 0 0 *:sunrpc *:* LISTEN 2151/portmap
    tcp 0 0 *:ndmp *:* LISTEN 2803/perl
    tcp 0 0 ridersnet.com:domain *:* LISTEN 2133/named
    tcp 0 0 24-38-113-154-st.los:domain *:* LISTEN 2133/named
    tcp 0 0 localhost.localdomai:domain *:* LISTEN 2133/named
    tcp 0 0 *:smtp *:* LISTEN 6024/master
    tcp 0 0 localhost.localdomain:rndc *:* LISTEN 2133/named
    tcp 0 0 24-38-113-154-st.losa:44670 fxp2.n0.dfw91.adelphia:http ESTABLISHED 6806/firefox-bin
    tcp 0 0 24-38-113-154-st.losa:44672 fxp2.n0.dfw91.adelphia:http ESTABLISHED 6806/firefox-bin
    tcp 0 0 24-38-113-154-st.losa:41339 a209-18-34-105.deploy.:http ESTABLISHED 6806/firefox-bin
    tcp 0 0 24-38-113-154-st.losa:42241 a209-18-34-110.deploy.:http ESTABLISHED 6806/firefox-bin
    tcp 0 0 24-38-113-154-st.losa:51164 po-in-f104.google.com:http ESTABLISHED 6806/firefox-bin
    tcp 0 0 *:imaps *:* LISTEN 2510/dovecot
    tcp 0 0 *:pop3s *:* LISTEN 2510/dovecot
    tcp 0 0 *:pop3 *:* LISTEN 2510/dovecot
    tcp 0 0 *:imap *:* LISTEN 2510/dovecot
    tcp 0 0 *:http *:* LISTEN 2651/httpd
    tcp 0 0 *:ftp *:* LISTEN 2631/proftpd: (acce
    tcp 0 0 *:ssh *:* LISTEN 2368/sshd
    tcp 0 0 *:https *:* LISTEN 2651/httpd

    Thanks
     
  8. kwinnuxbie

    kwinnuxbie New Member

    WOW it worked..

    I did have an error in amavisd.cnf (Wrong user name and password ) Advice well taken; I need to pay attention to things better... Also have created an account for it@mydomain.com but no receiving emails.. the regular account does have a /home/ but not IT does it need to be???

    So many thanks...
    At leat 1,000 per every bit of memory I have... :)
     

Share This Page